GroupWise client on openSUSE 10.3

GroupWise client on openSUSE 10.3

I need to precede this post with a bunch of disclaimers. This is not a supported configuration, it has not been tested by either GroupWise or SuSE engineering and I personally have not played with it enough to see if anything else is broken, however, it is possible to get the GroupWise client running on openSUSE 10.3.

When trying to install the RPM I got a number of dependency errors, so I installed:

Probably overkill, but it installed after adding all of those. Oh, and I had first added a bunch of 'community repositories' which I think these were installing from.  Once installed the GroupWise client still does not launch.

The last thing that you need to do is to modify /opt/novell/groupwise/client/bin/groupwise.   On the line after the first export enter:

The whole file now reads:
export LD_LIBRARY_PATH=/opt/novell/groupwise/client/lib:/opt/novell/groupwise/client/jre/lib/i386
/opt/novell/groupwise/client/bin/groupwise-bin "$@"

Save that file and launch the client again - it should now work.
Labels (1)


Some content on Community Tips & Information pages is not officially supported by Micro Focus. Please refer to our Terms of Use for more detail.
I only had to add the export line to mine. That may have been because I already added the repositories but I did not see anything else get installed
when I did the install. Seems to be working fine.
That's entirely possible. For a start I was installing the GroupWise Bonsai client, which may have different dependencies. I also did a pretty much Next...Next...Next install of openSUSE so you have have installed something else that autoadded the dependencies.
Worked for me just with the edit as well, but as you stated above it could be because i've installed a bunch of other software on here. Seems to work like a champ!
If you have compiz fusion active then groupwise starts but displays only a grey screen. To fix it, change the groupwise startup script to "/opt/novell/groupwise/client/bin/ -jvm=-Dawt.toolkit=sun.awt.motif.MToolkit"
Worked for me just with the edit too.
I had no openmotif rpm installed ...

Great cool solution.
Then it must be because I was installing the GroupWise Bonsai client. So, when you get your hands on that one you will know what you have to do 🙂
Where can I get the Groupwise Bonsai client?
You can't yet as it has not been released. We are targeting first half of '08
I have groupwise running on 10.2 with only the edit, no worries. It seems sluggish if I haven't used it for a while, but that is likely because of how I have my swappiness set.
I'm running OpenSUSE 10.3 x86_64 ... I seem to have developed an additional problem in that the binary that my workplace has is 32 bit. I can get the Groupwise initial menu, it creates the .Novell directory in my home directory, but at that point it hangs at "connecting . . . . " and doesn't give me the prompt to log in or give it connection settings for the groupwise servers. My coworker's is working on a previous build of SLED.

Any ideas?
Alex, You say that the release date of Bonsai has been pushed from November 07, to some time in the first 6 mths of 2008.....That's really bad news.....11 Schools that I know of in Melbourne, AU are already dumping GW over Xmas and going to the Dark Side... A six month delay in shipping will only fuel others to look elsewhere as well.... despite any argument I make..... Please stick a BMW M3 engine under desk and attempt to get the release out ASAP!
Off-topic but somewhat releated, has anyone gotten Mac OS X 10.5 (Leopard) working with any public release of the Mac Groupwise client?
Its a fine line that we have to walk. We have made the decision to be quality focused instead of date focused - the right decision in my opinion. Releasing a product that is not of the very best quality that we can make it is more damaging that slipping dates.
Run /opt/novell/groupwise/client/bin/groupwise from a terminal window and see what errors you get. Then look for a TID or in the forums to see if it's a known issue
Works also fine for me. The export line was just enough. Thanks
Cool! Just adding that EXPORT line fixed the issue.
WHERE/ HOW did you get that solution?!
I found that the later GroupWise 7.0.2 and beyond clients with Compiz-Fusion worked with an /opt/novell/groupwise/client/bin/groupwise like this:

export LD_LIBRARY_PATH=/opt/novell/groupwise/client/jre/lib/i386:${LD_LIBRARY_PATH}
/opt/novell/groupwise/client/bin/groupwise-bin "$@" -jvm=-Dawt.toolkit=sun.awt.motif.MToolkit

Anyone know if GW works ok with openSUSE 11?
Top Contributors
Version history
Revision #:
1 of 1
Last update:
‎2007-10-08 23:25
Updated by:
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.