Highlighted
Absent Member.
Absent Member.
1403 views

Auto archiving don't work

Hello.

With one of ´my users I've got a small problem, For the moment we're on GW2014 R2 Sp1.
The users mailbox is set to auto archiving mails after 180 days. The path is set correctly. Manual archiving works normal.
Running gwcheck don't solves this. I ran first check structure, then content.
I suppose that this comes with the upgrade from GW 2012 to GW 2014.

Any ideas to fix this?
Thanks in advance for your answers.

Regards

Dirk Emmermacher
Labels (1)
0 Likes
14 Replies
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: Auto archiving don't work

Hi Dirk,

It is my experience that if there is a single message that fails to archive the entire autoarchive process stalls/stops. Take a look at the GWCheck log file. In there should be a report on which item/items failed to archive. Sort those out and things should return to normal.

Please let us know how it goes.

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Auto archiving don't work

Good morning Laura.

Thanks for your answer. I checked the mailbox again. The only errors are this:
- checking Data records
1 FOLDER_RECORD (Universal Inbox)
163426 Execution record check
Problem 67- Outdated execution record, created on Nov 3, 2016
- Item 163426 deleted successfully
163498 Execution record check
Problem 67- Outdated execution record, created on Nov 4, 2016
- Item 163498 deleted successfully
163502 Execution record check
Problem 67- Outdated execution record, created on Nov 4, 2016
- Item 163502 deleted successfully

This errors don't have to do with the error.
What's about harder repair options like strucural rebuild or rebuild user database?

Regards from Hannover

Dirk
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: Auto archiving don't work

Hi Dirk,

A "rebuild user database" should be avoided at ALL COSTS and probably wouldn't solve this particular issue but will definitely result in loss of mail, folders, etc.

The error message that you would be looking for is something like this: item failed to archive

You could try a structural rebuild. In the interim I'll look for other options.

Greetings from South Africa 🙂

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Auto archiving don't work

Hello Laura.

I performed a structural rebuild:
STRUCTURAL VERIFICATION of database /grpwise/po/ofmsg/msg17.db
- Attempting to correct structural problem in database
- Beginning rebuild for database msg17.db
Saving old database to backup msg17.dba
Writing corrected records back to database
- Rebuild succeeded
* Recovered 27794 out of 27794 records
STRUCTURAL VERIFICATION of database /grpwise/po/ofuser/user2kk.db
- Attempting to correct structural problem in database
- Beginning rebuild for database user2kk.db
Saving old database to backup user2kk.dba
Writing corrected records back to database
- Rebuild succeeded
* Recovered 10295 out of 10295 records


PROCESSING COMPLETED- total processing time: 0:00:20

-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-

This is also well.

Regards.

Dirk

================================================================================
===== JOB LOG SUMMARY (582435ef.ckl) ===========================================
================================================================================
Processing completed



***** OVERALL STATS FOR THIS RUN *****
*********************************************************************
Uncorrectable conditions encountered:
- No problems found
Correctable conditions encountered:
- No problems found
*********************************************************************
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: Auto archiving don't work

Hi Dirk,

I suggest that you run a standalone GWCheck against the user in question. Do a Contents check and on the Logging tab set the log level to verbose. Take a look at the resultant log file for Problem 83.

Please let us know how it goes.

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Auto archiving don't work

Hi Laura.

There are no problems with this mailbox present.
This mailbox is sometimes a little curious.
When he writes a new mail, the subjects font-size changes, also the font-size in the body. This is the only mailbox with this behave.

Regards

Dirk
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: Auto archiving don't work

Hi Dirk,

Then I recommend a "Reset Client Options"

Just ensure that the user has logged out of GroupWise prior to running this. Please advise if this mailbox is Online or Caching?

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Auto archiving don't work

Hi Laura.
In the clients settings is caching mailbox path defined. For the moment I don't know, if the caching mailbox is in use.
If not, I would remove it from the workstation.

Regards

Dirk
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: Auto archiving don't work

Hi Dirk,

If the user is in Caching mode there is a setting: Accounts | Account Options | Properties | Advanced | ensure there is a tick in the box to sync settings from online to caching.

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Auto archiving don't work

Hi Laura.
I reset the client settings and removed the path to the caching mailbox.
Here is the result:
RESETTING user preferences for user database /grpwise/po/ofuser/user2kk.db
- resetting record 41000 - type = ENVIRONMENT
- resetting record 41001 - type = SEND
- resetting record 41002 - type = VIEWS
- resetting record 41003 - type = NOTIFY
- resetting record 41004 - type = DOS_PLATFORM
- resetting record 41005 - type = WIN_PLATFORM
- resetting record 41018 - type = TRANSACTION
- Record 41001 updated successfully
- Record 41001 updated successfully

The send folder is two times present (Sometimes he uses another mailprogram)


The setting for automatic archive I set to 180 days again. After restarting the client no archiving process started.
Two questions here:
1. Is it a difference when I use "normal" path with drive-letter or UNC-Path?

2. Does the automatic archiving process also archives unread messages? The user has a number of old, not read messages (I don't use this feature).

Regards

Dirk
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Auto archiving don't work

Hello Laura.

I moved several folders in the mailbox to the default structure. Folders, that name is twice were reduced to one folder.

I found out, that unread messages don't moved to the archive automatically. Its not possible for the program here to skip unread messages.
With the oldest message, which was not read, the archive process stops.

Regards

Dirk
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.