emmermacher Absent Member.
Absent Member.
3676 views

Auto refresh don't work in Webaccess

Hello.

Last week we the upgrade to GW2014 R2 HP1.
When I delete a message in normal view, the message remains visible. Its necessary here to click on Refresh to disappear the message. Then the message isn't visible.
Its running on SLES11 Sp3 OES11 Sp2.
Is it a bug, or a wrong setting?

Thanks in advance for your answers.

Best regards

Dirk Emmermacher
Labels (1)
0 Likes
22 Replies
Micro Focus Expert
Micro Focus Expert

Re: Auto refresh don't work in Webaccess

Hi Dirk,

Perhaps just double-check your setup/configuration. Here's a TID: https://www.novell.com/support/kb/doc.php?id=7015151

Please let us know how it goes.

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
emmermacher Absent Member.
Absent Member.

Re: Auto refresh don't work in Webaccess

Hi Laura.
Thanks for your reply.
In my webacc.cfg I have this values set:

SOAP.Poll.port=8500
SOAP.Poll.Threads.default=5
SOAP.Poll.Threads.max=20
Poll.Idle.timeout=10
Poll.Idle.interval=1

For testing I changed the SOAP.Poll.host=127.0.0.1 to servers IP address and restart novell-tomcat6 and apache
There is no change. When I delete a message, the screen flickers for a very short moment.Thats all. Only a manual refresh updates the screen.

Best regards

Dirk
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Auto refresh don't work in Webaccess

Hi Dirk,

Have you verified that the Poll Thread is listening - in your WebAccess log file (most recent) look for the following line:

12:03:37, <SOAP>, -, INFO, <system>, Poll thread listenening on: 10.11.113.220:8500


Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
emmermacher Absent Member.
Absent Member.

Re: Auto refresh don't work in Webaccess

Hi Laura.

in my logs I don't have entry like "Poll thread listenening on: 10.11.113.220:8500". I also checked older logs.
On my firewall I see most UDP 8500 traffic from the POA-server in the LAN to webacc-server in the DMZ.
Also there is traffic on TCP 7191 from the webacc-server to the POA-server.

Best regards

Dirk
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Auto refresh don't work in Webaccess

Hi Dirk,

Please post the output from this command:

lsof -i :8500; netstat -tulpn | grep 8500


Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
emmermacher Absent Member.
Absent Member.

Re: Auto refresh don't work in Webaccess

Hi Laura.

Here is the output:
mx:/etc/init.d # lsof -i :8500; netstat -tulpn|grep 8500
COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
java 22295 apacheuser 170u IPv4 618217880 0t0 UDP mydomain.de:fmtp
udp 0 0 xxx.xxx.xxx.xxx:8500 0.0.0.0:* 22295/java

This looks well for me.

Regards

Dirk
0 Likes
emmermacher Absent Member.
Absent Member.

Re: Auto refresh don't work in Webaccess

Hi Laura.

Let's have break for this week.
I'll be back on monday.

Have a nice weekend 🙂

Dirk
0 Likes
snielson1 Absent Member.
Absent Member.

Re: Auto refresh don't work in Webaccess

Has this ever worked?

Are you able to test 8500 UDP from your POA server?
netcat -z -u <webaccess IP> 8500 -v

Maybe also look into the webaccess apache error_log. Look out for something like: missing mod_proxy

Shane Nielson Kind of alright at doing stuff with the computer thing
0 Likes
emmermacher Absent Member.
Absent Member.

Re: Auto refresh don't work in Webaccess

Good morning Shane.

Thanks for your answer.
I checked it. Here is the result:
mymailserver:~ # netcat -z -u xxx.xxx.xxx.xxx 8500 -v
mail.server.dmz [xxx.xxx.xxx.xxx] 8500 (fmtp) open

Thats right here.

In the apache's errorlog I found this entries:
[SNIP]
[Sat Apr 23 09:30:02 2016] [notice] Apache/2.2.12 (Linux/SUSE) mod_ssl/2.2.12 OpenSSL/0.9.8j-fips configured -- resuming normal operations
[Sat Apr 23 09:30:03 2016] [notice] SIGUSR1 received. Doing graceful restart
[Sat Apr 23 09:30:03 2016] [warn] worker http://localhost:8080/gw/webacc/poll already used by another worker
[Sat Apr 23 09:30:03 2016] [warn] worker ajp://localhost:9009/gw/webacc already used by another worker
[Sat Apr 23 09:30:03 2016] [warn] The Alias directive in /etc/opt/novell/httpd/conf.d/gw.conf at line 4 will probably never match because it overlaps an earlier Alias.
[Sat Apr 23 09:30:03 2016] [notice] Apache/2.2.12 (Linux/SUSE) mod_ssl/2.2.12 OpenSSL/0.9.8j-fips configured -- resuming normal operations

[Mon Apr 25 08:15:24 2016] [warn] proxy: No protocol handler was valid for the URL /gw/webacc/poll. If you are using a DSO version of mod_proxy, make sure the proxy submodules are included in the configuration using LoadModule.
[/SNIP]

In line 4 there is this alias configured: Alias /gw "/opt/novell/groupwise/webaccess/gw/"

Here is my loadmodule.conf:
LoadModule authz_host_module /usr/lib64/apache2-worker/mod_authz_host.so
LoadModule actions_module /usr/lib64/apache2-worker/mod_actions.so
LoadModule alias_module /usr/lib64/apache2-worker/mod_alias.so
LoadModule auth_basic_module /usr/lib64/apache2-worker/mod_auth_basic.so
LoadModule authz_groupfile_module /usr/lib64/apache2-worker/mod_authz_groupfile.so
LoadModule authn_file_module /usr/lib64/apache2-worker/mod_authn_file.so
LoadModule authz_user_module /usr/lib64/apache2-worker/mod_authz_user.so
LoadModule autoindex_module /usr/lib64/apache2-worker/mod_autoindex.so
LoadModule cgid_module /usr/lib64/apache2-worker/mod_cgid.so
LoadModule dir_module /usr/lib64/apache2-worker/mod_dir.so
LoadModule include_module /usr/lib64/apache2-worker/mod_include.so
LoadModule log_config_module /usr/lib64/apache2-worker/mod_log_config.so
LoadModule mime_module /usr/lib64/apache2-worker/mod_mime.so
LoadModule negotiation_module /usr/lib64/apache2-worker/mod_negotiation.so
LoadModule setenvif_module /usr/lib64/apache2-worker/mod_setenvif.so
LoadModule status_module /usr/lib64/apache2-worker/mod_status.so
LoadModule userdir_module /usr/lib64/apache2-worker/mod_userdir.so
LoadModule asis_module /usr/lib64/apache2-worker/mod_asis.so
LoadModule imagemap_module /usr/lib64/apache2-worker/mod_imagemap.so
LoadModule proxy_module /usr/lib64/apache2-worker/mod_proxy.so
LoadModule rewrite_module /usr/lib64/apache2-worker/mod_rewrite.so
LoadModule ssl_module /usr/lib64/apache2-worker/mod_ssl.so
LoadModule authz_default_module /usr/lib64/apache2-worker/mod_authz_default.so
LoadModule proxy_ajp_module /usr/lib64/apache2-worker/mod_proxy_ajp.so
LoadModule proxy_module_http /usr/lib64/apache2-worker/mod_proxy_http.so

I used a2enmod proxy_http to enable the module. The I restart my apache.
No changes :(.

Regards

Dirk
0 Likes
snielson1 Absent Member.
Absent Member.

Re: Auto refresh don't work in Webaccess

I would suggest opening a SR with support if you haven't done so already. They could take a LAN trace, or look closer at your settings to find a cause.

Shane Nielson Kind of alright at doing stuff with the computer thing
0 Likes
emmermacher Absent Member.
Absent Member.

Re: Auto refresh don't work in Webaccess

Hello Shane.

Thanks for your answer. So I will open the next SR. IMHO the GW2014 R2 HF01 is not the best :(.
With the Win-client we have also several problems.

Regards,

Dirk
0 Likes
emmermacher Absent Member.
Absent Member.

Re: Auto refresh don't work in Webaccess

Hello Laura, hello Shane.

Here I'm back with solution for this issue.
I opened a SR. The Result here is:
Uninstall webacc 2014 r2 hf1
then I installed the last version of webacc 2014 sp2.

Now my webacc works without problem. I hope this will be fixed in the next SP.

Regards.

Dirk
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Auto refresh don't work in Webaccess

Hi Dirk,

Kindly confirm what build number you are running - thank you in advance.

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
emmermacher Absent Member.
Absent Member.

Re: Auto refresh don't work in Webaccess

Hi Laura.

We're running for the moment:
novell-groupwise-server-14.2.0-123047
novell-groupwise-webaccess-webapp-14.0.2-120664
novell-groupwise-gwha-14.2.0-123047

Regards

Dirk
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.