LidijaTW Absent Member.
Absent Member.
1745 views

Bad Parameter Error

We are currently on GW Mobility 14.2.1 build 237

I have users reporting the following issue: When the try to reply to a received message on their device they receive the following error:

Message is from: Mobility
With the subject line: Failed to Add Item
And the body: Mobility failed to add the following item because: Bad parameter. Internal error

The users can read messages, move messages, and compose messages, but not reply.

When I look at the admin console, the users show as:

User State: Synced
Device State: Normal (with a green check mark)
Last Sync: current

Also, we are on GW14.2.1.

Has anyone else seen this?
Labels (1)
0 Likes
8 Replies
Micro Focus Expert
Micro Focus Expert

Re: Bad Parameter Error

Hi,

By any chance are they trying to reply to messages in shared folders?

Please let us know - thanks.

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
arrojo Absent Member.
Absent Member.

Re: Bad Parameter Error

Hi,

We have the same issue in our company.
I received a forwarded Micro Focus mail with an EML in the attachement from an internal user.

If I will open and forward that integrated EML I will receive the same message like "LidijaTW".

GMS Version 14.2.1 Build: 267

Cheers
0 Likes
snielson1 Absent Member.
Absent Member.

Re: Bad Parameter Error

If you are running GMS 14.2.1 or newer, it may be due to shared folders.
That might even involve another sharing their 'mailbox' folder with you (which was only possible in older GroupWise clients)

You can check if they are shared, and from who by running an mcheck
cd /opt/novell/datasync/tools/mcheck
python mcheck.pyc

Check the user ID getting the bad parameter errors.
Exit mcheck, and view the logs for that user in the logs directory within the mcheck folder.
Near the bottom you'll find the folder structure. Search for mailbox, and look for another owner of that mailbox.

You'll simply need to unshare that folder from the other owners client.

Keep in mind that disabling the sharing in GMS will not fix the issue. You'll also want to make sure that sharing is enabled in GMS to pick up the unshare change made in the client.

Shane Nielson Kind of alright at doing stuff with the computer thing
0 Likes
arrojo Absent Member.
Absent Member.

Re: Bad Parameter Error

Hi Shane

Thank you for your info.

We have tried that, but it doesn't works.
Same error message again.

Another idea from Micro Focus was:

1. delete the user from webadmin console

2. use dsapp and force remove rests from GMS databases

3. Go into HTTP interface of this users -> Configuration -> Event Notification list. If a user is listed there (also multiple times for instance) .. then click on his user name -> activate Delete Events and Delete Event Configuration -> Submit.

4. Re-add the user back to GMS and wait for its initial sync -> then get connected to his account with a mobile and see if embedded mails are causing problems .. first in non-shared folder, then eventually also from a shared folder.

We still have the same problem.
0 Likes
arrojo Absent Member.
Absent Member.

Re: Bad Parameter Error

Hi

Now, we solved the issue with the bad parameter - internal error

Situation:
The user "A" can't reply any mails from his mobile. But he didn't replied to mails from a shared folder. he replied to mails from his mailbox directly. I opened an SR about 4-6 weeks ago.

MF saw in the logs, that it is a problem with a shared folder (shared mailbox or calendar from user or another user to him), but in new GW Versions you cannot share the mailbox, but in older versions of GW.

So, we saw, that user "B" shared his mailbox to user "A". Then we opened an old GW client with user "B" and deleted the share to user "A". Then we re-initialized the user "A"on gms. Now, user "A" can reply to mails from his mailbox.

I hope this is the solution for you too.

best regard
Diego
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Bad Parameter Error

Thank you for the information Diego. That's very interesting and I'm sure the community will find this helpful.

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
snielson1 Absent Member.
Absent Member.

Re: Bad Parameter Error

My earlier post (#4) should have explained that? 🙂
Side note.. you can still unshare the main mailbox with the latest clients, so there isn't a need to find and use an older client.

Shane Nielson Kind of alright at doing stuff with the computer thing
0 Likes
arrojo Absent Member.
Absent Member.

Re: Bad Parameter Error

Hi Shane
Sry, I didn't see that ^^
Thank you for your answer.

best regards
Diego
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.