domainmgr Absent Member.
Absent Member.
818 views

Can't add New users to Mobility server

Recently updated the primary post office server from 2014.2.0 to 2014.2.3. It appears users created after that are not findable in Mobility 14.2.2 build 225.

User source is Groupwise. Both PO and Mobility servers have been restarted. SOAP security unchanged (disabled). Configengine log during the search is not helpful:


2019-05-13 08:01:55.105 DEBUG [CP WSGIServer Thread-5] [__init__:1708] [userID:] [eventID:] [objectID:] [] Performing GAL user search, filter: enter a search phrase
2019-05-13 08:01:55.106 DEBUG [CP WSGIServer Thread-5] [__init__:1719] [userID:] [eventID:] [objectID:] [] Returning GAL user search results: 0
2019-05-13 08:02:06.914 DEBUG [CP WSGIServer Thread-6] [__init__:1708] [userID:] [eventID:] [objectID:] [] Performing GAL user search, filter: rausti
2019-05-13 08:02:06.915 DEBUG [CP WSGIServer Thread-6] [__init__:1719] [userID:] [eventID:] [objectID:] [] Returning GAL user search results: 0


Any hints or suggestions are greatly appreciated!
- Mike Howell
Labels (1)
0 Likes
13 Replies
Knowledge Partner Knowledge Partner
Knowledge Partner

Re: Can't add New users to Mobility server

Did you already run the 225 build before upgrading GW?
Is the addressbook user still valid?
Have you tried rebuilding the GAL from with dsapp?

Does
psql -U datasync_user mobility -c "select * from gal;"
show any entries?
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Can't add New users to Mobility server

Hi,

Also check this: https://support.microfocus.com/kb/doc.php?id=7022537

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
domainmgr Absent Member.
Absent Member.

Re: Can't add New users to Mobility server

Hi Mathiasbraun,

Thanks for your reply!

"Did you already run the 225 build before upgrading GW?"
Yes, I built the GW Mobile server a couple months ago from binaries that GW support had to send me (long story). Everything worked AFAIK. At least no reports of problems until yesterday.

"Is the addressbook user still valid?"
I ran a validation from the GW Admin console on the account, and it showed structurally consistent.

"Have you tried rebuilding the GAL from with dsapp?"
I found steps in dsapp to remove the GAL. It said it would remake the GAL on restart. Seemed reasonable, so I snapshotted and did it. GMS is running, but no change in behavior.

"Does
psql -U datasync_user mobility -c "select * from gal;"
show any entries?"
Yes. Several pages worth. (count 225)
0 Likes
domainmgr Absent Member.
Absent Member.

Re: Can't add New users to Mobility server

Hi Laura,

Thanks for your reply!

The Create Deltas checkbox was and is enabled.
0 Likes
domainmgr Absent Member.
Absent Member.

Re: Can't add New users to Mobility server

*NOTE* After I used dsapp to remove the GAL, running the psql command now produces no results. I am going to restart the service and see if it rebuilds.
-- psql command shows no rows.
0 Likes
Knowledge Partner Knowledge Partner
Knowledge Partner

Re: Can't add New users to Mobility server

Have you already tried another addressbook user?
With log level set to "debug", upon trying to browse users in the "add" dialog, which errors do you see in /var/log/datasync/configengine/configengine.log ?
0 Likes
domainmgr Absent Member.
Absent Member.

Re: Can't add New users to Mobility server

Hi Mathiasbraun,

tailing the configengine.log, I see:
2019-05-14 11:46:16.220 DEBUG [LDAPPoll_thread] [directory:202] [userID:] [eventID:] [objectID:] [] GALuser exception: list index out of range
2019-05-14 11:46:16.220 INFO [LDAPPoll_thread] [directory:180] [userID:] [eventID:] [objectID:] [] Polling user someuser1.firepo.firepub...
2019-05-14 11:46:16.220 DEBUG [LDAPPoll_thread] [__init__:1727] [userID:] [eventID:] [objectID:] [] Performing GAL user search using gwname: someuser1.firepo.firepub
2019-05-14 11:46:16.220 DEBUG [LDAPPoll_thread] [directory:202] [userID:] [eventID:] [objectID:] [] GALuser exception: list index out of range
2019-05-14 11:46:16.220 INFO [LDAPPoll_thread] [directory:180] [userID:] [eventID:] [objectID:] [] Polling user someuser2.firepo.firepub...
2019-05-14 11:46:16.220 DEBUG [LDAPPoll_thread] [__init__:1727] [userID:] [eventID:] [objectID:] [] Performing GAL user search using gwname: someuser2.firepo.firepub
2019-05-14 11:46:16.221 DEBUG [LDAPPoll_thread] [directory:202] [userID:] [eventID:] [objectID:] [] GALuser exception: list index out of range
2019-05-14 11:46:16.221 INFO [LDAPPoll_thread] [directory:180] [userID:] [eventID:] [objectID:] [] Polling user someuser3.firepo.firepub...
2019-05-14 11:46:16.221 DEBUG [LDAPPoll_thread] [__init__:1727] [userID:] [eventID:] [objectID:] [] Performing GAL user search using gwname: someuser3.firepo.firepub
2019-05-14 11:46:16.221 DEBUG [LDAPPoll_thread] [directory:202] [userID:] [eventID:] [objectID:] [] GALuser exception: list index out of range
2019-05-14 11:46:39.551 DEBUG [TargetsCleanup_Thread] [syncengine:83] [userID:] [eventID:] [objectID:] [] Pinging engineConnection...
2019-05-14 11:46:39.578 DEBUG [TargetsCleanup_Thread] [syncengine:97] [userID:] [eventID:] [objectID:] [] Engine ping succeeded
2019-05-14 11:46:39.603 INFO [TargetsCleanup_Thread] [syncengine:242] [userID:] [eventID:] [objectID:] [] Targets cleanup finished ...
2019-05-14 11:46:44.327 DEBUG [CP WSGIServer Thread-5] [__init__:1708] [userID:] [eventID:] [objectID:] [] Performing GAL user search, filter: enter a search phrase
2019-05-14 11:46:44.328 DEBUG [CP WSGIServer Thread-5] [__init__:1719] [userID:] [eventID:] [objectID:] [] Returning GAL user search results: 0
2019-05-14 11:46:46.872 DEBUG [CP WSGIServer Thread-6] [__init__:1708] [userID:] [eventID:] [objectID:] [] Performing GAL user search, filter: spock
2019-05-14 11:46:46.873 DEBUG [CP WSGIServer Thread-6] [__init__:1719] [userID:] [eventID:] [objectID:] [] Returning GAL user search results: 0
2019-05-14 11:49:10.427 DEBUG [CP WSGIServer Thread-9] [__init__:1708] [userID:] [eventID:] [objectID:] [] Performing GAL user search, filter: enter a search phrase
2019-05-14 11:49:10.428 DEBUG [CP WSGIServer Thread-9] [__init__:1719] [userID:] [eventID:] [objectID:] [] Returning GAL user search results: 0
2019-05-14 11:49:14.982 DEBUG [CP WSGIServer Thread-10] [__init__:1708] [userID:] [eventID:] [objectID:] [] Performing GAL user search, filter: james
2019-05-14 11:49:14.983 DEBUG [CP WSGIServer Thread-10] [__init__:1719] [userID:] [eventID:] [objectID:] [] Returning GAL user search results: 0


The "someuser" account names are redacted. But the spock account is a new test account I set up yesterday after I discovered this issue. But I can't find names I know are in groupwise (james). So the GAL is not rebuilding I guess.
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Can't add New users to Mobility server

Hi,

Try: /opt/novell/datasync/tools/mcheck # python mcheck.pyc
option 1 [system]
option 2 [GroupWise system Address Book Check]
follow the prompts.

A log file is also created in /opt/novell/datasync/tools/mcheck/logs

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
Knowledge Partner Knowledge Partner
Knowledge Partner

Re: Can't add New users to Mobility server

Assuming you've already performed stuff such as vacuum, reindex and (re-)running the update script:
With loglevel set to "debug", while in dsapp, after selecting the option to recreate the GAL, but BEFORE starting GMS services again:
rename the existing /var/log/datasync/connectors/groupwise-agent.log, start GMS and watch the new one growing. You'll see the system repopulate the GAL (or at least the attempt to do so), the errors you'll see should give us a hint.
Do i understand correctly that you still get entries in the GAL for "legacy" users or does it basically stay empty?
0 Likes
domainmgr Absent Member.
Absent Member.

Re: Can't add New users to Mobility server

Hi Laura,

mcheck log gives:

Checking GroupWise System Address Book against Mobility Address Book.

Mobility Service IP address: 172.16.1.62; DNS name: gw-mobile


Completed analysis for GroupWise System Address book.

Log file location: /opt/novell/datasync/tools/mcheck/logs/sab_2019-05-15T08:59:56.log

Problem getting the Mobility Address Book. If you re-initialized the mobility address book recently, wait an hour before running mcheck. Also, restarting the Mobility connector will speed up the process of re-initialization.
0 Likes
domainmgr Absent Member.
Absent Member.

Re: Can't add New users to Mobility server

Hi Mathiasbraun,

Eureka! I followed the steps, vacuuming, reindexing and re-running the gal update steps. Grep'd the following errors in groupwise-agent.log file:

2019-05-15 09:07:34.374 ERROR [CP WSGIServer Thread-3] [gal:110] [userID:] [eventID:] [objectID:] [GALMonitor] Problem getting the GALUser from the mobility sync agent settings. The Gal sync will not work.
2019-05-15 09:07:34.374 INFO [GALMonitor_Thread] [gal:48] [userID:] [eventID:] [objectID:] [GALMonitor] Started GAL Monitor
2019-05-15 09:07:34.375 INFO [configureUsersOnStartupThread] [gwuserlist:105] [userID:] [eventID:] [objectID:] [configureUser] configureAllUsers: Configuring Users: Start
2019-05-15 09:07:34.375 ERROR [GALMonitor_Thread] [gal:53] [userID:] [eventID:] [objectID:] [GALMonitor] Could not find GAL user in the Mobility XML settings. Cannot continue. Stopping GroupWise System Address Book (GAL) Sync.
2019-05-15 09:07:34.376 DEBUG [configureUsersOnStartupThread] [gwuserlist:108] [userID:] [eventID:] [objectID:] [configureUser] Retrieving list of users from sync engine...
2019-05-15 09:07:34.376 INFO [GALMonitor_Thread] [gal:76] [userID:] [eventID:] [objectID:] [GALMonitor] GAL Monitor Terminated


I changed the Address Book User in the gui console to another user, and re-re-built the GAL. I'm tailing the groupwise-agent.log file and watching Gal Items populate. I can find my test user, Mr. Spock, and I basically everyone.

Not sure why my mobile user didn't work--he was created for the purpose. But that's a problem for another time.

Thanks for all your help!

-Mike
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Can't add New users to Mobility server

Hi Mike,

Great that it's working for you. I do have one question though, the mobile user you initially used for the Address Book user.... did the account have visibility set to "System" in GroupWise?

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
Knowledge Partner Knowledge Partner
Knowledge Partner

Re: Can't add New users to Mobility server

How was the visibility level set for the "old" user?
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.