NOTICE: Significant community changes coming soon
The header menu and the home page on our community will be changing soon. Get more information HERE.
Highlighted
Knowledge Partner
Knowledge Partner
5040 views

Cannot double-click on an .HTM or .HTML attachment to open?

I can duplicate this fairly consistently, although I'm not sure what the cause is.

GW 8.0.2 on Windows XP SP3 Pro.

Sometimes, "html" email comes with a .HTM or .HTML attachment.

In Gwise 7.x we could always double-click on it and it would open in IE.

However, now when we double-click on it, it will state that this isn't a registered file, yet if you SAVE the file to the local hard drive and double-click, THEN it opens with IE.

I would imagine that as long as .HTM and .HTML are associated file types in Explorer (they are), then GW should pass that along to the OS, but it seems that something's getting mucked up?
Labels (2)
0 Likes
12 Replies
Highlighted
Absent Member.
Absent Member.

I just started seeing this, too. I've not kept up with the client versions, I'll start logging that.

We can right-click the attachment and "open with" and it'll work...

<shrug>

Greg Amy GroupWise Admin Hartford (CT) Hospital
0 Likes
Highlighted
Absent Member.
Absent Member.

Same issue with
GW8SP2 on WinXP SP3
Error:
This file does not have a program associated with it for performing this action. Create an association in the Folder Options Control panel.

Can open the HTML file from C:\Windows\Temp\XPgrpwise folder with double click, but cannot from within email attachment.
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Yes! That's the EXACT error. What's stupid is that when you look, it IS associated with it.

I have a feeling this is another bug in GW client.

grrrrrr.
0 Likes
Highlighted
Absent Member.
Absent Member.

Tools > Options > Environment > General > HTML Browser > Microsoft Internet Explorer
0 Likes
Highlighted
Absent Member.
Absent Member.

I'm starting to get reports of a similar problem in WebAcc with HTML attachments. If the user selects "open" it locks the browser session, but if the user saves the HTML attachment to the desktop they can open it from there.

The complaints seem to be isolated at this point to a daily internal newsletter, which is created on a Mac. I am looking into what versions of authoring software they're using, including what versions of HTML they're using.

We're all v8.02 now on all domains, POs, gateways, and WebAccs. However, we're a spattering of v6.5 and up for the clients (~25% v6.x, ~50% v7.x, ~25% v8.x). I still do not yet know if this problem is isolated to specific versions of the client.

GA

Greg Amy GroupWise Admin Hartford (CT) Hospital
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

viethoang;2013395 wrote:
Tools > Options > Environment > General > HTML Browser > Microsoft Internet Explorer


Nope, still broken. Apparently it's a bug.

Even though the file type IS registered (the "icon" in the attachment will show an IE icon) GroupWise isn't passing the command properly to the OS and it keeps insisting that you haven't associated file type: .htm or .html to anything even though you have.
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

gregamy;2013464 wrote:
I'm starting to get reports of a similar problem in WebAcc with HTML attachments. If the user selects "open" it locks the browser session, but if the user saves the HTML attachment to the desktop they can open it from there.

The complaints seem to be isolated at this point to a daily internal newsletter, which is created on a Mac. I am looking into what versions of authoring software they're using, including what versions of HTML they're using.

We're all v8.02 now on all domains, POs, gateways, and WebAccs. However, we're a spattering of v6.5 and up for the clients (~25% v6.x, ~50% v7.x, ~25% v8.x). I still do not yet know if this problem is isolated to specific versions of the client.

GA


So far only 8.0.2 (for us) has the problem. 7.0.3 works fine.
0 Likes
Highlighted
Absent Member.
Absent Member.

kjhurni;2013739 wrote:
Nope, still broken. Apparently it's a bug.
It may not be a bug but a security features 🙂 Groupwise should have picked up the Default Browser setting from Windows but looks like it uses its own settings. I've switch the setting Firefox and it launches Firefox when double click on HTML attachment even though the icon still shows IE icon. Switch to Chrome or Default Browser bring the error message back. I've tried this on several computers, both Windows 7 and XP and it works on all of them.

I've vaguely remember having to do this way back (pre GW5.5) but my Agent Reader offline archive of the old forums is long gone so I can't check.
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

viethoang;2013811 wrote:
It may not be a bug but a security features 🙂 Groupwise should have picked up the Default Browser setting from Windows but looks like it uses its own settings. I've switch the setting Firefox and it launches Firefox when double click on HTML attachment even though the icon still shows IE icon. Switch to Chrome or Default Browser bring the error message back. I've tried this on several computers, both Windows 7 and XP and it works on all of them.

I've vaguely remember having to do this way back (pre GW5.5) but my Agent Reader offline archive of the old forums is long gone so I can't check.


I say it's a bug since that's what NTS has reported back to me after duplicating this.

On every pc I've tried, including a "fresh" vmware copy of XP SP3 and JUST IE or Firefox, it doesn't matter which browser I choose. Double-click the attachment does NOT open the attachment. "Open With" will work, or saving the file will work.

On mine, when I set Firefox as the default browser in the OS AND in Gwise, the icon shows up as "firefox" but get the same error (file not associated, blah blah blah). However, in our organization, IE is the standardized web browser so on 95% of the workstations, IE7 is the default browser and it makes no difference in GroupWise what you choose in this regard (based upon my testing).

But NTS duplicated this and has submitted a bug/defect # so all we can do is wait 6-12 months for a fix.
0 Likes
Highlighted
Absent Member.
Absent Member.

We had the same problem at my office, so we did some digging. Our fix is to modify the registry as follows:


HKEY_CURRENT_USER\Software\Novell\GroupWise\Client\Setup\HTML Browser:1
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Unfortunately that doesn't solve it here. Even when IE is the default browser, GroupWise will still complain that .htm and .html are not associated File Types in the OS, even though they are.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.