Highlighted
Absent Member.
Absent Member.
2834 views

Change GWIA SMTP Port Number

Is there any way to change the port number from port 25 to port 587? Do I have to configure that in the gwia.cfg file? My ISP, Comcast, blocks port 25. I'd try unblocking it but due to there crappy tech support service, I can't unfortunately. I'm using SLES 10 SP4 with OES 2 SP4. Also I'm using GroupWise 8.
Labels (2)
0 Likes
8 Replies
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: Change GWIA SMTP Port Number

Hi

Yes you can change the SMTP port in the gwia.cfg file by using the following switch: --smtpport 25

I don't know how well this will work though!

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Change GWIA SMTP Port Number

laurabuckley;2282383 wrote:
Hi

Yes you can change the SMTP port in the gwia.cfg file by using the following switch: --smtpport 25

I don't know how well this will work though!

Cheers,


Do I have to change anything else? Something in ConsoleOne? How can I test it out locally?
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: Change GWIA SMTP Port Number

Hi,

You can change the port in ConsoleOne to match what you are doing in the gwia.cfg file. Once set and GWIA has been shutdown entirely and then restarted you can test by using telnet to your IP address and specifying the new port number.

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Change GWIA SMTP Port Number

laurabuckley;2282643 wrote:
Hi,

You can change the port in ConsoleOne to match what you are doing in the gwia.cfg file. Once set and GWIA has been shutdown entirely and then restarted you can test by using telnet to your IP address and specifying the new port number.

Cheers,


Thanks for the reply. But every time I try "telneting" port 587, it says connection refused. But when I telnet port 25, it does not give me that error. I configured everything in the gwia.cfg file and in ConsoleOne. Am I missing anything?
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: Change GWIA SMTP Port Number

In article <anthonycastro.61twy0@no-mx.forums.novell.com>,
Anthonycastro wrote:
> Am I missing anything?
>

Restarted GWIA?
Look at the bunch of lines at the start of the recent log file after
start up as they should indicate any issues with the port.


Andy Konecny
Knowledge Partner (voluntary SysOp)
KonecnyConsulting.ca in Toronto
----------------------------------------------------------------------
Andy's Profile: http://forums.novell.com/member.php?userid=75037


___
“i’ve sworn an oath of solitude til the blight is purged from these lands”
Andy of Konecny Consulting in Toronto
Knowledge Partner Profile
If you find a post helpful, click the Like button below. Thanks!
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: Change GWIA SMTP Port Number

Hi,

Ensure that under the Network settings your GWIA is set to "Bind Exclusively to TCP/IP Address".

Then check what ports your GWIA is running on:

gw12:/ # netstat -plan | grep gwia
tcp 0 0 10.11.41.102:25 0.0.0.0:* LISTEN 18238/gwia
tcp 0 0 10.11.41.102:9850 0.0.0.0:* LISTEN 18238/gwia
tcp 0 0 10.11.41.102:7102 0.0.0.0:* LISTEN 18238/gwia
gw12:/ #


That should give you an indication of whether it is binding on port 25 (see above) or on your uniquely specified port.

Let us know how it goes.

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Change GWIA SMTP Port Number

laurabuckley;2282895 wrote:
Hi,

Ensure that under the Network settings your GWIA is set to "Bind Exclusively to TCP/IP Address".

Then check what ports your GWIA is running on:

gw12:/ # netstat -plan | grep gwia
tcp 0 0 10.11.41.102:25 0.0.0.0:* LISTEN 18238/gwia
tcp 0 0 10.11.41.102:9850 0.0.0.0:* LISTEN 18238/gwia
tcp 0 0 10.11.41.102:7102 0.0.0.0:* LISTEN 18238/gwia
gw12:/ #


That should give you an indication of whether it is binding on port 25 (see above) or on your uniquely specified port.

Let us know how it goes.

Cheers,


Sorry for the late reply. But I changed the port to 465 for various reasons. And When i run the "netstat -plan | grep gwia" command I get the following:
"N309US:~ # netstat -plan | grep gwia
tcp 0 0 192.168.1.3:465 0.0.0.0:* LISTEN 4365/gwia
tcp 0 0 192.168.1.3:9850 0.0.0.0:* LISTEN 4365/gwia
N309US:~ #"

Now I know everything is normal and all, but I can't send out mail. I set up port fowarding on my modem and router. Still nothing.
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: Change GWIA SMTP Port Number

Hi.

On 24.09.2013 22:16, anthonycastro wrote:
> Sorry for the late reply. But I changed the port to 465 for various
> reasons. And When i run the "netstat -plan | grep gwia" command I get
> the following:
> "N309US:~ # netstat -plan | grep gwia
> tcp 0 0 192.168.1.3:465 0.0.0.0:*
> LISTEN 4365/gwia
> tcp 0 0 192.168.1.3:9850 0.0.0.0:*
> LISTEN 4365/gwia
> N309US:~ #"
>
> Now I know everything is normal and all, but I can't send out mail. I
> set up port fowarding on my modem and router. Still nothing.


I was afraid this would be the outcome of the thread. You cannot chnage
the SMTP port as you wish. SMTP uses port 25, period. WHat you chnaged
now makes your server *listen on incoming mail* on port 465. But nobody
will send you anything there, except possibly IMAP/SMTP clients that you
control.

Additionaly, that does absolutely nothing for sending regular internet
email. That is port 25, and if your provider blocks this, you cannot
send mail, and need a different provider, or use their mail relay (if
they offer one).

CU,
--
Massimo Rosen
Novell Knowledge Partner
No emails please!
http://www.cfc-it.de
CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.