Highlighted
Absent Member.
Absent Member.
1069 views

Contact sync issues after 2.0 upgrade

Hi
I'm having major issues with contacts not sync-ing since upgrading to GMS 2.0 :-
1. We have a mixture of iPhones & Android. There is no consistency as to which sync and which do not by phone type.
2. Most of the phones that are not sync-ing lost all contacts created on the phones, the ones in GW don't get to the phones.
3. There is no consistency in the address book names. In GW the books have the name of the user. In GMS "Folders", some folders are labeled "Contacts", others have the user name. Some of each type sync and some do not.
4. MCHECK doesn't indicate any problem. In one test case it indicated that all contacts had synced but they were sitting in a "pending" status in GMS folders. I have tried forcing a re-sync in GMS. I've tried removing the account from the phones and re-adding.
I would appreciate any help with solving these issues.
Thanks, Rod
Labels (1)
0 Likes
5 Replies
Highlighted
Knowledge Partner
Knowledge Partner

Re: Contact sync issues after 2.0 upgrade

In article <rjfraser.6d5ijz@no-mx.forums.novell.com>, Rjfraser wrote:
> I'm having major issues with contacts not sync-ing since upgrading to
> GMS 2.0 :-
>

hmm, first step I'd check is to make sure we're not running low on the
basics, so a "free -m" and a "df -h" to make sure we aren't getting to
tight on RAM or drive space.
SLES 11 sp2 or higher? 64-bit?

Have you recently vacuumed the GMS databases as per TID 7009453?

Regular Contents & Index GWchecks are running clean?

One contacts problem we had with one user was resolved by exporting the
particular address book, rename the old, create a new one by the same
name and importing the old one in. Then reinitialize the user
connection.



Andy of
KonecnyConsulting.ca in Toronto
Knowledge Partner
http://forums.novell.com/member.php/75037-konecnya
If you find a post helpful and are logged in the Web interface, please
show your appreciation by clicking on the star below. Thanks!

___
“i’ve sworn an oath of solitude til the blight is purged from these lands”
Andy of Konecny Consulting in Toronto
Knowledge Partner Profile
If you find a post helpful, click the Like button below. Thanks!
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Contact sync issues after 2.0 upgrade

Thanks, Andy. I'm running SLES 11 sp2 64-bit.
free -m: mem
total: 3834 used: 3430 free: 403 Shared: 0 buffers: 151 cached: 2305

-/+ buffers/cache: used: 973 free: 2860

swap: total: 4094 used: 149 free: 3945

df -h: used 6%

I'll check TID 7009453. I have never vacuumed the database.

Do you think there is any relevance to the address book name not matching the folder name in GMS? and the inconsistency there? I've also had a couple of authentication issues since changing from LDAP to GroupWise. Do you think I should change back to LDAP? If I put the users into a GroupWise distribution list will I get duplicate entries in the GMS database?

Thanks, Rod

Rod
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: Contact sync issues after 2.0 upgrade

In article <rjfraser.6daj40@no-mx.forums.novell.com>, Rjfraser wrote:
> I'll check TID 7009453. I have never vacuumed the database.

Then time to run through that as it will get some potential problems out
of the way

> Do you think there is any relevance to the address book name not
> matching the folder name in GMS? and the inconsistency there?

Yes, but it doesn't tell us exactly what is happening. Worth watching and
trying to dig further to see if it can be seen where exactly this is
happening.

> Do you think I should change back to LDAP?

I don't think flipping that is worth the headaches at this point. Leave
that until something more concrete surfaces.

Are there any reoccurring problems in your regular Contents GWchecks? Not
all problems found are actually fixed and need some additional prodding to
fully fix and some of those apply very much to addressbook issues.

Have you tried the export/import trick yet on any user?



Andy of
KonecnyConsulting.ca in Toronto
Knowledge Partner
http://forums.novell.com/member.php/75037-konecnya
If you find a post helpful and are logged in the Web interface, please
show your appreciation by clicking on the star below. Thanks!

___
“i’ve sworn an oath of solitude til the blight is purged from these lands”
Andy of Konecny Consulting in Toronto
Knowledge Partner Profile
If you find a post helpful, click the Like button below. Thanks!
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Contact sync issues after 2.0 upgrade

Hi Andy

Sorry this has taken some time but I've had other fires. My GWChecks look relatively clean. I also tried the renaming the address book and that seems to work but I have a bigger issue. All but one of my users got to GMS via an edirectory group. That group does not appear to work any more. I tried to delete an old user from the edirectory group and it does not remove him from GSM. I removed my account from the edirectory group, add it to the GW distribution group and re-initialize. In GMS it still shows me associated with the edirectory group. New users added to the GW group appear to work fine. But, as the system works right now, I cannot remove any users that came through the edirectory group.

Thanks,

Rod
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: Contact sync issues after 2.0 upgrade

In article <rjfraser.6dnj5z@no-mx.forums.novell.com>, Rjfraser wrote:
> Sorry this has taken some time but I've had other fires.

Ah fires, they do tend to demand our attention. Completely understandable
as it isn't like I manage to be in here every day.

> My GWChecks look relatively clean.

That can sometimes be misleading. The trick is to make sure that none of
the individual Problems repeat each run. I wrote up the process to check
for this http://www.konecnyad.ca/andyk/gwlogs.htm and like all other PM,
staying on top can help head off those fires before they happen.

> I also tried the renaming the address book and
> that seems to work

Very good, so the issue of this thread is solved. Thankyou for the
feedback.

> But I have a bigger issue. All but one of my users
> got to GMS via an edirectory group. That group does not appear to work
> any more. I tried to delete an old user from the edirectory group and
> it does not remove him from GSM. I removed my account from the
> edirectory group, add it to the GW distribution group and re-initialize.
> In GMS it still shows me associated with the edirectory group. New
> users added to the GW group appear to work fine. But, as the system
> works right now, I cannot remove any users that came through the
> edirectory group.

Ahh, a new issue. Ideally you should have started a new thread. If the
following doesn't do the trick, please start a new thread on this and
we'll work it through there making our exploration more findable for
others.

I am assuming you are currently in GW Authentication which appears to be
the direction things are going in.
Test 1. For a user you want to delete; remove them from the eDir group,
add them to the GroupWise group, let GMS get used to this for a day
(vacuum perhaps), then delete them from the GW group. This would be the
ideal.
Test2. Almost the same just add to the GW group before removing from the
eDir group.

A test I would rather do in Lab first to make sure that the newly added GW
Group based users don't get removed. Switch GMS back to LDAP mode,
quickly delete the users you need, then flip back to GW mode.



Andy of
KonecnyConsulting.ca in Toronto
Knowledge Partner
http://forums.novell.com/member.php/75037-konecnya
If you find a post helpful and are logged in the Web interface, please
show your appreciation by clicking on the star below. Thanks!

___
“i’ve sworn an oath of solitude til the blight is purged from these lands”
Andy of Konecny Consulting in Toronto
Knowledge Partner Profile
If you find a post helpful, click the Like button below. Thanks!
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.