Highlighted
Honored Contributor.
Honored Contributor.
568 views

Delete GW8 domain from GW 2014

I have a test environment running to upgrade GW8 to GW2014. The primary domain, secondary domain and all the post offices have been upgraded to 2014. I configured a new server/new domain with the Webaccess application in 2014, and had the old GW 8 webaccess server running in tandum. I'd like to retire the GW8 Webaccess server (and domain) from the system since its no longer need it.
Any ideas how to remove this domain from 2014?
Labels (1)
0 Likes
5 Replies
Highlighted
Knowledge Partner
Knowledge Partner

Re: Delete GW8 domain from GW 2014

squartec;2414348 wrote:
I have a test environment running to upgrade GW8 to GW2014. The primary domain, secondary domain and all the post offices have been upgraded to 2014. I configured a new server/new domain with the Webaccess application in 2014, and had the old GW 8 webaccess server running in tandum. I'd like to retire the GW8 Webaccess server (and domain) from the system since its no longer need it.
Any ideas how to remove this domain from 2014?


If there are no objects you need under that GroupWise 8 domain, you should be able to simply delete in within the GroupWise webadmin.
While doing this keep both/all MTA's running so all the needed changes sync back and forth.

Before doing that, make a backup copy of the domain databases and do make sure there are no pending operations (in the System section of the webadmin).

To clean up to old eDirectory counterparts for those GroupWise objects, use iManager (or "something" that does not have the old GroupWise snapins) to remove them.

Cheers,
Willem
0 Likes
Highlighted
Honored Contributor.
Honored Contributor.

Re: Delete GW8 domain from GW 2014

Thanks Willem. Followed your suggestions. There are no pending operations. In the 2014 Admin console, when i look at the objects in that GW8 Domain (gw8MTA) and try to delete the gw8mta, (while connected to the Primary domain) it gives me this error: MTA needs to be running for the admin-service to function properly. You can create a new MTA on the domain and it will automatically delete this MTA. I try going to the Message Transfer Agents tab, select the gw8MTA and delete and it gives me this :
(Option available only when connected to the parent domain.) Obviously can't connect to the old GW8web domain in GW2014 admin console to delete it as it doesn't have the admin service running! Do I just delete the objects in iManager then?
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: Delete GW8 domain from GW 2014

squartec;2414401 wrote:
Thanks Willem. Followed your suggestions. There are no pending operations. In the 2014 Admin console, when i look at the objects in that GW8 Domain (gw8MTA) and try to delete the gw8mta, (while connected to the Primary domain) it gives me this error: MTA needs to be running for the admin-service to function properly. You can create a new MTA on the domain and it will automatically delete this MTA. I try going to the Message Transfer Agents tab, select the gw8MTA and delete and it gives me this :
(Option available only when connected to the parent domain.) Obviously can't connect to the old GW8web domain in GW2014 admin console ...


Ah, sorry, my bad as I was convinced the primary MTA would send through the delete to the old domain. Apparently that does not work from the new WebAdmin in the case of older domians.

In this case you can spin up a copy of ConsoleOne (with the GroupWise snapins, as you need to edit the GroupWise system to send through the delete job) and run it against the /old GW 8 domain/.

Are you allowed to delete the domain in this case?

iManager should only be used to delete old eDirectory objects that no longer have a GroupWise counterpart in the GroupWise system. So that will not work for your domain delete operation, as that requires a change in the GroupWise system/database.

Cheers,
Willem
0 Likes
Highlighted
Honored Contributor.
Honored Contributor.

Re: Delete GW8 domain from GW 2014

magic31;2414407 wrote:
Ah, sorry, my bad as I was convinced the primary MTA would send through the delete to the old domain. Apparently that does not work from the new WebAdmin in the case of older domians.

In this case you can spin up a copy of ConsoleOne (with the GroupWise snapins, as you need to edit the GroupWise system to send through the delete job) and run it against the /old GW 8 domain/.

Are you allowed to delete the domain in this case?

iManager should only be used to delete old eDirectory objects that no longer have a GroupWise counterpart in the GroupWise system. So that will not work for your domain delete operation, as that requires a change in the GroupWise system/database.

Cheers,
Willem


Perfect! Connect to the (gw8)webdomain and deleted the gw8MTA in C1, it wouldn't let me delete the (gw8)webdomain as it couldn't access the Primary Domain, so I went over to the 2014 Admin console and was able to delete the domain from there.
Thanks for all your help Willem! Much appreciated!
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: Delete GW8 domain from GW 2014

squartec;2414409 wrote:
Perfect! Connect to the (gw8)webdomain and deleted the gw8MTA in C1, it wouldn't let me delete the (gw8)webdomain as it couldn't access the Primary Domain, so I went over to the 2014 Admin console and was able to delete the domain from there.
Thanks for all your help Willem! Much appreciated!


Cool! Good to hear you've sorted it. Surprising (or maybe not) that both old and new tooling is needed. I'll make a little test setup for this myself as I'm curious to see if it can also be done in one go.

Thanks for feeding your steps back into the forums. 🙂

Cheers,
Willem
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.