Highlighted
medtrials Absent Member.
Absent Member.
1299 views

Forcing GWIA to ignore MX and use hardcoded info

I am working on an issue with messagelabs in which they are suggesting that we hardcode messages destined for xyz.com to a name.of.cluster where both are names. I guess I'm asking how can I force GWIA to use an MX record I create instead of public DNS mx. Messagelabs says that we are randomly using a pref 20 mail exchanger which is causing issues with delayed messages until we resend to pref 10 mail exhchanger. The idea is that we tell gwia only to go to pref 10 mx.

Thanks in advance!
Labels (2)
Tags (2)
0 Likes
4 Replies
Anonymous_User Absent Member.
Absent Member.

Re: Forcing GWIA to ignore MX and use hardcoded info

On 5/16/2012 2:56 PM, medtrials wrote:
>
> I am working on an issue with messagelabs in which they are suggesting
> that we hardcode messages destined for xyz.com to a name.of.cluster
> where both are names. I guess I'm asking how can I force GWIA to use an
> MX record I create instead of public DNS mx. Messagelabs says that we
> are randomly using a pref 20 mail exchanger which is causing issues with
> delayed messages until we resend to pref 10 mail exhchanger. The idea
> is that we tell gwia only to go to pref 10 mx.
>
> Thanks in advance!
>
>

Look up route.cfg in the knowledgebase
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Forcing GWIA to ignore MX and use hardcoded info

On 5/16/2012 6:41 PM, Michael Bell wrote:
> On 5/16/2012 2:56 PM, medtrials wrote:
>>
>> I am working on an issue with messagelabs in which they are suggesting
>> that we hardcode messages destined for xyz.com to a name.of.cluster
>> where both are names. I guess I'm asking how can I force GWIA to use an
>> MX record I create instead of public DNS mx. Messagelabs says that we
>> are randomly using a pref 20 mail exchanger which is causing issues with
>> delayed messages until we resend to pref 10 mail exhchanger. The idea
>> is that we tell gwia only to go to pref 10 mx.
>>
>> Thanks in advance!
>>
>>

> Look up route.cfg in the knowledgebase

otherwise the question isn't a GWIA question. GWIA will always use the
underlying os resolver. So you'd point that to a dns that is not a
public one.
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Forcing GWIA to ignore MX and use hardcoded info

route.cfg is a much easier option - in my humble opinion
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
medtrials Absent Member.
Absent Member.

Re: Forcing GWIA to ignore MX and use hardcoded info

Thank you for the replies, from what I've read on the route.cfg it seems pretty similar in that it specifies a domain and IP address. I haven't tried due to it being on our production box, but was hoping to clarify if I could use domain to nameserver. (ie: domain.com [messagelabsserver.com])
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.