hhs_admin Contributor.
Contributor.
1216 views

GMS 18.1 Install error on SLES12SP3 missing Repository

On a fresh installed and registered SLE12SP3 with up to date updates calling ./install on a mounted groupwise-mobility-service-18.1.0-x86_64-410.iso I get the following errors:

Installing librtfcomp0...
error: /mnt/suse/x86_64/librtfcomp0-1.1-2.18.x86_64.rpm: not an rpm package (or package manifest):
Installing psqlODBC...
error: /mnt/suse/x86_64/psqlODBC-09.03.0300-4.1.x86_64.rpm: not an rpm package (or package manifest):
Installing python-pyodbc...
error: /mnt/suse/x86_64/python-pyodbc-2.1.6-1.26.x86_64.rpm: not an rpm package (or package manifest):
Installing python-psycopg2...
error: /mnt/suse/x86_64/python-psycopg2-2.4.2-2.23.x86_64.rpm: not an rpm package (or package manifest):
Installing python-rtfcomp...
error: /mnt/suse/x86_64/python-rtfcomp-1.1-2.18.x86_64.rpm: not an rpm package (or package manifest):
Installing GMS rpms...
error: /mnt/suse/x86_64/datasync-common-lib-PySQLPool-18.0.0.7411-1.1.x86_64.rpm: not an rpm package (or package manifest):
error: /mnt/suse/x86_64/datasync-common-lib-cherrypy-18.0.0.7411-1.1.x86_64.rpm: not an rpm package (or package manifest):
error: /mnt/suse/x86_64/datasync-common-lib-django-18.0.0.7411-1.1.x86_64.rpm: not an rpm package (or package manifest):
error: /mnt/suse/x86_64/datasync-common-lib-iso8601-18.0.0.7411-1.1.x86_64.rpm: not an rpm package (or package manifest):
error: /mnt/suse/x86_64/datasync-common-lib-networkx-18.0.0.7411-1.1.x86_64.rpm: not an rpm package (or package manifest):
error: /mnt/suse/x86_64/datasync-common-lib-ntlm-18.0.0.7411-1.1.x86_64.rpm: not an rpm package (or package manifest):
error: /mnt/suse/x86_64/datasync-common-lib-pytz-18.0.0.7411-1.1.x86_64.rpm: not an rpm package (or package manifest):
error: /mnt/suse/x86_64/datasync-common-lib-requests-18.0.0.7411-1.1.x86_64.rpm: not an rpm package (or package manifest):
error: /mnt/suse/x86_64/datasync-common-lib-soaplib-18.0.0.7411-1.1.x86_64.rpm: not an rpm package (or package manifest):
error: /mnt/suse/x86_64/datasync-common-lib-suds-18.0.0.7411-1.1.x86_64.rpm: not an rpm package (or package manifest):
error: /mnt/suse/x86_64/datasync-configengine-18.0.0.7411-1.1.x86_64.rpm: not an rpm package (or package manifest):
error: /mnt/suse/x86_64/datasync-syncengine-18.0.0.7411-1.1.x86_64.rpm: not an rpm package (or package manifest):
error: /mnt/suse/x86_64/datasync-syncengine-connector-engine-18.0.0.7411-1.1.x86_64.rpm: not an rpm package (or package manifest):
error: /mnt/suse/x86_64/datasync-syncengine-connector-groupwise-18.0.0.7411-1.1.x86_64.rpm: not an rpm package (or package manifest):
error: /mnt/suse/x86_64/datasync-syncengine-connector-mobility-18.0.0.7411-1.1.x86_64.rpm: not an rpm package (or package manifest):
error: /mnt/suse/x86_64/datasync-webadmin-18.0.0.7411-1.1.x86_64.rpm: not an rpm package (or package manifest):
The GMS rpms failed to install. You must have a Software Repository configured for SLES 12.

The SLES12SP3 installation DVD is mounted an the following Repos are available:
zypper lr
Repository priorities are without effect. All enabled repositories share the same priority.

# | Alias | Name | Enabled | GPG Check | Refresh
---+-------------------------------------------------------------------------+----------------------------------+---------+-----------+--------
1 | SLES12-SP3-12.3-0 | SLES12-SP3-12.3-0 | Yes | (r ) Yes | No
2 | SLES12-SP3_12.3-0 | SLES12-SP3 12.3-0 | Yes | (r ) Yes | No
3 | SUSE_Linux_Enterprise_Server_12_SP3_x86_64:SLES12-SP3-Debuginfo-Pool | SLES12-SP3-Debuginfo-Pool | No | ---- | ----
4 | SUSE_Linux_Enterprise_Server_12_SP3_x86_64:SLES12-SP3-Debuginfo-Updates | SLES12-SP3-Debuginfo-Updates | Yes | (r ) Yes | Yes
5 | SUSE_Linux_Enterprise_Server_12_SP3_x86_64:SLES12-SP3-Pool | SLES12-SP3-Pool | Yes | (r ) Yes | No
6 | SUSE_Linux_Enterprise_Server_12_SP3_x86_64:SLES12-SP3-Source-Pool | SLES12-SP3-Source-Pool | Yes | (r ) Yes | Yes
7 | SUSE_Linux_Enterprise_Server_12_SP3_x86_64:SLES12-SP3-Updates | SLES12-SP3-Updates | Yes | (r ) Yes | Yes
8 | SUSE_Package_Hub_12_SP3_x86_64:SUSE-PackageHub-12-SP3 | SUSE-PackageHub-12-SP3 | Yes | (r ) Yes | Yes
9 | SUSE_Package_Hub_12_SP3_x86_64:SUSE-PackageHub-12-SP3-Debuginfo | SUSE-PackageHub-12-SP3-Debuginfo | No | ---- | ----
10 | SUSE_Package_Hub_12_SP3_x86_64:SUSE-PackageHub-12-SP3-Pool | SUSE-PackageHub-12-SP3-Pool | Yes | (r ) Yes | Yes


In the docs I can't find a hint for a missing repo :confused:

Sorry for the confusion: These are the error messages for 18.0.0 but similar output for 18.1.0
Klaus
Labels (1)
0 Likes
8 Replies
hhs_admin Contributor.
Contributor.

Re: GMS 18.1 Install error on SLES12SP3 missing Repository

Addendum:

When trying to manual install some of the rpms which are on the distro iso I get "Wrong Digest" error with bad checksums.

Klaus
0 Likes
Knowledge Partner
Knowledge Partner

Re: GMS 18.1 Install error on SLES12SP3 missing Repository

What happens if you try to manually install let's say librtfcomp?
0 Likes
hhs_admin Contributor.
Contributor.

Re: GMS 18.1 Install error on SLES12SP3 missing Repository

mathiasbraun;2491500 wrote:
What happens if you try to manually install let's say librtfcomp?


When using YaST I get "Wrong Digest" error with bad checksums.
rpm will not install

When using rpm
rpm -i librtfcomp0-1.1-1.1.x86_64.rpm 
error: librtfcomp0-1.1-1.1.x86_64.rpm: not an rpm package (or package manifest)
0 Likes
Knowledge Partner
Knowledge Partner

Re: GMS 18.1 Install error on SLES12SP3 missing Repository

Did you check the md5 checksum of the iso?
Where is the iso mounted from (local disk? nfs share?).
Did you run rpm -qlp and rpm -qip against the rpm?
Maybe the iso is really just corrupted...
0 Likes
hhs_admin Contributor.
Contributor.

Re: GMS 18.1 Install error on SLES12SP3 missing Repository

mathiasbraun;2491512 wrote:
Did you check the md5 checksum of the iso?
Where is the iso mounted from (local disk? nfs share?).
Maybe the iso is really just corrupted...


THX! It's always worthwhile to double check.
I checked the md5sum of the iso after downloading, but not after copying it to my virtual machine 😞

Klaus

So thread should be marked as "solved" ... how to do that?
0 Likes
Knowledge Partner
Knowledge Partner

Re: GMS 18.1 Install error on SLES12SP3 missing Repository

Frankly spoken: no idea. I'll ask, though.
0 Likes
Knowledge Partner
Knowledge Partner

Re: GMS 18.1 Install error on SLES12SP3 missing Repository

There's no such feature in the BB backend.
0 Likes
Knowledge Partner
Knowledge Partner

Re: GMS 18.1 Install error on SLES12SP3 missing Repository

In article <hhs_admin.8rd5hb@no-mx.forums.microfocus.com>, Hhs admin
wrote:
> So thread should be marked as "solved" ... how to do that?


This particular forum software doesn't have this function, but the one
we likely to be moving to some point in the new year does have it
something close to that function.


Andy of
http://KonecnyConsulting.ca in Toronto
Knowledge Partner
http://forums.novell.com/member.php/75037-konecnya
If you find a post helpful and are logged in the Web interface, please
show your appreciation by clicking on the star below. Thanks!
GMS troubleshooting tips at
https://www.konecnyad.ca/andyk/gwmobility.htm


___
Andy of Konecny Consulting in Toronto
Knowledge Partner Profile
If you find a post helpful, click the Like button below. Thanks!
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.