Highlighted
Absent Member.
Absent Member.
964 views

GMS18 not opening port 443

I just built a new server for GMS18 because our GMS14 was SLES 11, and after installing the GMS18 services I found that my on-network devices are not able to connect to it. The local firewall is turned off, there are no other firewalls between devices, and when I do a port scan the server is not showing port 443 as being open. When I scan against my GMS14 server it does show that port 443 is open. I've compared their configurations and I'm not seeing anything aside from the local IP address and what they're using to authenticate to LDAP different between them, and none of that would be related to why port 443 isn't opening. Any suggestions? Thanks!
Labels (1)
0 Likes
6 Replies
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: GMS18 not opening port 443

Hi,

On the GMS server do the following: netstat -plan | grep 443

Should show python listining on that port.

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: GMS18 not opening port 443

laurabuckley;2474041 wrote:
Hi,

On the GMS server do the following: netstat -plan | grep 443

Should show python listining on that port.

Cheers,


When I typed that in it came back with no results, just gave me another command line prompt
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: GMS18 not opening port 443

Hi,

I would check to see if python is indeed running. When I do a: ps -ef | grep python I get the following:


gms18:~ # ps -ef | grep python
root 10163 10118 0 08:32 pts/0 00:00:00 grep --color=auto python
root 16046 1 0 2017 ? 01:36:29 /usr/bin/python /opt/novell/datasync/monitorengine/sbin/monitorEngine.pyc
root 16094 1 0 2017 ? 00:47:49 /usr/bin/python /opt/novell/datasync/configengine/sbin/configEngine.pyc
root 16152 1 0 2017 ? 00:19:41 /usr/bin/python /opt/novell/datasync/syncengine/sbin/syncEngine.pyc
root 16222 1 0 2017 ? 00:00:12 /usr/bin/python /opt/novell/datasync/webadmin/sbin/webadminServer.pyc
root 16252 1 0 2017 ? 00:05:35 /usr/bin/python /opt/novell/datasync/syncengine/sbin/connectorManager.pyc
root 16254 16252 0 2017 ? 01:54:50 /usr/bin/python /opt/novell/datasync/syncengine/sbin/connectorManager.pyc
root 16255 16252 0 2017 ? 03:40:35 /usr/bin/python /opt/novell/datasync/syncengine/sbin/connectorManager.pyc
gms18:~ #



Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: GMS18 not opening port 443

Hi,

Further to my post above about python running... when you start GMS do you see a line like this in the mobility-agent.log file:


2018-01-24 09:21:40.641 INFO [DeviceInterfaceMonitor_Thread] [DeviceInterface:185] [userID:] [eventID:] [objectID:] [Server] Mobility Device Interface Running... device.wsgiserver.CherryPyWSGIServer(('0.0.0.0', 443))



Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: GMS18 not opening port 443

laurabuckley;2474098 wrote:
Hi,

Further to my post above about python running... when you start GMS do you see a line like this in the mobility-agent.log file:


2018-01-24 09:21:40.641 INFO [DeviceInterfaceMonitor_Thread] [DeviceInterface:185] [userID:] [eventID:] [objectID:] [Server] Mobility Device Interface Running... device.wsgiserver.CherryPyWSGIServer(('0.0.0.0', 443))



Cheers,


To answer both of your posts, yes I do see python running and I do see the line as you have indicated. When I do a port scan on the local server while GMS is running I only see ports 22, 25 and 5432 as active. I'm about to open a ticket on this since I wasn't sure if I messed something up on my first attempt at the server so I rebuilt it and this is a repeating issue.
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: GMS18 not opening port 443

Possible the install was bad, and the connectors didn't get set up properly?

Check the path /etc/datasync/configengine/engine/pipeline1/connectors/ (I may have that path mistyped..)
In that folder you should have two other folders. One called groupwise, and the other mobility. Make sure you have a connector.xml in the mobility folder.

If that checks out.. possible the cert is bad? /var/lib/datasync/device/mobility.pem

Good luck!

Shane Nielson Kind of alright at doing stuff with the computer thing
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.