Highlighted
Contributor.
Contributor.
1378 views

GMS2: Sync errors after restarting datasync-connectors

System: SLES11SP3 fresh install, GMS 2.0.0 Build 429
Groupwise 2012sp2

GMS is working fine till restarting the connectors in a ssh shell or restarting the whole GMS service (rcgms restart)
after that, mail without attachment are working fine but mails with an attachment don't sync anymore.
After restarting the Host all mails are syncing fine.

the error I get after I restart the connectors when gms get an mail with attachment in the groupwise-connector is:

groupwise-agent.log
2013-12-23 13:16:52.182 INFO [POPULATE_WORKER_Thread-8] [engine:955] [userID:userid.po.domain] [eventID:] [objectID:] [CheckPoint] Created Consumer Event: 1b00127f6bcc11e3adf100505687290d
2013-12-23 13:16:52.188 INFO [POPULATE_WORKER_Thread-8] [AppInterface:1525] [userID:] [eventID:] [objectID:] [CheckPoint] Sent event to engine: 52B3AEC9.UNILINZ.ZID.100.1363032.1.177292.1
2013-12-23 13:16:52.292 ERROR [POPULATE_WORKER_Thread-8] [gwconnectorlogic:1414] [userID:userid] [eventID:] [objectID:] [ItemHandler] An unexpected error occurred while trying to handle the item: 52B3F402.domain.po.100.1363032.1.17729E.1@1:7.domain.po.100.0.1.0.1@16 : <urlopen error Tunnel connection failed: 403 Forbidden>
2013-12-23 13:16:52.294 ERROR [POPULATE_WORKER_Thread-8] [util:253] [userID:] [eventID:] [objectID:] [] EXCEPTION: ********************
2013-12-23 13:16:52.294 ERROR [POPULATE_WORKER_Thread-8] [util:256] [userID:] [eventID:] [objectID:] [] EXCEPTION: Traceback (most recent call last):
2013-12-23 13:16:52.294 ERROR [POPULATE_WORKER_Thread-8] [util:256] [userID:] [eventID:] [objectID:] [] EXCEPTION: File "./groupwise/lib/gwconnectorlogic.py", line 1227, in itemHandler
2013-12-23 13:16:52.295 ERROR [POPULATE_WORKER_Thread-8] [util:256] [userID:] [eventID:] [objectID:] [] EXCEPTION: File "./groupwise/lib/gwconnectorlogic.py", line 1600, in processItemAttachments
2013-12-23 13:16:52.295 ERROR [POPULATE_WORKER_Thread-8] [util:256] [userID:] [eventID:] [objectID:] [] EXCEPTION: File "./groupwise/lib/gwconnectorlogic.py", line 1709, in downloadAttachment
2013-12-23 13:16:52.295 ERROR [POPULATE_WORKER_Thread-8] [util:256] [userID:] [eventID:] [objectID:] [] EXCEPTION: File "/usr/lib64/python2.6/urllib2.py", line 126, in urlopen
2013-12-23 13:16:52.295 ERROR [POPULATE_WORKER_Thread-8] [util:256] [userID:] [eventID:] [objectID:] [] EXCEPTION: return _opener.open(url, data, timeout)
2013-12-23 13:16:52.296 ERROR [POPULATE_WORKER_Thread-8] [util:256] [userID:] [eventID:] [objectID:] [] EXCEPTION: File "/usr/lib64/python2.6/urllib2.py", line 391, in open
2013-12-23 13:16:52.296 ERROR [POPULATE_WORKER_Thread-8] [util:256] [userID:] [eventID:] [objectID:] [] EXCEPTION: response = self._open(req, data)
2013-12-23 13:16:52.296 ERROR [POPULATE_WORKER_Thread-8] [util:256] [userID:] [eventID:] [objectID:] [] EXCEPTION: File "/usr/lib64/python2.6/urllib2.py", line 409, in _open
2013-12-23 13:16:52.296 ERROR [POPULATE_WORKER_Thread-8] [util:256] [userID:] [eventID:] [objectID:] [] EXCEPTION: '_open', req)
2013-12-23 13:16:52.297 ERROR [POPULATE_WORKER_Thread-8] [util:256] [userID:] [eventID:] [objectID:] [] EXCEPTION: File "/usr/lib64/python2.6/urllib2.py", line 369, in _call_chain
2013-12-23 13:16:52.297 ERROR [POPULATE_WORKER_Thread-8] [util:256] [userID:] [eventID:] [objectID:] [] EXCEPTION: result = func(*args)
2013-12-23 13:16:52.297 ERROR [POPULATE_WORKER_Thread-8] [util:256] [userID:] [eventID:] [objectID:] [] EXCEPTION: File "/usr/lib64/python2.6/urllib2.py", line 1194, in https_open
2013-12-23 13:16:52.297 ERROR [POPULATE_WORKER_Thread-8] [util:256] [userID:] [eventID:] [objectID:] [] EXCEPTION: return self.do_open(httplib.HTTPSConnection, req)
2013-12-23 13:16:52.297 ERROR [POPULATE_WORKER_Thread-8] [util:256] [userID:] [eventID:] [objectID:] [] EXCEPTION: File "/usr/lib64/python2.6/urllib2.py", line 1161, in do_open
2013-12-23 13:16:52.298 ERROR [POPULATE_WORKER_Thread-8] [util:256] [userID:] [eventID:] [objectID:] [] EXCEPTION: raise URLError(err)
2013-12-23 13:16:52.298 ERROR [POPULATE_WORKER_Thread-8] [util:256] [userID:] [eventID:] [objectID:] [] EXCEPTION: URLError: <urlopen error Tunnel connection failed: 403 Forbidden>
2013-12-23 13:16:52.298 ERROR [POPULATE_WORKER_Thread-8] [util:257] [userID:] [eventID:] [objectID:] [] EXCEPTION: ********************


restarting the postgresql doesn't help,
a fresh installation of the gms neither
when restarting the connectors in the gui the problem doesn't occur


any ideas?
thanks
claus


I already tried a fresh installation
Labels (1)
0 Likes
2 Replies
Highlighted
Contributor.
Contributor.

Re: GMS2: Sync errors after restarting datasync-connectors

update:
reinstalling SLES resolved the issue.
0 Likes
Highlighted
Honored Contributor.
Honored Contributor.

Re: GMS2: Sync errors after restarting datasync-connectors

Hi, Claus

Sorry for warming up an old thread.

How did you reinstall SLES?
May be you changed some network parameters?

I have same issue here. After rebuild of gms database the logs are full of errors, timeouts and invalid keys.

Go
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.