DavudOeden
New Member.
1683 views

GW 18.1 how to upgrade MTA & POA Database ?

Hello,

we've upgraded GW 18.0.2 to 18.1 with the install.sh script.
But after restarting all agents, GW shows us DB Ver 1800 in the admin console but the agents are running 18.1.
How do we perform the database update/upgrade to 18.1. ?

And the second problem is, GWAdmin Console does not work anymore with Google Chrome.

Regards,
D.O.
Labels (1)
0 Likes
14 Replies
NoDau Honored Contributor.
Honored Contributor.

Re: GW 18.1 how to upgrade MTA & POA Database ?

Hi,

just double click the Groupwise Install icon on the sles server an run the upgrade option on the primary domain. This will upgrade the domain and postoffice to the latest build. Restart the admin service afterwards.

Norman
BahSIG Bahn-Signalbau GmbH
0 Likes
Knowledge Partner
Knowledge Partner

Re: GW 18.1 how to upgrade MTA & POA Database ?

On 12.11.2018 16:14, DavudOeden wrote:
>
> Hello,
>
> we've upgraded GW 18.0.2 to 18.1 with the install.sh script.
> But after restarting all agents, GW shows us DB Ver 1800 in the admin
> console but the agents are running 18.1.
> How do we perform the database update/upgrade to 18.1. ?


As usual, by running the configuration and following the link you get.

> And the second problem is, GWAdmin Console does not work anymore with
> Google Chrome.


Yes. Workaround: Disable TLS1.3.

CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
0 Likes
warper2 Outstanding Contributor.
Outstanding Contributor.

Re: GW 18.1 how to upgrade MTA & POA Database ?

OK what is the correct database version after the upgrade. I have upgraded to 18.1. So much is broke. The only thing that will auth is the gw client.
This was upgraded from 18.02. to 18.1.
0 Likes
Knowledge Partner
Knowledge Partner

Re: GW 18.1 how to upgrade MTA & POA Database ?

On 12.11.2018 19:54, warper2 wrote:
>
> OK what is the correct database version after the upgrade.


1810

> I have
> upgraded to 18.1. So much is broke. The only thing that will auth is the
> gw client.


More info please. Which version of the client, and what fails?

> This was upgraded from 18.02. to 18.1.


And did you run the configuration, or just the install?

CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
0 Likes
highvoltage Absent Member.
Absent Member.

Re: GW 18.1 how to upgrade MTA & POA Database ?

I am having same problem as warper2
In that GW client is only thing that can access Groupwise on a Windows 2016 standard server at this time.
Using client 18.02 afraid to upgrade that to 18.1 at this time since that is working.
Can not access via IMAP, but could right before install. Using it to access email from android phones. After upgrade phones say Sign-in failed "Server password has changed. Enter the new password."
I upgraded via Install after expanding the zip file.
Have the problem accessing with Chrome after update but Firefox works.
My database is still saying 1800

0 Likes
Knowledge Partner
Knowledge Partner

Re: GW 18.1 how to upgrade MTA & POA Database ?

On 13.11.2018 13:36, highvoltage wrote:
>
> I am having same problem as warper2
> In that GW client is only thing that can access Groupwise on a Windows
> 2016 standard server at this time.
> Using client 18.02 afraid to upgrade that to 18.1 at this time since
> that is working.
> Can not access via IMAP, but could right before install. Using it to
> access email from android phones. After upgrade phones say Sign-in
> failed "Server password has changed. Enter the new password."
> I upgraded via Install after expanding the zip file.
> Have the problem accessing with Chrome after update but Firefox works.
> My database is still saying 1800


You *MUST* run the configuration too on a full version upgrade (which
this is), and follow the instructions to upgrade the database. Then
everything will start working again.

CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
0 Likes
schleissheimer Super Contributor.
Super Contributor.

Re: GW 18.1 how to upgrade MTA & POA Database ?

Hi,
I had the same problem and had to copy over *.dc files by hand.

# cd /opt/novell/groupwise/admin/data
# cp *.dc /yourgroupwise/do/
# cp *.dc /yourgroupwise/po/

Not sure if that could work for you...

cu SveN
0 Likes
highvoltage Absent Member.
Absent Member.

Re: GW 18.1 how to upgrade MTA & POA Database ?

mrosen;2490644 wrote:
On 13.11.2018 13:36, highvoltage wrote:

You *MUST* run the configuration too on a full version upgrade (which
this is), and follow the instructions to upgrade the database. Then
everything will start working again.

CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de


I do not understand what you are saying by " Must run the configuration too on full version upgrade"

Logged on to server as administrator.
What I did was downloaded the gw18.1.0_client_win_multi.exe
extracted the file
Double clicked on "Setup"
Clicked on "Yes" to Do you want to allow this app to make changes to your device - Groupwise Launcher"
Double clicked on Groupwise server.
Then accepted all of the defaults.
When it was finished I rebooted the server.

So what did I do wrong or what do I need to do?

Thanks,
Jack

0 Likes
Knowledge Partner
Knowledge Partner

Re: GW 18.1 how to upgrade MTA & POA Database ?

Hi.

On 13.11.2018 22:54, highvoltage wrote:
> I do not understand what you are saying by " Must run the configuration
> too on full version upgrade"
>
> Logged on to server as administrator.
> What I did was downloaded the gw18.1.0_client_win_multi.exe


That is the client. I'm talking about the groupwise server.

Updating Groupwise Server components is a two-step process.

1. Install the Software.
2. Run the Configuration (through the link to the admin interface) to
update the Databases.

You (and most likely everybody else with the same issue) didn't do the
2nd step, which means you're still running GW1800 Databases, and no
GW1810 client can login to it. That includes IMAP and webaccess, as well
as every 18.1 client. Old 18.0X clients will work.

It's all in the docs.

CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
0 Likes
Knowledge Partner
Knowledge Partner

Re: GW 18.1 how to upgrade MTA & POA Database ?

On 13.11.2018 15:54, Schleissheimer wrote:
>
> Hi,
> I had the same problem and had to copy over *.dc files by hand.


So even you didn't run the configuration. 😞

CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
0 Likes
Highlighted
schleissheimer Super Contributor.
Super Contributor.

Re: GW 18.1 how to upgrade MTA & POA Database ?

Hi Massimo,
support advised me to copy over dc files since they were able to reproduce... strange.

neverthless: of course you are right, did no configuration run 😉
but is it save to run the configuration now again... 2 weeks after upgrade and copying dc files by hand?

cu SveN
0 Likes
Knowledge Partner
Knowledge Partner

Re: GW 18.1 how to upgrade MTA & POA Database ?

On 14.11.2018 14:06, Schleissheimer wrote:
>
> Hi Massimo,
> support advised me to copy over dc files since they were able to
> reproduce... strange.
>
> neverthless: of course you are right, did no configuration run 😉
> but is it save to run the configuration now again... 2 weeks after
> upgrade and copying dc files by hand?


Yes, it's safe. It might be unnecessary, but I just don't know what the
configuration does besides copying the .dc files. It also depends on
what version you come from. To be safe, lways run the configuration and
then follow the link to the admin interface with the upgrade database
option.

CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
0 Likes
bkesting Honored Contributor.
Honored Contributor.

Re: GW 18.1 how to upgrade MTA & POA Database ?

I think a lot of folk, myself anyway, thought that 18.1 was just a minor upgrade from 18.0.x and therefore didn't require the running of the "Configuration" option, as that in the past hadn't needed to be run on minor updates.

I must have initially misread that this was considered a major upgrade. Anyway, I ran the config and everything is working fine for me.
0 Likes
Knowledge Partner
Knowledge Partner

Re: GW 18.1 how to upgrade MTA & POA Database ?

On 14.11.2018 16:36, bkesting wrote:
>
> I think a lot of folk, myself anyway, thought that 18.1 was just a minor
> upgrade from 18.0.x and therefore didn't require the running of the
> "Configuration" option, as that in the past hadn't needed to be run on
> minor updates.


And that, of course is absolutel understandable, and the version number
scheme chosen by Micro Focus is very unfortunate.

> I must have initially misread that this was considered a major upgrade.
> Anyway, I ran the config and everything is working fine for me.


Great.

CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.