Valued Contributor.
Valued Contributor.
255 views

GW 2012 unable to add user to restore area

I used to do this in my sleep.

Created a restore area in ConsoleOne on Linux. Restore area is on linux, same server as PO. Cannot add members.

When trying to add can see the domains, grey-ish, but nothing below.  In other words cannot add the domains shown and cannot "drill down" to see other objects, s

Ideas?

Labels (1)
0 Likes
22 Replies
Highlighted
Valued Contributor.
Valued Contributor.

Re: GW 2012 unable to add user to restore area

This appears to be an issue with eDirectory,  rights, snapins, or ???

The graft objects dialog box items are all grayed out.  Tools, Utilities, check eDirectory schema is  grayed out.

Seems there used to be  a way to install snapins again, without a lot of fuss.

 

0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: GW 2012 unable to add user to restore area

If you download the "current" build here

http://download.novell.com/Download?buildid=Zl8580Kelx4~

you'll find the snapins in the "admin\c1admin" folder. You can simply copy them in the C1 directory structure. Nevertheless i'd doubt it's a C1 issue, rather something related to GW rights or the client OS you're running C1 from.

 

0 Likes
Highlighted
Valued Contributor.
Valued Contributor.

Re: GW 2012 unable to add user to restore area

I tend to agree with you about rights being the problem.  I see this from two installations of ConsoleOne, on Linux.

Do you know where I can find a listing of what right a GW admin requires?  Seems there are sufficient as is, and dsrepair shows no errors.  Schema, according to the check via ConsoleOne is sufficient for GW.

0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: GW 2012 unable to add user to restore area

https://www.novell.com/documentation/groupwise2012/gw2012_guide_admin/data/a4i1mi3.html?view=print

Other than that, IIRC, some stuff is intentionally greyed out depending on the currently highlighted object. You had e.g. to have the tree object highlighted in order to have "Tools -> Utilities -> Check Schema". To see "Grafting" you had to have a container object marked in the eDir view.

 

 

0 Likes
Highlighted
Frequent Contributor.
Frequent Contributor.

Re: GW 2012 unable to add user to restore area

I guess I'm at a loss.   The rignts look sufficient.  Checking "Effective Rights" in any case.   I have not had the inclination, yet, to go looking for the explicit rights.    Been a while.

I suspect an eDirectory issue of some kind, even though dsrepair runs without error.

Each time I enter the Restore area dialog box in ConsoleOne, I see this on the terminal screen I launched it from:

Novell JClient 1.3.1182-1.3.1182. Copyright 1999 Novell Inc. All Rights Reserved.
node.getText[Entry Rights]
Members: null
About to commit Members: null
Members: null
About to commit Members: null
Members: null

Seems like I recall there would only be errors or unexpected behavior put out to the console. 

Thanks.

Oh , also, I did not see the property "Description Member" in either the Domain or the Post office rights list, only "Description".   No idea if that matters.

 

0 Likes
Highlighted
Frequent Contributor.
Frequent Contributor.

Re: GW 2012 unable to add user to restore area

FWIW, I am the OP.  Only the names have been changed to obscure the guilty.

 

0 Likes
Highlighted
Frequent Contributor.
Frequent Contributor.

Re: GW 2012 unable to add user to restore area

The link appears to be a Windows only build. This is an all Linux install.
0 Likes
Highlighted
Frequent Contributor.
Frequent Contributor.

Re: GW 2012 unable to add user to restore area

OK found the linux version.
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: GW 2012 unable to add user to restore area

This was intentionally. Wanted you to try from a Windows Workstation. XP or Windows 7. If you try this you'll have to make sure that "File Caching" is set "off" and "File Commit" "on" in the client properties if the domain DB you access is located on a NCP share.

 

0 Likes
Highlighted
Valued Contributor.
Valued Contributor.

Re: GW 2012 unable to add user to restore area

Ah, I see.  I'll see if I can manage that and post the results.

I did see some oddities that appear to be eDirectory related, so also working that in the eDir forum.

 

0 Likes
Highlighted
Valued Contributor.
Valued Contributor.

Re: GW 2012 unable to add user to restore area

Consoleone starts and shuts down immediately on Windows 7, latest windows patches.  The splash screen then the opening view, then winks out.

 

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.