Highlighted
Super Contributor.
Super Contributor.
146 views

GW-Mobility: The remote server returned an error: (404)Not Found

Hi,

we now have an problem, with our GW-Mobility server.

Yesterday in the afternoon, sameone must puch an the button and our GW-Mobility stop to work.

I have sync a new device and all work fine, because it was my private device I delete the Mail-account on the device. About 5 Minites later my college want to bring an buissines device in sync with the GW-Mobility, with another user-account, and from there on, the GW-Mobilty stop working.

Every time we insert the correct credetials and than we become the error

the request failed. the request failed.
the remote server returned an error: (404)Not Found

The error where displayd in both cases, if we connect from outside witht the external-credentials and if we connect from inside withe internal name or the ip of the gms-server.

We restartet the gms service and the server several times, we opened the entire firewall on the gms, nothing, everytime the same error. If we connect to the dashboard of the gms, all sems to work correctly, there are no errors

Labels (1)
0 Likes
16 Replies
Highlighted
Knowledge Partner
Knowledge Partner

Re: GW-Mobility: The remote server returned an error: (404)Not Found

Just to verify the basics ...

 

If you check your web frontend for GMS, you see that both services are up and running?

If you check via command line "rcgms status", all services are up and running?

Your postgresql database is up and running?

And you have checked disc space?

Diethmar Rimser
If you like my idea or solution, please show it and click i.e. on "Like"!
0 Likes
Highlighted
Super Contributor.
Super Contributor.

Re: GW-Mobility: The remote server returned an error: (404)Not Found


@Rimser wrote:

Just to verify the basics ...

 

If you check your web frontend for GMS, you see that both services are up and running?

If you check via command line "rcgms status", all services are up and running?

Your postgresql database is up and running?

And you have checked disc space?



rcgms status
Checking for gms monitor: running
Checking for gms config: running
Checking for gms engine: running
Checking for gms web admin: running
Checking for gms agent manager: running
● gms.service - LSB: Start datasync services
Loaded: loaded (/etc/init.d/gms; generated; vendor preset: disabled)
Active: active (exited) since Wed 2020-07-01 07:38:24 CEST; 1h 48min ago
Docs: man:systemd-sysv-generator(8)
Process: 19184 ExecStop=/etc/init.d/gms stop (code=exited, status=0/SUCCESS)
Process: 19470 ExecStart=/etc/init.d/gms start (code=exited, status=0/SUCCESS)
Tasks: 0
CGroup: /system.slice/gms.service

 

Postgres is running to

 

Diskspace: 196.8 GB /  205.9 GB available

 

I can sync users, resync user, import new user to GMS. But I can´t connect devices to GMS

0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: GW-Mobility: The remote server returned an error: (404)Not Found

Hi @landrich 

From a browser external to your network, go to the URL of your GMS server on port 443 (default, change it if you've changed the port your devices sync on) and you should get a 403 response from your GMS server that looks like this:

 

laurabuckley_0-1593594893725.png

If you are not getting that in a browser from an external/public network then that would indicate that your GMS server is not reachable.

Cheers,

Laura

 

Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: GW-Mobility: The remote server returned an error: (404)Not Found

Well, sounds good.

Did you try to re-install the iso file.

i.e.: mount -o loop iso.file /mnt, change to /mnt and run install.sh. Usually no values or settings will be deleted.

Diethmar Rimser
If you like my idea or solution, please show it and click i.e. on "Like"!
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: GW-Mobility: The remote server returned an error: (404)Not Found

One more idea

Do you use dsapp? dsapp can do a lot of checks for you (including vacuum and index your database). 

Diethmar Rimser
If you like my idea or solution, please show it and click i.e. on "Like"!
0 Likes
Highlighted
Super Contributor.
Super Contributor.

Re: GW-Mobility: The remote server returned an error: (404)Not Found


@laurabuckley wrote:

Hi @landrich 

From a browser external to your network, go to the URL of your GMS server on port 443 (default, change it if you've changed the port your devices sync on) and you should get a 403 response from your GMS server that looks like this:

 

laurabuckley_0-1593594893725.png

If you are not getting that in a browser from an external/public network then that would indicate that your GMS server is not reachable.

Cheers,

Laura

 


It´s exactly what´s displayed in the browser from internal and from external

0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: GW-Mobility: The remote server returned an error: (404)Not Found

Good idea, Laura. Maybe it's not a GMS problem but a network issue (firewall, proxy, subnet mask, ...)

Diethmar Rimser
If you like my idea or solution, please show it and click i.e. on "Like"!
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: GW-Mobility: The remote server returned an error: (404)Not Found

... and you checked the Device configuration in the GMS Admin Console to ensure that "Quarantine new devices" has not been enabled?

 

 

Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
Highlighted
Super Contributor.
Super Contributor.

Re: GW-Mobility: The remote server returned an error: (404)Not Found

Hello,

No i don´t tried to re-install

Yes the checkpox for "Quarantine new devices" is disabeld

Now I was eable to bring my private device in GMS but a few minutes later when I tried another user, the same problem and on other diveces to. So I delete the account from my private device an tried to re-create with Outlook, but after insert the mailadress I only can use pop3 or imap, no other options will show up and an other mailclient shows the erro above.

I think the server is bullying me 😞

0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: GW-Mobility: The remote server returned an error: (404)Not Found

... set the log level on your GMS server to DEBUG... then look in the mobility-agent.log file and see if there is evidence of the devices connecting to GMS and, if so, what errors are being logged...

 

Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: GW-Mobility: The remote server returned an error: (404)Not Found

@landrich 

Reinstalling does not hurt! I had to do it many times because the monitor was empty or showed zero values.

Diethmar Rimser
If you like my idea or solution, please show it and click i.e. on "Like"!
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.