Highlighted
Respected Contributor.
Respected Contributor.
128 views

GW sending emails delayed / TCP write errors at GWIA

Jump to solution
Hi all,

today was a bad day.
 
All servers were shut down after a power failure because of the raining weather yesterday.
 
I booted up the servers today again - so far so good.
 
But after a couple of hours i recognized, that Emails from GW were send delayed automatically and also many emails from external user are don't into the inbox.

The delay time is different - one email tooks 40 minutes, another one took 2 hours to be send.

You can't work like that in business, so i have to fix the problem quickly.

I started to check every service of GW try some restarts of the the GW Services and then i found in the GWIA console that are over 40 emails are in the delayed message queue folder and currently i've got 98 TCP/IP errors.
 
There are currently still 10 Emails in queue - after 8 hours!!
 
We use GW18 on OES2018.
 
Logfile of GWIA writes as example for all emails:
 
20:43:53 2B2F MSG 1233569 Analyzing result file: /media/nss/GWIA/dom/wpgate/gwia/result/ref0edb7.013
20:43:53 2B2F MSG 1233569 Detected error on SMTP command
20:43:53 2B2F MSG 1233569  Command:  ***********.com
20:43:53 2B2F MSG 1233569  Response: 421 Too many concurrent SMTP connections; please try again later.
 
MTP Status in the console writes:

Current StatusUnavailableUnavailable
Last Closed  
Last Opened  
Last Closure Reason  

 

Do anybody of the masterminds here have approaches for me?

Cheers,
Tom

 

Labels (1)
0 Likes
1 Solution

Accepted Solutions
Highlighted
Knowledge Partner
Knowledge Partner

Re: GW sending emails delayed / TCP write errors at GWIA

Jump to solution

This looks like you're using a relay host outbound, and said relayhost doesn't like so many queued messages coming in from your GWIA simultaneously.

 

Your problem is *NOT* groupwise, but the next hop.

CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de

View solution in original post

6 Replies
Highlighted
Knowledge Partner
Knowledge Partner

Re: GW sending emails delayed / TCP write errors at GWIA

Jump to solution

Hi Tom,

I know your feeling - because I am from Austria too. Yes, it was heavy rain in Austria.

But there is no reason to stop mails!

My suggestion: rename existing wpcsout and wpcsin directories for GWIA, MTA and POA and restart these services. Maybe you start with GWIA, then try your MTA and if there is no success try your POA too. In case of GWIA you can do the same with send und receive directories.
Restarting a service will recreate these directories. Afterwards move old entries from your renamed directories to the new directories.
Check your logs if you see any strange errors. Maybe you file system is damaged.

If there is no success with your queuing directories then rename database gwac.db in your GWIA directory and restart your GWIA.

Let's start with these steps.

Diethmar

Diethmar Rimser
If you like my idea or solution, please show it and click i.e. on "Like"!
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: GW sending emails delayed / TCP write errors at GWIA

Jump to solution

This looks like you're using a relay host outbound, and said relayhost doesn't like so many queued messages coming in from your GWIA simultaneously.

 

Your problem is *NOT* groupwise, but the next hop.

CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de

View solution in original post

Highlighted
Respected Contributor.
Respected Contributor.

Re: GW sending emails delayed / TCP write errors at GWIA

Jump to solution

Hello @Rimser ,

thanks for your answer.

I follow the steps but unfortunately without success.

The emails are getting more and more in the queue folder 🙄

Tom

Tags (1)
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: GW sending emails delayed / TCP write errors at GWIA

Jump to solution

Hi Tom,

which queue? Only one single queue - i.e. send? Maybe we have to follow Massimo's approach ...

Diethmar Rimser
If you like my idea or solution, please show it and click i.e. on "Like"!
0 Likes
Highlighted
Respected Contributor.
Respected Contributor.

Re: GW sending emails delayed / TCP write errors at GWIA

Jump to solution

@mrosen@Rimser 

Hey guys,
 
problem is solved now - we are victims of some botnet attacks,
which tryed to come into our server trough smtp.

This was the reason of the many connection requests and because of this the firewall blocked the outgoing mails.

I blocked the attack ip's and now everthing is working fine again.

Thanks for support.


Cheers,
Tom

Highlighted
Knowledge Partner
Knowledge Partner

Re: GW sending emails delayed / TCP write errors at GWIA

Jump to solution

So the rain swashed in an attack 😇

Diethmar Rimser
If you like my idea or solution, please show it and click i.e. on "Like"!
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.