Highlighted
Not applicable
653 views

GW2014R2SP1: Do not show any user inside GAC after creating userobject for external PO

Good afrernoon,

we have a special problem with GAC.

The customer needs create external mail addresses inside GW Global
Address Book. No problem, we created external domain, inside external
postoffice and finaly one external user inside external PO.

But we have discovered there are no user shown inside GAC, no standard,
no external. It seems, there are no user defined but the user objects are
there, e.g. we can add them into groups, we can login into GW and so on.

The problem is only with GAC.

The solutin is to delete external PO with all users and resources and
suddenly the users object are back again.


In our testing site there is no problem with it at all. One different
thing is the customer has used external MS AD source for users.


Any idea? What can be wrong?

---

Thanks,

-Jan Dus
Labels (1)
0 Likes
9 Replies
Highlighted
Knowledge Partner
Knowledge Partner

On Fri, 05 May 2017 11:45:22 GMT, dus2002
<dus2002@no-mx.forums.microfocus.com> wrote:

>Good afrernoon,
>
>we have a special problem with GAC.
>
>The customer needs create external mail addresses inside GW Global
>Address Book. No problem, we created external domain, inside external
>postoffice and finaly one external user inside external PO.
>
>But we have discovered there are no user shown inside GAC, no standard,
>no external. It seems, there are no user defined but the user objects are
>there, e.g. we can add them into groups, we can login into GW and so on.
>
>The problem is only with GAC.
>
>The solutin is to delete external PO with all users and resources and
>suddenly the users object are back again.
>
>
>In our testing site there is no problem with it at all. One different
>thing is the customer has used external MS AD source for users.
>
>
>Any idea? What can be wrong?


What is GAC? Don't believe I've heard that acronym yet.

--
Ken
Knowledge Partner

If this post was helpful and you are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

Create and vote for enhancements!
https://www.microfocus.com/products/enhancement-request.html
--
Ken
Knowledge Partner

Create and vote for enhancements in the Idea Exchange forums within this community!
0 Likes
Highlighted
Not applicable

On Fri, 05 May 2017 12:47:49 +0000, KeN Etter wrote:

> On Fri, 05 May 2017 11:45:22 GMT, dus2002
> <dus2002@no-mx.forums.microfocus.com> wrote:
>
>>Good afrernoon,
>>
>>we have a special problem with GAC.
>>
>>The customer needs create external mail addresses inside GW Global
>>Address Book. No problem, we created external domain, inside external
>>postoffice and finaly one external user inside external PO.
>>
>>But we have discovered there are no user shown inside GAC, no standard,
>>no external. It seems, there are no user defined but the user objects
>>are there, e.g. we can add them into groups, we can login into GW and so
>>on.
>>
>>The problem is only with GAC.
>>
>>The solutin is to delete external PO with all users and resources and
>>suddenly the users object are back again.
>>
>>
>>In our testing site there is no problem with it at all. One different
>>thing is the customer has used external MS AD source for users.
>>
>>
>>Any idea? What can be wrong?

>
> What is GAC? Don't believe I've heard that acronym yet.


Good afternoon,

sorry for my specification. GAC means GroupWise Administration Console.

---

Thanks,

-Jan
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

On Fri, 05 May 2017 15:04:27 GMT, dus2002
<dus2002@no-mx.forums.microfocus.com> wrote:

>On Fri, 05 May 2017 12:47:49 +0000, KeN Etter wrote:
>
>> On Fri, 05 May 2017 11:45:22 GMT, dus2002
>> <dus2002@no-mx.forums.microfocus.com> wrote:
>>
>>>Good afrernoon,
>>>
>>>we have a special problem with GAC.
>>>
>>>The customer needs create external mail addresses inside GW Global
>>>Address Book. No problem, we created external domain, inside external
>>>postoffice and finaly one external user inside external PO.
>>>
>>>But we have discovered there are no user shown inside GAC, no standard,
>>>no external. It seems, there are no user defined but the user objects
>>>are there, e.g. we can add them into groups, we can login into GW and so
>>>on.
>>>
>>>The problem is only with GAC.
>>>
>>>The solutin is to delete external PO with all users and resources and
>>>suddenly the users object are back again.
>>>
>>>
>>>In our testing site there is no problem with it at all. One different
>>>thing is the customer has used external MS AD source for users.
>>>
>>>
>>>Any idea? What can be wrong?

>>
>> What is GAC? Don't believe I've heard that acronym yet.

>
>Good afternoon,
>
>sorry for my specification. GAC means GroupWise Administration Console.


Ah, I should have guessed...I just think of it as GWAdmin.
So they create a user in GAC and then it disappears?
Maybe they have a filter enabled?

--
Ken
Knowledge Partner

If this post was helpful and you are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

Create and vote for enhancements!
https://www.microfocus.com/products/enhancement-request.html
--
Ken
Knowledge Partner

Create and vote for enhancements in the Idea Exchange forums within this community!
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

On Fri, 05 May 2017 15:04:27 GMT, dus2002
<dus2002@no-mx.forums.microfocus.com> wrote:

>On Fri, 05 May 2017 12:47:49 +0000, KeN Etter wrote:
>
>> On Fri, 05 May 2017 11:45:22 GMT, dus2002
>> <dus2002@no-mx.forums.microfocus.com> wrote:
>>
>>>Good afrernoon,
>>>
>>>we have a special problem with GAC.
>>>
>>>The customer needs create external mail addresses inside GW Global
>>>Address Book. No problem, we created external domain, inside external
>>>postoffice and finaly one external user inside external PO.
>>>
>>>But we have discovered there are no user shown inside GAC, no standard,
>>>no external. It seems, there are no user defined but the user objects
>>>are there, e.g. we can add them into groups, we can login into GW and so
>>>on.
>>>
>>>The problem is only with GAC.
>>>
>>>The solutin is to delete external PO with all users and resources and
>>>suddenly the users object are back again.
>>>
>>>
>>>In our testing site there is no problem with it at all. One different
>>>thing is the customer has used external MS AD source for users.
>>>
>>>
>>>Any idea? What can be wrong?

>>
>> What is GAC? Don't believe I've heard that acronym yet.

>
>Good afternoon,
>
>sorry for my specification. GAC means GroupWise Administration Console.


Read through your original post again. So it appears that the
existence of an external PO causes all user objects to not display.
I've not seen that and I have external objects. I'll ask around.

--
Ken
Knowledge Partner

If this post was helpful and you are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

Create and vote for enhancements!
https://www.microfocus.com/products/enhancement-request.html
--
Ken
Knowledge Partner

Create and vote for enhancements in the Idea Exchange forums within this community!
0 Likes
Highlighted
Not applicable

On Fri, 05 May 2017 21:16:03 +0000, KeN Etter wrote:

> On Fri, 05 May 2017 15:04:27 GMT, dus2002
> <dus2002@no-mx.forums.microfocus.com> wrote:
>
>>On Fri, 05 May 2017 12:47:49 +0000, KeN Etter wrote:
>>
>>> On Fri, 05 May 2017 11:45:22 GMT, dus2002
>>> <dus2002@no-mx.forums.microfocus.com> wrote:
>>>
>>>>Good afrernoon,
>>>>
>>>>we have a special problem with GAC.
>>>>
>>>>The customer needs create external mail addresses inside GW Global
>>>>Address Book. No problem, we created external domain, inside external
>>>>postoffice and finaly one external user inside external PO.
>>>>
>>>>But we have discovered there are no user shown inside GAC, no
>>>>standard, no external. It seems, there are no user defined but the
>>>>user objects are there, e.g. we can add them into groups, we can login
>>>>into GW and so on.
>>>>
>>>>The problem is only with GAC.
>>>>
>>>>The solutin is to delete external PO with all users and resources and
>>>>suddenly the users object are back again.
>>>>
>>>>
>>>>In our testing site there is no problem with it at all. One different
>>>>thing is the customer has used external MS AD source for users.
>>>>
>>>>
>>>>Any idea? What can be wrong?
>>>
>>> What is GAC? Don't believe I've heard that acronym yet.

>>
>>Good afternoon,
>>
>>sorry for my specification. GAC means GroupWise Administration Console.

>
> Read through your original post again. So it appears that the existence
> of an external PO causes all user objects to not display.
> I've not seen that and I have external objects. I'll ask around.


Good morning,

I have created SR # 101068273981 with Micro Focus support.

This situation is double dutch for me, we use this external domains, post
offices and users with other installation without any problem. Even I am
unable to replicate it elsewhere.

---

-Jan
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

On Wed, 10 May 2017 10:11:40 GMT, dus2002
<dus2002@no-mx.forums.microfocus.com> wrote:

>On Fri, 05 May 2017 21:16:03 +0000, KeN Etter wrote:
>
>> On Fri, 05 May 2017 15:04:27 GMT, dus2002
>> <dus2002@no-mx.forums.microfocus.com> wrote:
>>
>>>On Fri, 05 May 2017 12:47:49 +0000, KeN Etter wrote:
>>>
>>>> On Fri, 05 May 2017 11:45:22 GMT, dus2002
>>>> <dus2002@no-mx.forums.microfocus.com> wrote:
>>>>
>>>>>Good afrernoon,
>>>>>
>>>>>we have a special problem with GAC.
>>>>>
>>>>>The customer needs create external mail addresses inside GW Global
>>>>>Address Book. No problem, we created external domain, inside external
>>>>>postoffice and finaly one external user inside external PO.
>>>>>
>>>>>But we have discovered there are no user shown inside GAC, no
>>>>>standard, no external. It seems, there are no user defined but the
>>>>>user objects are there, e.g. we can add them into groups, we can login
>>>>>into GW and so on.
>>>>>
>>>>>The problem is only with GAC.
>>>>>
>>>>>The solutin is to delete external PO with all users and resources and
>>>>>suddenly the users object are back again.
>>>>>
>>>>>
>>>>>In our testing site there is no problem with it at all. One different
>>>>>thing is the customer has used external MS AD source for users.
>>>>>
>>>>>
>>>>>Any idea? What can be wrong?
>>>>
>>>> What is GAC? Don't believe I've heard that acronym yet.
>>>
>>>Good afternoon,
>>>
>>>sorry for my specification. GAC means GroupWise Administration Console.

>>
>> Read through your original post again. So it appears that the existence
>> of an external PO causes all user objects to not display.
>> I've not seen that and I have external objects. I'll ask around.

>
>Good morning,
>
>I have created SR # 101068273981 with Micro Focus support.
>
>This situation is double dutch for me, we use this external domains, post
>offices and users with other installation without any problem. Even I am
>unable to replicate it elsewhere.


Ok. I haven't come up with anything. I also use external objects
without a problem. Please post back after you have a resolution, it
would be helpful to hear what the issue was.

--
Ken
Knowledge Partner

If this post was helpful and you are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

Create and vote for enhancements!
https://www.microfocus.com/products/enhancement-request.html
--
Ken
Knowledge Partner

Create and vote for enhancements in the Idea Exchange forums within this community!
0 Likes
Highlighted
Not applicable

On Wed, 10 May 2017 12:53:14 +0000, KeN Etter wrote:

> On Wed, 10 May 2017 10:11:40 GMT, dus2002
> <dus2002@no-mx.forums.microfocus.com> wrote:
>
>>On Fri, 05 May 2017 21:16:03 +0000, KeN Etter wrote:
>>
>>> On Fri, 05 May 2017 15:04:27 GMT, dus2002
>>> <dus2002@no-mx.forums.microfocus.com> wrote:
>>>
>>>>On Fri, 05 May 2017 12:47:49 +0000, KeN Etter wrote:
>>>>
>>>>> On Fri, 05 May 2017 11:45:22 GMT, dus2002
>>>>> <dus2002@no-mx.forums.microfocus.com> wrote:
>>>>>
>>>>>>Good afrernoon,
>>>>>>
>>>>>>we have a special problem with GAC.
>>>>>>
>>>>>>The customer needs create external mail addresses inside GW Global
>>>>>>Address Book. No problem, we created external domain, inside
>>>>>>external postoffice and finaly one external user inside external PO.
>>>>>>
>>>>>>But we have discovered there are no user shown inside GAC, no
>>>>>>standard, no external. It seems, there are no user defined but the
>>>>>>user objects are there, e.g. we can add them into groups, we can
>>>>>>login into GW and so on.
>>>>>>
>>>>>>The problem is only with GAC.
>>>>>>
>>>>>>The solutin is to delete external PO with all users and resources
>>>>>>and suddenly the users object are back again.
>>>>>>
>>>>>>
>>>>>>In our testing site there is no problem with it at all. One
>>>>>>different thing is the customer has used external MS AD source for
>>>>>>users.
>>>>>>
>>>>>>
>>>>>>Any idea? What can be wrong?
>>>>>
>>>>> What is GAC? Don't believe I've heard that acronym yet.
>>>>
>>>>Good afternoon,
>>>>
>>>>sorry for my specification. GAC means GroupWise Administration
>>>>Console.
>>>
>>> Read through your original post again. So it appears that the
>>> existence of an external PO causes all user objects to not display.
>>> I've not seen that and I have external objects. I'll ask around.

>>
>>Good morning,
>>
>>I have created SR # 101068273981 with Micro Focus support.
>>
>>This situation is double dutch for me, we use this external domains,
>>post offices and users with other installation without any problem. Even
>>I am unable to replicate it elsewhere.

>
> Ok. I haven't come up with anything. I also use external objects
> without a problem. Please post back after you have a resolution, it
> would be helpful to hear what the issue was.


Good afternoon,

together with Microfocus we've found the solution finaly.


On the Users page, I have added Internet Domain as a sortable field and
this was the cause of problem, because external user has no Internet
Domain during creating process via GAC. The solution was easy -- remove
the Internet Domain field from the Users page.

The other solution is opening the properties of the external user, go to
the Internet Addressing tab and assign an Internet domain name to the
user. But if we cannot see user object this is no so easy, I can manage
to do it via REST API.

---

Thanks,

-Jan
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Thank you for posting the resolution. Helps everyone learn.

--
Ken
Knowledge Partner

If this post was helpful and you are logged into the web interface,
please show your appreciation and click on the star below... Thanks!

Create and vote for enhancements!
https://www.microfocus.com/products/enhancement-request.html
--
Ken
Knowledge Partner

Create and vote for enhancements in the Idea Exchange forums within this community!
0 Likes
Highlighted
Not applicable

On Mon, 15 May 2017 14:19:17 +0000, KeN Etter wrote:

> Thank you for posting the resolution. Helps everyone learn.


You are welcome.

---

-Jan

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.