raronson Super Contributor.
Super Contributor.
941 views

GWIA 18.1.0 crashes after preplasing certificate

We have groupwise-server-18.1.0-132269.x86_64 deployed on sles 12 sp3. It's been running well for months. Last week we replaced our Digicert certificates that were set to expire across our entire system, that's 5 POA, 5 MTAs and 4 GWIAs. I use this gwia to send and receive to our mail filter company and this system is sued for imap connections.

This is the only host that has problems. I'm getting general protection errors from libpthread-2022.so at least once if not 3 or 4 times per day. I've got GWmonitor and gwha running and it's doing a good job of restartinging the agent.

I've checked the gwia log in debug mode, made sure there's enough space on the filesystem, and tried unsuccessfully to correlate firewall logs with the time that the agent fails. So far no patters. If anyone has some ideas I'd live to hear them before opening an incident with Microfocus.

Thanks
Rob A.
Labels (1)
0 Likes
3 Replies
Micro Focus Expert
Micro Focus Expert

Re: GWIA 18.1.0 crashes after preplasing certificate

Hi Rob,

Seeing as it's on SLES12 I strongly recommend following the instructions in this TID: https://support.microfocus.com/kb/doc.php?id=7019037

After you have done all of the TID, run this command:

ldd /opt/novell/groupwise/agents/bin/gwia

In the output from the above command libpthread.so.0 should reference /lib64/noelision/libpthread.so.0

If you do open an SR the above would probably be amongst the first steps they'd ask you to do.

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
raronson Super Contributor.
Super Contributor.

Re: GWIA 18.1.0 crashes after preplasing certificate

Thanks Laura. I'd seen this information but discounted it believing the issues would have been resolved on SLES12 SP3 and Groupwise 18.1. I was also thinking it could be something else because it had worked for months prior to replacing the certificate.


laurabuckley;2494168 wrote:
Hi Rob,

Seeing as it's on SLES12 I strongly recommend following the instructions in this TID: https://support.microfocus.com/kb/doc.php?id=7019037

After you have done all of the TID, run this command:

ldd /opt/novell/groupwise/agents/bin/gwia

In the output from the above command libpthread.so.0 should reference /lib64/noelision/libpthread.so.0

If you do open an SR the above would probably be amongst the first steps they'd ask you to do.

Cheers,
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: GWIA 18.1.0 crashes after preplasing certificate

Hi Rob,

I do not believe the "elision" issue is a GroupWise defect/bug. See here: https://www.suse.com/support/kb/doc/?id=7022289 and look at "Cause".

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.