Highlighted
Absent Member.
Absent Member.
2766 views

GWIA not listening on HTTP port

I recently upgraded our GW8 to new hardware and eventually to 2012 sp1, now I'm seeing the following error in the GWIA log and the GWIA is not listening on its http port.
There is nothing listening on 9850 (default http port for gwia).

****** 04-10-13 10:03:39 ******
10:03:39 F476 ****************** Agent Restarted ******************
10:03:39 F476 MTP: Message Transfer Protocol initialization...
10:03:39 F476 MTP: Queue initialization...
10:03:39 F476 MTP: Queue initialization...
10:03:39 F476 Startup: No frgnames.cfg file found.
10:03:39 F3C7 Starting GWHTTP-Listener
10:03:39 F476 HTTP server running
10:03:40 F476 Error Listen Port is already in use. [856A]
10:03:41 F476 Shutdown of Threads
10:03:42 F476 Shutdown of Threads


After disabling GWIA POP / IMAP / LDAP (setting them to port 0) I'm getting the following(and still no http):

10:08:12 F476 ****************** Agent Restarted ******************
10:08:12 F476 MTP: Message Transfer Protocol initialization...
10:08:12 F476 MTP: Queue initialization...
10:08:12 F476 MTP: Queue initialization...
10:08:12 F476 Startup: No frgnames.cfg file found.
10:08:12 F3E7 Starting GWHTTP-Listener
10:08:12 F476 HTTP server running
10:08:13 F476 Error, Internal Udp Port is unusable. [8911]
10:08:14 F476 Shutdown of Threads
10:08:15 F476 Shutdown of Threads


GWIA is listening on the following ports, 1.2.3.4 being the server ip and I removed the POA connections.
# netstat -pan | grep -i gwia
tcp 0 0 1.2.3.4:7060 0.0.0.0:* LISTEN 12253/gwia
tcp 0 0 0.0.0.0:25 0.0.0.0:* LISTEN 12253/gwia
udp 0 0 0.0.0.0:41547 0.0.0.0:* 12253/gwia


Any ideas ?

Besides this GW is running just fine.
Labels (2)
0 Likes
11 Replies
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: GWIA not listening on HTTP port

What do you get when you do the following: netstat -plan | grep 9850

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: GWIA not listening on HTTP port

laurabuckley;2257225 wrote:
What do you get when you do the following: netstat -plan | grep 9850

Cheers,


GroupWise:~ # netstat -plan | grep 9850
GroupWise:~ #

Nothing.
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: GWIA not listening on HTTP port

Oh ok.

Check to see if the firewall is disabled on the server.

Also, set an HTTP username and password in ConsoleOne then do a full stop and start of GWIA.

Please post back your results.

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: GWIA not listening on HTTP port

One more thing.... if your POA is running on the same box try disabling POP and IMAP on the POA - restart the POA and GWIA.

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: GWIA not listening on HTTP port

laurabuckley;2257233 wrote:
Oh ok.
Check to see if the firewall is disabled on the server.
Also, set an HTTP username and password in ConsoleOne then do a full stop and start of GWIA.
Please post back your results.
Cheers,


Hi Laura,
The firewall is disabled (double checked), there is a http username and password (re-set it) set in C1, a full stop and start did not make a difference.


laurabuckley;2257235 wrote:
One more thing.... if your POA is running on the same box try disabling POP and IMAP on the POA - restart the POA and GWIA.
Cheers,


We're actively using the POA IMAP so that's not something I can disable.

Thanks,
Arjan
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: GWIA not listening on HTTP port

Hi Arjan

For testing purposes disable IMAP on the POA and then, after the necessary restarts, test the HTTP port on GWIA.

If that works then you have decisions to make, live without the GWIA HTTP console, or move IMAP to the GWIA.

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: GWIA not listening on HTTP port

Conz wrote:

> > 10:03:40 F476 Error Listen Port is already in use. [856A]


Unfortunately, this is a problem if ANY port is unhappy. Are you on Linux?
What happens if you telnet to port 25 of your GWIA server? Is it the GWIA or
postfix? Have you checked the box in ConsoleOne to bind GWIA to one address
only? Do you have anything other than 0 in the Message Transfer port for the
GWIA in ConsoleOne?


--
Danita
Novell Knowledge Partner
Time to upgrade to GW 2012!
http://www.caledonia.net/upgrade
http://www.facebook.com/caledonia.net
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: GWIA not listening on HTTP port

I'm going to put the answers step by step:
- Disabling IMAP on POA makes no difference.
- It is indeed unhappy with any port for http.
- Our GW2012 runs on SLES11.2 with OES 11sp1
- Postfix smtp has been disabled (server requires it to send management e-mails), port 25 answers with GWIA.
- GWIA is not exclusively bound to the server ip.
- Our message transfer port is actually set to the default port (7060) and this port is active.

Its just the http port which is refusing to come up, other then that there is no loss of function.
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: GWIA not listening on HTTP port

Try the "Bind Exclusive" option - you've got nothing to loose!

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: GWIA not listening on HTTP port

So I never managed to figure out what was going on here and left it at that till today when I really needed the gwia http to work because of GW2014.

Turns out that even if you have configured a custom port for the GWIA, it *only* listens on port 9850 for http.
At least with GW2014 release 115243. (not entirely sure if this goes for 2012/gw8)

I put the GWIA http port on 9850 and all of a sudden the lights turned green.
Bit of an odd one this .. but I hope this will help anyone else who runs into the same issue.
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: GWIA not listening on HTTP port

Hi,

Many thanks for letting us know the solution to your problem - that way we all learn 🙂

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.