Highlighted
Micro Focus Expert
Micro Focus Expert
1165 views

GWIA stopping/restarting

Good morning,

Just had a new (or perhaps ongoing issue) with my customers GWIA's. Basically when looking through the logs we are seeing something similar to the following:

08:17:34 F47B Processing outbound command...
08:17:34 F47B Restart in progress...
08:17:34 F47B Shutting down thread: GWIMAP-Listener
08:17:34 F47B Shutting down thread: GWPOP-Listener
08:17:34 F47B Shutting down thread: GWHTTP-Listener
08:17:34 F47B Shutting down thread: GWTCP-Dispatcher
08:17:34 EF87 Exiting GWHTTP-Listener
08:17:34 EF0F Exiting GWIMAP-Listener
08:17:34 F009 Exiting GWPOP-Listener
08:17:34 EEBF Exiting GWTCP-Dispatcher
08:17:34 F47B Shutting down thread: GWIMAP-Listener
08:17:34 F47B Shutting down thread: GWPOP-Listener
08:17:34 F47B Shutting down thread: GWHTTP-Listener
08:17:34 F47B Shutting down thread: GWTCP-Dispatcher
08:17:34 F47B Shutting down thread: GWTCP-Monitor
08:17:34 F47B Shutting down thread: GWHTTP-Handler_3
08:17:34 F47B Shutting down thread: GWHTTP-Handler_2
08:17:34 F47B Shutting down thread: GWHTTP-Handler_1
08:17:34 F47B Shutting down thread: GWIMAP-Handler_2
08:17:34 F47B Shutting down thread: GWIMAP-Handler_1
08:17:34 F47B Shutting down thread: GWPOP-Handler_2
08:17:34 F47B Shutting down thread: GWPOP-Handler_1
08:17:34 F47B Shutdown of Threads
08:17:34 EEA7 Exiting GWIMAP-Handler_2
08:17:34 EE86 Exiting GWIMAP-Handler_1
08:17:34 F031 Exiting GWPOP-Handler_2
08:17:34 EFD9 Exiting GWPOP-Handler_1
08:17:34 F019 Exiting GWHTTP-Handler_2
08:17:34 EF9F Exiting GWHTTP-Handler_3
08:17:34 F3F3 Exiting GWHTTP-Handler_1
08:17:50 F47B ****************** Agent Restarted ******************
08:17:50 F47B MTP: Message Transfer Protocol initialization...
08:17:50 F47B MTP: Queue initialization...
08:17:51 F47B MTP: Queue initialization...
08:17:51 F47B Startup: No frgnames.cfg file found.
08:17:51 EF3F Starting GWHTTP-Listener
08:17:51 F47B HTTP server running
08:17:51 EF1F Starting GWHTTP-Handler_1
08:17:51 F47B Startup: No route.cfg file found.
08:17:51 EEFF SMTP service running
08:17:51 F47B
08:17:51 EFF1 Starting GWTCP-Dispatcher
08:17:51 F001 Starting GWTCP-Monitor
08:17:51 EEE7 Starting GWPOP-Listener
08:17:51 EDAF Starting GWIMAP-Listener

However; within a few minutes (if not shorter) the processing outbound command is seen once more and the GWIA seems to shutdown.

The GWIA is GW2012 SP2 server OS is OES2SP3, and SLES 10SP4 Linux Release 2.6.16.60-0.99.1-smp

If any additional information is needed, please let me know.

Thank you,

-DS
Labels (2)
0 Likes
2 Replies
Highlighted
Knowledge Partner
Knowledge Partner

Re: GWIA stopping/restarting

In article <dschaldenovell.6j5ebb@no-mx.forums.novell.com>,
Dschaldenovell wrote:
> However; within a few minutes (if not shorter) the processing outbound
> command is seen once more and the GWIA seems to shutdown.
>
> The GWIA is GW2012 SP2 server OS is OES2SP3, and SLES 10SP4 Linux
> Release 2.6.16.60-0.99.1-smp
>

Is this just one system seeing this or multiples?
Am assuming 64-bit SLES, please confirm.
How tight is memory? As in are we pushing heavily into swap?
How tight is disk space on that partition and what type is that
partition?
What does the uptime for GWIA show in the web interface home page?

Perhaps it is one of those times to delete or move(to a temp area to see
what was hiding there) out those GWIA folders problems sometimes stick
in, naturally while GWIA is down
(000.prc, receive, send, wpcsin, wpcsout, GWIA will recreate these when
you start it back up)


Andy of
KonecnyConsulting.ca in Toronto
Knowledge Partner
http://forums.novell.com/member.php/75037-konecnya
If you find a post helpful and are logged in the Web interface, please
show your appreciation by clicking on the star below. Thanks!

___
“i’ve sworn an oath of solitude til the blight is purged from these lands”
Andy of Konecny Consulting in Toronto
Knowledge Partner Profile
If you find a post helpful, click the Like button below. Thanks!
0 Likes
Highlighted
Visitor.

Re: GWIA stopping/restarting

Check the ./mta_name/wpgate/gwia_name/wpcsout and wpcsin folders and subfolders for stuck messages you can use ls -liaR to see them. You may see a message file in there which is telling the agent to restart. It may be that a control message telling the agent to restart is stuck in its queue, this triggers the restarting behavior.

Also do you have the GroupWise "high avaiability" service ( gwha ) stuff enabled? It may be detecting that the agent is down and restarting it. If gwha is your problem, you can try to fix it ( oh, joy ) or disable it and create your own ( See TID 7002918 for example, or one of the posts in the forums, I think I posted my own at one point, its similar. ) Disabling gwha can be done by killing the gwha process, or via togging the services status in YaST-->Network Services-->Network Services (xinetd)--> gwha disable. Either way, make sure gwha is not running.

Or it could be some 3rd thing?

-- Bob
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.