Highlighted
Honored Contributor.
Honored Contributor.
14628 views

GroupWise 2014 R2 Support Pack 2 (14.2.2) released

http://download.novell.com/Download?buildid=FpCD1GJ8vgg~

Micro Focus has released GroupWise 2014 R2 Support Pack 2 (14.2.2)

Security Fixes
1022895 - Oracle Outside-In security updates for Jan 2017
1020674 - JRE update

Change Log

Admin
967687 - Sort Exclude lists in GWIA Access Control and POA Scheduled Events
973362 - Unsuccessful LDAP sync by MTA sets on user accounts expiration date
980717 - After upgrade to 2014, not able to remove gateway alias from external entities
986015 - Issue with password expiration policy and Active Directory
1021769 - Domain administrator cannot edit users in GW Admin console if domain/po name is in the incorrect case (uppercase or lowercase)
1025098 - Reorder the items on the Client Options Integration left-hand navigation panel
1030315 - The GroupWise Administration Console displays an error when working with nicknames for resource objects
1030950 - Help link errors
1031552 - Fix problems with validating roles for mixed case domains and post offices

Calendar Server
1000912 - All day events without timezone show up on wrong day

Calendar Publisher
982841 - Published calendars do not display in Firefox or IE with compatibility mode

Windows Client
1018927 - Infinite loop when accepting an appointment that has a view name or account id (comes in from outside the system)
987250 - Client hangs when trying to access attachments in shared folders
989822 - Drag and drop attachment to desktop changes the "name information" of the file
996425 - GW client always downloads a mail attachment / BLOB via a secure C/S connection
1000763 - Attachment jpg lost when forwarding message
1005656 - PTX document temp files are removed with application still open
963384 - AM/PM mark drawing incorrectly
981506 - Appointment sent from custom view shows 1.1.1970.
1009712 - Day picker window overlap issue when calendar view is maximized on entire screen.
1012606 - The Month and Calendar view does not update when switching back and forth to a proxy mailbox.
1012686 - Client locking up when clicking on the calendar tab.
972176 - Skype ics not showing all text in description.
998407 - Sort by Categories does not also sort by date.
963816 - Copy and paste from HTML view still adding unwanted spaces.
1009726 - Copying and pasting an image from one mail to another fails.
990858 - Delegate does not work anymore after upgrade to 14.2.x POA.
982898 - Unread panel suddenly turns on sent items.
994003 - Filtering the sent items folder, when sorted by subject, never returns anything.
986065 - Find / Filter in a Remote /Caching Mailbox is showing too many results.
994318 - Quicksearch only finds items of today.
1016906 - Quicksearch not showing calendar items.
968473 - D126 record update filter failed error when searching a shared folder.
989066 - Shared sub-calendars are missing the calendarAttribute element.
965851 - Blank line added in message body.
984991 - Hyperlink issues when attachment filename contains cyrillic characters.
987962 - HTML message body text disappears when GW user clicks on Reply.
996948 - Default encoding does not properly display message.
1002545 - Mail body is blank.
1005490 - Client crash on mso99Lwin32client.dll / mso20win32client.dll.
1007237 - maito puts html in message body.
1015820 - Some 14.2.2 FTF builds are not working correctly with Formativ portal.
1017947 - GroupWise client does not properly display received HTML message.
938962 - Client install error "ordinal not found".
988367 - Install.bat /unattended error - Microsoft Visual C++ 2013.
989114 - Client install breaks iPrint client - MSVCR120.dll.
990018 - Unattended GroupWise Client 2014 R2 SP1 via Zen is no longer working.
1015438 - Running install.bat with silent, errors out the first time.
957875 - Words improperly marked as mispelled when switching languages.
962780 - Unexpected mail group selection after previewing few mails.
985899 - Client crash while sending mail or replying to mail.
988318 - New mail flag on shared folder shows every time the client is started regardless of whether there is new mail or not.
990955 - Since upgrading to R2 SP1, the client hangs when opening random email messages.
991072 - C006 error in German client.
991522 - Original message with Chinese characters get garbled when using forward using GW client.
993380 - Client crashes at times when opening, forwarding or replying to messages.
981449 - Client crashes in caching mode.
982271 - Link on email does not link to the correct page.
984644 - Running R2HP1, users get D04F several times throughout the day.
987065 - D04F error at random times while running the windows client.
989636 - Random client crashes with the R2 SP1 client - Folder Tree related.
990512 - Client crash on Windows 10 since upgrade to r2 sp1.
991310 - GroupWise client hangs when opening certain messages.
1009131 - Client crashes randomly.
1015353 - Application connection table full after upgrade into HP2 and using newer clients.
1020155 - Client takes 40 to 50 seconds longer to do anything after moving system from Linux to Windows.
986599 - Inconsistent color use.
992586 - Changing from filtered mailbox to filtered multi user calendar view hangs client.
975407 - Printing message in Chinese prints the signature line even if there is no signature there.
959989 - Sending a mail from a proxy mailbox to a personal group has 0 recipients.
994029 - Sender address set in new format GHV templates not being used when sending messages via proxied user.
990954 - When doing a reply to all on a message from an appliance, the To field is blank.
999695 - Part of the message is missing when using reply.
1008562 - Client crashes when replying/forwarding an email with image.
1013138 - For messages from the email address of a distribution list, replies go to recipient rather than to distribution list email address.
946177 - Colon missing in 'when actions are' section after Accept Rule has been created.
1022338 - NGW_E_UDW_RULE_TOKEN_FLAGS is not written to the database if there is not a start and end date set (Needed for Mobility to function as expected).
1024755 - Client crash with vacation rule.
1026226 - Vacation Rule: If the Main message body is empty, the External message body can't be saved.
992737 - Unable to save an attachment from a forwarded mail.
1024219 - Users can send emails despite mailbox showing that quota has been exceeded.
988832 - Caching client does not use Default Global Signature.
979365 - Task list panels display "Start Date" for posted tasks as "Today" rather than actual start dates.
909061 - Unable to save default compose font color settings.
995585 - Backslash in saved view changes to ampersand.
1000089 - Saving modified customer view corrupts file.
1005250 - Client crash selecting December 1 or 2 in MU view.
984925 - Groupwise sees pdf files created with pdf creator version 1.6 as something other than text.
1001144 - Hang when opening mail.
1031126 - Cursor positioned incorrectly after createing second bullet point formatting section.

Document Viewer Agent
970685 - DVA cores even after applying gw14.2.0-122791.
983966 - DVA goes into high utilization several times during the day - waiting Oracle Stellent fixes.
1018418 - DVA is creating tons of files - randomly resulting in disk full errors.
1025991 - GroupWise DVA Seg faults immediately on startup.

Engine
981424 - GWIA can't look up name servers in Windows 2012 R2 if server is setup as a DHCP.
986301 - Status tracking on completed checklist items.
986325 - Duplicate cancel notifications on appointments from Exchange.
986330 - Duplicate appointments after an appointment update from Exchange.
987392 - Auto-replies display string "&" on some clients.
991751 - Buffer overflow in creating a comment for a group.
994694 - Shared folder replication stops after transferring ownership.
996101 - Move user not completing if you have a shared folder tree.
996129 - Not creating NGW_HSZ_THREAD correctly in some instances.
1005043 - With a cross-host shared address book, you have to exit the client to get deletes to replicate.
1005294 - LDAP Connection down using SSL.
1008960 - Errors in POA Logs that are not going away even after gwcheck.
1010931 - Invite-Delegate option sends a notification email with wrong account photo.
1027114 - To-do Folder doesn't move with Move User.
1027118 - GWCheck - 8209 errors on external calendar events.

GroupWise Internet Agent (GWIA)
771142 - Groupwise mail threading broken.
985680 - Unable to send to some domains with extended characters.
985900 - Getting an unwanted extra day of a recurring appointment.
985906 - Appointment edits from the internet lose personalizations.
990000 - Fatal error processing incoming message, Error: 616E after upgrade to GroupWise R2.
991529 - Decline notification date/time for external appointment is the same as the appointment date/time.
995338 - The name of a resource is duplicated in the From: field of an outbound mail.
1008931 - Emails with MS Word attachments via GWIA arrive corrupted.
1015331 - Increase the hop count for the GWIA.
1022090 - External Recipient sees garbage when from contains extended character.
1022373 - GWIA moves received messages to problem dir if bad UTF-8 characters in subject.
1025099 - Outbound messages through GWIA are not threading.

GWCheck
979936 - Run the catchupquickfinder switch during a gwcheck on a caching DB.
1017365 - Windows gwcheck in 14.2.2 branch does not run.

ICAL protocol support
967918 - External appointment creation date shows 31 December 1969.
983320 - GW doesn't handle Outlook series modifications after a single instance has been modified.

Install
1004267 - Install_webaccess.sh incorrectly checks OS check.
1010082 - Python error when Configuring Web components on SLES12sp2.
1018291 - New build from 14.2.2 FTF fails to start any agent with GUI.
1030350 - Monitor agent configure does not properly Base64 encode certificate password.

Message Transfer Agent (MTA)
980423 - GWMTA not setting the Linux RLIMIT_NOFILE option like the GWPOA and GWIA does today.
983562 - Primary Domain on Windows shows several Windows Post Offices closed then open repeatedly.

Monitor
981461 - Add new branding to gwmon language selector page.
992183 - Default monitor agent to start with SSL enabled.
(no bug #) - Monitor Agent reporting no HTTP for all GW agents

Outlook Client Support
1007334 - Outlook comments not working with appointments.
1012752 - Problems with Russian extended chars in display name part of email address using Outlook - GMS.

Post Office Agent (POA)
971492 - Performance issue - slowness for all users on Post Office.
971693 - Post Office Database will not update on domain - 8209 error.
985915 - Edited instance of a recurring appointment from Exchange becomes unlinked from the series.
986299 - Memory leak.
987523 - POA core - _WpsvGetContextsFromBag.
990851 - POA Crash
991914 - After update to GroupWise 2014 R2 SP1 build 124188 the POA randomly cores.
992895 - POA crash on exit due to MTP.
994117 - POA crash when submitting gwcheck from gwadmin console.
994393 - Frequent POA crashes - buffer overridden in log writing.
994664 - POA causing high CPU and eventually crashes.
994929 - POA crashing after applying FTF.
995576 - POA cores 5 to 6 times in a day - TNEF handling.
996942 - Enabling high level SOAP logging causing the POA to crash and/or the server to core.
998653 - POA cores following update to 14.2.1HP1.
1006883 - Cluster POA crash after upgrading to 124595 build.
1015436 - POA stopping during night.
1015888 - Configuring SSO with Active Directory (Linux PO) on an NCS cluster results in a GW password prompt.
1024516 - GW POA segfault - waiting for a readable core.
1025444 - POA core - waiting for status update.
1028532 - POA core - poa crashed inside Flaim.

IMAP Protocol
960616 - Native Mac Mail Client: New items not showing up.
993654 - Extended characters get truncated when using IMAP protocol on Android or iOS devices.
1004390 - Deleting a message from the GW client appears to delete the wrong message in the Mac Mail client.
1023265 - IMAP via GWIA will allow very large draft messages to use up all available disk space.

LDAP protocol
986432 - Can't bind to ldap service with cn=adminapp,o=system.
1008123 - Admin Service LDAP does not show/support the GroupWise GUID.

SOAP protocol
987731 - D107 Error on FireFox when transferring owner rights to a folder.
988400 - When users log into WebAccess they get an "unable to add instance" error.
989605 - QueryRequest is returning documents but it's misidentifying those as shared folder notifications.
992891 - Shared address book right changes do not provide a UUID for shared recipients.
995425 - D01B error streaming attachments.
995682 - Streaming or downloading embedded attachments in a folder sharedToMe does not work.
995870 - Administrator changed GWIA and Mobility is now getting SAB deltas on the GWIA record.
1003412 - If vacationrule doesn't have a start/end date, we don't get the "replyToExternalUsers" setting in the getRuleListResponse.
1005691 - When Mobility sends to a SAB group with 1000+ recipients, the connection times out.
1007331 - Creating the vacation rule via SOAP requires a subject. The Windows client does not require a subject.
1021477 - SOAP redirection is using wrong address for GroupWise Mobility.
1022148 - On the Vacation Rule, external subject and message body are not returned unless a start and end date are added to rule.
1022151 - On a vacation rule, SOAP is not returning the myContactsOnly element.

SDK - Object API
989592 - OAPI - Granular proxy access settings for rules, folders and security options are missing.

Search
1016906 - Quicksearch not showing calendar items.

WebAccess
962582 - Accepting shared address book shows E71E error - A folder with specified name already exists.
981724 - On day and week view a right click gives "Add appointment", but not on 31 day view.
989598 - Shared sub-calendars are missing the calendarAttribute element.
989435 - GW WebAccess 14.2.1 doesn't reply to any DL.
997095 - WebAccess - attaching files to new message in mobile interface does not actually attach the file.
1001160 - WebAccess does not exclusively use the address in the reply-to: field.
1015365 - WebAccess sending attachment that was deleted.
1027140 - WebAccess attachments smaller than 10kb are received as 0kb.
989808 - WebAccess Find feature returns no results when including category.
1028498 - Search function bypasses explicit granted proxy rights.
1012453 - WebAccess not receiving slaps anymore from the POA.
981702 - Due time entry does not appear to validate for legal times.
998453 - WebAccess stores temp file in unencrypted format.
1002041 - A few WebAccess users cannot SEND e-mail from WebAccess.
1004015 - Problems with auto-refresh feature of WebAccess on Windows platforms.
1028566 - Webaccess users must login 2 times to successfully login.
999837 - On ios10 you can't reply to messages.
1029399 - WebAccess mobile interface does not find any or random search results.
985724 - Error 951F, The username or password you entered is incorrect.
964679 - Spellcheck removes line in Hungarian.
996327 - Mobile interface does not honor "Attachment access control" settings to disable viewing of attachments.
1031543 - Name completion does not work on Android.
Labels (1)
0 Likes
40 Replies
Highlighted
Knowledge Partner
Knowledge Partner

Re: GroupWise 2014 R2 Support Pack 2 (14.2.2) released

In article <bkesting.7wnagn@no-mx.forums.microfocus.com>, Bkesting
wrote:
> 983966 - DVA goes into high utilization several times during the day -
> waiting Oracle Stellent fixes.


Ahhh, that will be nice, as even though the utilization was niced, it
sets off NAGios at times.



Andy of
http://KonecnyConsulting.ca in Toronto
Knowledge Partner, trying to stop Mr Automatic from complaining.
http://forums.novell.com/member.php/75037-konecnya
If you find a post helpful and are logged in the Web interface, please
show your appreciation by clicking on the star below. Thanks!

___
“i’ve sworn an oath of solitude til the blight is purged from these lands”
Andy of Konecny Consulting in Toronto
Knowledge Partner Profile
If you find a post helpful, click the Like button below. Thanks!
0 Likes
Highlighted
Honored Contributor.
Honored Contributor.

Re: GroupWise 2014 R2 Support Pack 2 (14.2.2) released

Additionally:

What's New in GroupWise 2014 R2 SP2

- Micro Focus Filr Integration: GroupWise 14.2.2 allows you to integrate with Micro Focus Filr. You can enable Filr in the Admin Console > select a Domain, PO or user > Client Options > Integrations > Micro Focus Filr. You will need to enter the URL of your Filr installation. With Filr enabled, you can force all attachments to be placed in Filr or set a size limit for the attachments and anything over that size is placed in Filr. In the client, when creating an email, you can add a Filr reference as an attachment or upload an attachment to Filr when you send the email. You can search Filr when using Find. You can save received attachments to Filr using the File > Save menu.

- DE Mail Integration: You can enable DE Mail in the Admin console > select a Domain, PO or user > Client Options > Integrations > DE Mail. Users will then see DE Mail options in the client when sending an email to a DE Mail address.

- Vacation Rule Enhancements: Vacation rules have been updated so that you can have a separate message body for replying to external users and you can limit your replies to external Address Book members.

=====================================

Known Issues in GroupWise 2014 R2 SP2

Installing .NET 4.5 on Windows 7 through GroupWise Client takes a long time
When installing .NET 4.5 on a Windows 7 machine using the GroupWise Client install, the install can take over 12 minutes to install .NET. Installing .NET prior to the GroupWise client install fixes the issue.

No Default Email Client error after installing GW Client with Microsoft Outlook installed
If you install the GroupWise Client with Microsoft Outlook installed on the machine, you could run into the following error:

No e-mail program is assigned to export the desired action. Install a corresponding e-mail program, or create a map in the system control under "Standard Programs" if a program is already installed.

To fix this issue, create a Novell GroupWise profile in Outlook. See "Creating the GroupWise Account Manually" in the "GroupWise Mobility Service 2014 R2 Administration Guide"

WebAccess Item Read Window Closes when Navigating to Next or Previous Item
If you have an item open in WebAccess in Internet Explorer 11 or Microsoft Edge, and you navigate to the next or previous item using the arrows in the Item Read window, then the Item Read window closes. This does not happen in other browsers. We are working on a fix for this issue.

===========================================
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: GroupWise 2014 R2 Support Pack 2 (14.2.2) released

I'm sure this has been asked (and answered) before but.... can the 14.2.2 client access a 14.2.1 PO?
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: GroupWise 2014 R2 Support Pack 2 (14.2.2) released

Hi CB,

Yes it can.... it is only between major updates that it can't. Support Packs are inter-operable.

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: GroupWise 2014 R2 Support Pack 2 (14.2.2) released

Am 12.04.2017 um 18:46 schrieb cbristol:
>
> I'm sure this has been asked (and answered) before but.... can the
> 14.2.2 client access a 14.2.1 PO?
>
>

In addition to Lauras answer: Of course, any enhancement that needs
server side features won't work until the server is updated.

CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
0 Likes
Highlighted
Super Contributor.
Super Contributor.

Re: GroupWise 2014 R2 Support Pack 2 (14.2.2) released

We found our first problem. The install process for the client, specifically the install.bat that's described for installing with ZCM. It calls for forcing the install of dotnetfx45. This breaks if the computer has the same or newer version already installed. We've tried it a number of different ways, always the same outcome. It should test to see if the dotnetfx45 is already installed and error gracefully. Instead the installer stops to inform the user of the problem. Not so great when it's a silent install or deployed as part of an image.
0 Likes
Highlighted
Honored Contributor.
Honored Contributor.

Re: GroupWise 2014 R2 Support Pack 2 (14.2.2) released

I installed 14.2.2 tonight. Seems to have went smoothly. One thing I did notice, when I run "rpm -qa | grep groupwise" I get:

groupwise-webaccess-webapp-14.2.2-126868

When I log into WebAccess and go to Settings > About it shows "Program Release: 14.2.1 11/22/2016 (WebAccsesServlet.class) | POA Version 14.2.2 | POA Build: 126868

Is it just a cosmetic thing within WebAccess or did I miss something in the upgrade?
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: GroupWise 2014 R2 Support Pack 2 (14.2.2) released

Browser cache by chance?
The install bounces tomcat and apache, so these shouldn't be an issue.
0 Likes
Highlighted
Honored Contributor.
Honored Contributor.

Re: GroupWise 2014 R2 Support Pack 2 (14.2.2) released

mathiasbraun;2454894 wrote:
Browser cache by chance?
The install bounces tomcat and apache, so these shouldn't be an issue.


Cache is cleared. Still shows 14.2.1
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: GroupWise 2014 R2 Support Pack 2 (14.2.2) released

Am 13.04.2017 um 02:06 schrieb raronson:
>
> We found our first problem. The install process for the client,
> specifically the install.bat that's described for installing with ZCM.


Sorry to say, but please don't use the .bat. It's basically a very bad
idea to boot to have ZCM call batch files (it has no control over, aka
can't properly decide if the install worked or not) to install software.
And then, the .bat isn't really very well done or smart.

CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
0 Likes
Highlighted
New Member.

Re: GroupWise 2014 R2 Support Pack 2 (14.2.2) released

Yes, you are right. From version to version novell is not able to build a really out of the box usable install.bat.
Every new version a new surprise, shame on them for such a simple batch file.

Here is the way how we handle this buggy install.bat to use it in a ZCM bundle with both parameters /log and /unattended (because we do not install any software without an install log):

These modifications of the install.bat must be done (All modifications handled by the ZCM bundle action "Edit Text File"):
Option /log:
- comment out all lines with "echo" command -> Batch echos not possible with ZCM.
- correct creation of "TIMESTAMP_DATE" and "TIMESTAMP_TIME" variables -> German time and date format.
- Change logging path to have it under our central place "C:\Temp\..."
Option /unattended:
- for really unattended msi setup replace groupwise.msi option "/qb!" with "/qb-!"
- for really unattended prerequisite setup replace "set GW_OPTS_VCRUNTIMES_2013=/qn" with "set GW_OPTS_VCRUNTIMES_2013=/quiet /repair /norestart"
General:
- comment out all lines with "wmic ..." command -> very slow with "run as dynamic local user".
- comment out all lines with "start /wait %GW_PKG_DOTNETFX ..." command -> because: not necessary to install DOTNETxx / used command "/q:a /c:"install /l %LOG_DIR%\03_%GW_PKG_DOTNETFX45%.log" is incorrect or not unattended, it should be something like "/passive /norestart /log %LOG_DIR%\03_%GW_PKG_DOTNETFX45%.log"

See attached a zip file with the original and our modified install.bat of GW version 14.2.2.126868.
If somebody is interested you can use for example notepad++ with the compare plugin to see the differences.

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.