Highlighted
Account_Closed
Not applicable
1405 views

Groupwise 2014 r2, SLES SP3, VMWARE, inconsistent sending

30 percent of the time to hotmail, yahoo and other domains I get the C141 DMN: MSG 1667 SMTP session ended: [98.138.112.35] (mta6.am0.yahoodns.net)
15:15:19 C141 DMN: MSG 1667 Send Failure: 420 TCP write error or I get the host down. I thought it could be the isp, but they came and the internet works fine, the only thing that I found was that the vmware driver with SLES sp3 you need to put the following command "ethtool -K eth0 tso off. But I did that, but no change.. The vmware ESXI is on a Levono ThinkServer TS430. I thought it could actually be the nic on the server, but I don´t see any dropped packets... Any help is appreciated...
Labels (1)
0 Likes
11 Replies
Highlighted
Knowledge Partner
Knowledge Partner

Re: Groupwise 2014 r2, SLES SP3, VMWARE, inconsistent sendin

crobison;2464305 wrote:
the only thing that I found was that the vmware driver with SLES sp3 you need to put the following command "ethtool -K eth0 tso off. But I did that, but no change..


First off, we need to know what release of SLES you are running. SP3 is the service pack, not the release. Please post the output from this command:
cat /etc/*release

There may be other calculations offloaded to your eth0 adapter which could cause issues. Make note of them then disable all of them to see if it resolves your issue. You can see which ones are enabled with this command:
ethtool -k eth0


Another thing to check is the type of adapter assigned to eth0 on your virtual machine. You can see this when you edit the VMware virtual machine settings. You can try a different adapter. If your SLES release and your ESXi version support it, try VMXNET3. It is the newest virtual nic and provides the best performance.
_____
Kevin Boyle - Knowledge Partner - Calgary, Alberta, Canada
Who are the Knowledge Partners?
If you appreciate my comments, please click the Like button.
If I have resolved your issue, please click the Accept as Solution button.
0 Likes
Highlighted
Account_Closed
Not applicable

Re: Groupwise 2014 r2, SLES SP3, VMWARE, inconsistent sendin

LSB_VERSION="core-2.0-noarch:core-3.2-noarch:core-4.0-noarch:core-2.0-x86_64:core-3.2-x86_64:core-4.0-x86_64"
SUSE Linux Enterprise Server 11 (x86_64)
VERSION = 11
PATCHLEVEL = 3

ethtool -k eth0
Offload parameters for eth0:
rx-checksumming: on
tx-checksumming: on
scatter-gather: on
tcp-segmentation-offload: off
udp-fragmentation-offload: off
generic-segmentation-offload: on
generic-receive-offload: on
large-receive-offload: off
rx-vlan-offload: on
tx-vlan-offload: on
ntuple-filters: off
receive-hashing: off
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: Groupwise 2014 r2, SLES SP3, VMWARE, inconsistent sendin

Hi,

Just to add this in here.... the problem might not be the server but something connecting the server to the outside world. I had a mismatched duplex setting on a switch port once causing this kind of problem.

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: Groupwise 2014 r2, SLES SP3, VMWARE, inconsistent sendin

crobison;2464305 wrote:
420 TCP write error


If these errors are not due to issues with your nic, you need to look elsewhere. These types of errors are sometimes difficult to debug and you may have to open an Sevice Request.

Have you seen this TID?
TID 7007770 "420 TCP Read" Error Sending to Specific Domains
_____
Kevin Boyle - Knowledge Partner - Calgary, Alberta, Canada
Who are the Knowledge Partners?
If you appreciate my comments, please click the Like button.
If I have resolved your issue, please click the Accept as Solution button.
0 Likes
Highlighted
Account_Closed
Not applicable

Re: Groupwise 2014 r2, SLES SP3, VMWARE, inconsistent sendin

The packet inspection is disabled, question the tls enabled is it referring to the ssl being enabled on the smtp agent?
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: Groupwise 2014 r2, SLES SP3, VMWARE, inconsistent sendin

Issues similar to yours have been reported frequently over the years. They are difficult to diagnose especially for Forum Volunteers who don't have access to your system. Often, it is not a GroupWise issue.

Read through previous threads to see if they help. If not, then I suggest you open a Service Request.

In each of the following forums, search for "tcp 420" using the "Search Forums" drop-down at the top of the list of threads on the right hand side.



Good luck!
_____
Kevin Boyle - Knowledge Partner - Calgary, Alberta, Canada
Who are the Knowledge Partners?
If you appreciate my comments, please click the Like button.
If I have resolved your issue, please click the Accept as Solution button.
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: Groupwise 2014 r2, SLES SP3, VMWARE, inconsistent sendin

laurabuckley;2464368 wrote:
the problem might not be the server but something connecting the server to the outside world.

You are absolutely correct.

We can try a couple of quick things that have been known to resolve similar problems but if they don't fix it then a full diagnosis is needed to pinpoint the problem before considering possible solutions. 🙂
_____
Kevin Boyle - Knowledge Partner - Calgary, Alberta, Canada
Who are the Knowledge Partners?
If you appreciate my comments, please click the Like button.
If I have resolved your issue, please click the Accept as Solution button.
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: Groupwise 2014 r2, SLES SP3, VMWARE, inconsistent sending

Am 17.08.2017 um 22:44 schrieb KBOYLE:
>
> Issues similar to yours have been reported frequently over the years.
> They are difficult to diagnose especially for Forum Volunteers who don't
> have access to your system. Often, it is not a GroupWise issue.


Let me rephrase this. It is virtually never a groupwise issue. 😉

And it's virtually always a communication issue, and in the majority of
cases it's the local firewall/router.

The proper solution to find what's going on is to take a lan trace on
the GW serve ritself, and if possible simultaneoulsy on the outmost
device possible (firewall?) until a 420 error shows up. The lan trace
will show what's up without having to guess or go for trial&error solutions.


CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
0 Likes
Highlighted
Outstanding Contributor.
Outstanding Contributor.

Re: Groupwise 2014 r2, SLES SP3, VMWARE, inconsistent sendin

I can confirm, never a groupwise Problem, i works since many years with virtual Installation on vmware 5x und 6.x and don't have any Problems!
0 Likes
Highlighted
Account_Closed
Not applicable

Re: Groupwise 2014 r2, SLES SP3, VMWARE, inconsistent sendin

The issue was resolved, never a groupwise issue. The isp used to associate the authorized ips with the mac address of the device, but they had but the wrong mac for the firewall causing all kinda problems, yesterday the but the correct mac and everything is flowing great...
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: Groupwise 2014 r2, SLES SP3, VMWARE, inconsistent sendin

crobison;2464635 wrote:
The issue was resolved, never a groupwise issue. The isp used to associate the authorized ips with the mac address of the device, but they had but the wrong mac for the firewall causing all kinda problems, yesterday the but the correct mac and everything is flowing great...


I'm glad your issue has been resolved.

We appreciate the feedback. It may help others who have similar issues.
_____
Kevin Boyle - Knowledge Partner - Calgary, Alberta, Canada
Who are the Knowledge Partners?
If you appreciate my comments, please click the Like button.
If I have resolved your issue, please click the Accept as Solution button.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.