Highlighted
Honored Contributor.
Honored Contributor.
173 views

Groupwise Find does not produce all results

Jump to solution

GW 18.1.1.133172 linux backend and Windows client

When user does a Global Find and enters the name they wish to search for ie "Jane Smith" it does not produce all results found in the mailbox - it only shows one or two emails.

If the user modifies the find, and adds "Jane Smith" name in the From Field, same issue - doesn't produce all results.

If he then select More Options, then  removes the asterisk  from  "Jane Smith*" in  the from field,  it then produces all results.

I try searching for the same user in my find and it shows all results the first time I search in the Global find.

User has no pending jobs for indexing, and also indicated he has the same issue when searching on another user's name as well. So no idea why it's not producing the full results?

Labels (2)
Tags (1)
0 Likes
1 Solution

Accepted Solutions
Highlighted
Knowledge Partner
Knowledge Partner

Re: Groupwise Find does not produce all results

Jump to solution

Apart from a client issue it might well be something wrong with this user's indexes (despite of the fact that there's nothing pending). So it might be worth a try to recreate those indexes from scratch by either following this one

https://support.microfocus.com/kb/doc.php?id=7012997

or:

- logging in to the poa console with adequate rights

- setting the loglevel to "diagnostic" which will provide an additional option for

- "deleting and recreating all indexes" in the "Configuration -> QuickFinder Indexing" section

- setting the level to "unlimited"

- typing in the user's FID as both beginning and ending user's FID

- starting the process, waiting 'til it's finished and trying again

18.1.1 is a little old btw, but as you couldn't login to an 18.1.x DB with a current client you'd have to upgrade the backend first (which you should do anyway). Finally, you could also open a SR and request the latest pre-18.2 build available.

 

View solution in original post

7 Replies
Highlighted
Knowledge Partner
Knowledge Partner

Re: Groupwise Find does not produce all results

Jump to solution

Apart from a client issue it might well be something wrong with this user's indexes (despite of the fact that there's nothing pending). So it might be worth a try to recreate those indexes from scratch by either following this one

https://support.microfocus.com/kb/doc.php?id=7012997

or:

- logging in to the poa console with adequate rights

- setting the loglevel to "diagnostic" which will provide an additional option for

- "deleting and recreating all indexes" in the "Configuration -> QuickFinder Indexing" section

- setting the level to "unlimited"

- typing in the user's FID as both beginning and ending user's FID

- starting the process, waiting 'til it's finished and trying again

18.1.1 is a little old btw, but as you couldn't login to an 18.1.x DB with a current client you'd have to upgrade the backend first (which you should do anyway). Finally, you could also open a SR and request the latest pre-18.2 build available.

 

View solution in original post

Highlighted
Micro Focus Expert
Micro Focus Expert

Re: Groupwise Find does not produce all results

Jump to solution

Hi,

I recommend doing exactly as mathiasbraun has recommended - rebuild the indexes.  But please do open an SR to get the last pre-18.2 build of the client as it does contain fixes for the find/search feature.

Cheers,

Laura

 

Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
Highlighted
Honored Contributor.
Honored Contributor.

Re: Groupwise Find does not produce all results

Jump to solution

Thank you, switching the logs to diagnostic and following that procedure seemed to work!

Yes plan is to move to 18.2 in the upcoming months!

Thank you again for your responses!

 

0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: Groupwise Find does not produce all results

Jump to solution

Cool. Please don't forget to switch loglevel back from "diagnostic", stuff might grow quickly...

 

Highlighted
Knowledge Partner
Knowledge Partner

Re: Groupwise Find does not produce all results

Jump to solution

Another helpful utility you should not forget is gwcheck. Run scheduled gwchecks (POA settings) and read the log files. Running this tool without checking the log files is only the half purpose.

The last line for each user's log is showing "pending jobs". If there is a high number on pending jobs for a user, I would suggest to run a re-index (see the solution above). If there are high numbers on many users, then you have to redefine your index settings.

Diethmar Rimser
If you like my idea or solution, please show it and click i.e. on "Like"!
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: Groupwise Find does not produce all results

Jump to solution


Personally I do not think the default settings for Quick Finder indexing are sufficient for even a moderately busy POA. By default, it is set to start at 20 hours after midnight, which means it's only starting at 8:00 pm. The Quick Finder process will only run until midnight at which point it stops and waits for its start hour again. This means that the process only has a four-hour processing window. I typically set my start hour for 1 hour after midnight and my interval at 4 hours. If you check your Verbose POA log files from 8:00 pm at night you will see entries for each user db being indexed and how many pending items there are in brackets behind the db name. If these numbers are very high it means your system is behind on indexing. In that case, I'd initiate a full unlimited index from the POA Web Console. Note that I would only do such a thing starting on a Friday afternoon and let it run for the weekend. Quick Finder indexing can place a load on the POA if it's far behind.

Cheers,

 

Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: Groupwise Find does not produce all results

Jump to solution

@laurabuckley 

I fully agree, Laura.

That's the reason why I started my remark 😉

Diethmar Rimser
If you like my idea or solution, please show it and click i.e. on "Like"!
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.