DavudOeden Trusted Contributor.
Trusted Contributor.

HTC HD2 & Touch2 -> 0x80072F17


does anyone sync with HTC HD2 or HTC Touchpro2 ?
I'll always get an error 0x80072F17.

Datasynchronizer is configured to sync on 443, we have installed a SSL cert., opening our site with mobile browser on https://xxxxx.xxxxx.de works and shows our ssl cert.

I really dont know how to get HTC (Win Mobile 6.5) to work.

Anyone an idea ?
Labels (1)
3 Replies
d3b14n Absent Member.
Absent Member.

Re: HTC HD2 & Touch2 -> 0x80072F17

hey davud,

have exactly the same problem with a t-mobile mda (htc innovation). it just wont eat the cert. did the same by browsing to our website and accepted the cert but it just wont connect. now I wanted to delete the cert from the device but there seems to be no way to find it.
I'm testing DS with symbian, android, iphone and win mobile. they all have their glitches but win mobile acts the worst!!!
still fiddeling wit it and as soon as I have a solution to this, I'll let you know.

DavudOeden Trusted Contributor.
Trusted Contributor.

Re: HTC HD2 & Touch2 -> 0x80072F17 (solved)

Hello again,

I've got it to work !

The problem is, that our ssl cert wont install into the root cert's on windows mobile. I've found this site with a working description, how to install the ssl cert to the root cert's of the wm device.

Installing Windows Mobile 6.0 Root Certificates | Confused Amused

After installing the ssl cert to the root cert's, I still get the same failure.
So I've stoped all engines and uninstalled DS on server with the ds_uninstall.sh.
After that I've installed DS new with our cert file in PEM format.

Now syncing with WM 6.5 works, but I'll get always the problem, that NO Password is accepted. If I let the password field BLANK, sync works fine !

But everytime when it syncs, always username and password are questioned. Just pressing okay without typing in any password, syncs again.

Buggy ?

Will wait for next release.

anthompson Absent Member.
Absent Member.

Re: HTC HD2 & Touch2 -> 0x80072F17

I know that you said you're issue is resolved but I found this site that has a list of these awesomely cryptic Microsoft error codes. You'll find the one that you mentioned on the list. It's also a good list for future reference when you get these types of error/support codes.

Adam Thompson
Q&A Team - Novell
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.