Welcome Serena Central users! CLICK HERE
The migration of the Serena Central community is currently underway. Be sure to read THIS MESSAGE to get your new login set up to access your account.
Booj2 Absent Member.
Absent Member.
516 views

How to remove an external domain from a GW2014R2 system


Hello,



We want to remove an external domain (the external system doesn't exist anymore).

I can't find it in the documentation, only a thread for GW2012 using Console one.



What is the correct procedure?



Kind regards,
Hans Boone
Labels (1)
0 Likes
7 Replies
Anonymous_User Absent Member.
Absent Member.

Re: How to remove an external domain from a GW2014R2 system


Have to do this by hand with Rest.



curl -k --user gwadmin:pwd -X DELETE https:/10.10.10.10:9710/gwadmin-service/domains/domtodelete



if there are other objects like a MTA, GWIA or Postoffice under the domain, you'll have to do the same for those items before deleting the domain.



There is a defect written on this, but it hasn't risen up the priority chain yet..



--Morris




>>> Hans Boone<booj@no-mx.forums.microfocus.com> 7/18/2016 9:18 AM >>>


Hello,




We want to remove an external domain (the external system doesn't exist anymore).

I can't find it in the documentation, only a thread for GW2012 using Console one.




What is the correct procedure?




Kind regards,
Hans Boone
0 Likes
Booj2 Absent Member.
Absent Member.

Betr.: Re: How to remove an external domain from a GW2014R2 system


Hello,



I could delete the MTA under the domain.



For the domain I get:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?><apiStatus xmlns:ns2="http://www.w3.org/2005/Atom"><error>true</error><httpStatus>FORBIDDEN</httpStatus><httpStatusCode>403</httpStatusCode><statusCode>56122</statusCode><statusMsg>Deletion failed. Links exist (0xDB3A)</statusMsg></apiStatus>




Checked all links on all domains and all links to the external domain are "undefined".



Hans







>>> Morris Blackham<mb@no.mx.forums.microfocus.com> Maandag 18 Juli 2016 23:28 >>>


Have to do this by hand with Rest.




curl -k --user gwadmin:pwd -X DELETE https:/10.10.10.10:9710/gwadmin-service/domains/domtodelete




if there are other objects like a MTA, GWIA or Postoffice under the domain, you'll have to do the same for those items before deleting the domain.




There is a defect written on this, but it hasn't risen up the priority chain yet..




--Morris




>>> Hans Boone<booj@no-mx.forums.microfocus.com> 7/18/2016 9:18 AM >>>


Hello,




We want to remove an external domain (the external system doesn't exist anymore).

I can't find it in the documentation, only a thread for GW2012 using Console one.




What is the correct procedure?




Kind regards,
Hans Boone
0 Likes
Anonymous_User Absent Member.
Absent Member.

Betr.: Re: How to remove an external domain from a GW2014R2 system


Look under System | External System Synchronization to see if a record exists there..



--Morris




>>> Hans Boone<booj@no-mx.forums.microfocus.com> 7/19/2016 3:30 AM >>>


Hello,




I could delete the MTA under the domain.




For the domain I get:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?><apiStatus xmlns:ns2="http://www.w3.org/2005/Atom"><error>true</error><httpStatus>FORBIDDEN</httpStatus><httpStatusCode>403</httpStatusCode><statusCode>56122</statusCode><statusMsg>Deletion failed. Links exist (0xDB3A)</statusMsg></apiStatus>





Checked all links on all domains and all links to the external domain are "undefined".




Hans








>>> Morris Blackham<mb@no.mx.forums.microfocus.com> Maandag 18 Juli 2016 23:28 >>>


Have to do this by hand with Rest.




curl -k --user gwadmin:pwd -X DELETE https:/10.10.10.10:9710/gwadmin-service/domains/domtodelete




if there are other objects like a MTA, GWIA or Postoffice under the domain, you'll have to do the same for those items before deleting the domain.




There is a defect written on this, but it hasn't risen up the priority chain yet..




--Morris




>>> Hans Boone<booj@no-mx.forums.microfocus.com> 7/18/2016 9:18 AM >>>


Hello,




We want to remove an external domain (the external system doesn't exist anymore).

I can't find it in the documentation, only a thread for GW2012 using Console one.




What is the correct procedure?




Kind regards,
Hans Boone
0 Likes
Highlighted
Booj2 Absent Member.
Absent Member.

Betr.: Re: How to remove an external domain from a GW2014R2 system


No



Hans




>>> Morris Blackham<mb@no.mx.forums.microfocus.com> Dinsdag 19 Juli 2016 16:39 >>>


Look under System | External System Synchronization to see if a record exists there..




--Morris




>>> Hans Boone<booj@no-mx.forums.microfocus.com> 7/19/2016 3:30 AM >>>


Hello,




I could delete the MTA under the domain.




For the domain I get:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?><apiStatus xmlns:ns2="http://www.w3.org/2005/Atom"><error>true</error><httpStatus>FORBIDDEN</httpStatus><httpStatusCode>403</httpStatusCode><statusCode>56122</statusCode><statusMsg>Deletion failed. Links exist (0xDB3A)</statusMsg></apiStatus>





Checked all links on all domains and all links to the external domain are "undefined".




Hans








>>> Morris Blackham<mb@no.mx.forums.microfocus.com> Maandag 18 Juli 2016 23:28 >>>


Have to do this by hand with Rest.




curl -k --user gwadmin:pwd -X DELETE https:/10.10.10.10:9710/gwadmin-service/domains/domtodelete




if there are other objects like a MTA, GWIA or Postoffice under the domain, you'll have to do the same for those items before deleting the domain.




There is a defect written on this, but it hasn't risen up the priority chain yet..




--Morris




>>> Hans Boone<booj@no-mx.forums.microfocus.com> 7/18/2016 9:18 AM >>>


Hello,




We want to remove an external domain (the external system doesn't exist anymore).

I can't find it in the documentation, only a thread for GW2012 using Console one.




What is the correct procedure?




Kind regards,
Hans Boone
0 Likes
Booj2 Absent Member.
Absent Member.

Betr.: Re: How to remove an external domain from a GW2014R2 system


And no pending operations



Hans






>>> Morris Blackham<mb@no.mx.forums.microfocus.com> Dinsdag 19 Juli 2016 16:39 >>>


Look under System | External System Synchronization to see if a record exists there..




--Morris




>>> Hans Boone<booj@no-mx.forums.microfocus.com> 7/19/2016 3:30 AM >>>


Hello,




I could delete the MTA under the domain.




For the domain I get:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?><apiStatus xmlns:ns2="http://www.w3.org/2005/Atom"><error>true</error><httpStatus>FORBIDDEN</httpStatus><httpStatusCode>403</httpStatusCode><statusCode>56122</statusCode><statusMsg>Deletion failed. Links exist (0xDB3A)</statusMsg></apiStatus>





Checked all links on all domains and all links to the external domain are "undefined".




Hans








>>> Morris Blackham<mb@no.mx.forums.microfocus.com> Maandag 18 Juli 2016 23:28 >>>


Have to do this by hand with Rest.




curl -k --user gwadmin:pwd -X DELETE https:/10.10.10.10:9710/gwadmin-service/domains/domtodelete




if there are other objects like a MTA, GWIA or Postoffice under the domain, you'll have to do the same for those items before deleting the domain.




There is a defect written on this, but it hasn't risen up the priority chain yet..




--Morris




>>> Hans Boone<booj@no-mx.forums.microfocus.com> 7/18/2016 9:18 AM >>>


Hello,




We want to remove an external domain (the external system doesn't exist anymore).

I can't find it in the documentation, only a thread for GW2012 using Console one.




What is the correct procedure?




Kind regards,
Hans Boone
0 Likes
Anonymous_User Absent Member.
Absent Member.

Betr.: Re: How to remove an external domain from a GW2014R2 system


Possibly an orphaned link record. Try doing a validate on the primary domain.



--Morris




>>> Hans Boone<booj@no-mx.forums.microfocus.com> 7/19/2016 8:55 AM >>>


No




Hans




>>> Morris Blackham<mb@no.mx.forums.microfocus.com> Dinsdag 19 Juli 2016 16:39 >>>


Look under System | External System Synchronization to see if a record exists there..




--Morris




>>> Hans Boone<booj@no-mx.forums.microfocus.com> 7/19/2016 3:30 AM >>>


Hello,




I could delete the MTA under the domain.




For the domain I get:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?><apiStatus xmlns:ns2="http://www.w3.org/2005/Atom"><error>true</error><httpStatus>FORBIDDEN</httpStatus><httpStatusCode>403</httpStatusCode><statusCode>56122</statusCode><statusMsg>Deletion failed. Links exist (0xDB3A)</statusMsg></apiStatus>





Checked all links on all domains and all links to the external domain are "undefined".




Hans








>>> Morris Blackham<mb@no.mx.forums.microfocus.com> Maandag 18 Juli 2016 23:28 >>>


Have to do this by hand with Rest.




curl -k --user gwadmin:pwd -X DELETE https:/10.10.10.10:9710/gwadmin-service/domains/domtodelete




if there are other objects like a MTA, GWIA or Postoffice under the domain, you'll have to do the same for those items before deleting the domain.




There is a defect written on this, but it hasn't risen up the priority chain yet..




--Morris




>>> Hans Boone<booj@no-mx.forums.microfocus.com> 7/18/2016 9:18 AM >>>


Hello,




We want to remove an external domain (the external system doesn't exist anymore).

I can't find it in the documentation, only a thread for GW2012 using Console one.




What is the correct procedure?




Kind regards,
Hans Boone
0 Likes
Booj2 Absent Member.
Absent Member.

Betr.: Re: How to remove an external domain from a GW2014R2 system


Validate and recover done.

Doesn''t help.



Any idea's left, or should I a create a support incident?



Hans






>>> Morris Blackham<mb@no.mx.forums.microfocus.com> Dinsdag 19 Juli 2016 18:58 >>>


Possibly an orphaned link record. Try doing a validate on the primary domain.




--Morris




>>> Hans Boone<booj@no-mx.forums.microfocus.com> 7/19/2016 8:55 AM >>>


No




Hans




>>> Morris Blackham<mb@no.mx.forums.microfocus.com> Dinsdag 19 Juli 2016 16:39 >>>


Look under System | External System Synchronization to see if a record exists there..




--Morris




>>> Hans Boone<booj@no-mx.forums.microfocus.com> 7/19/2016 3:30 AM >>>


Hello,




I could delete the MTA under the domain.




For the domain I get:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?><apiStatus xmlns:ns2="http://www.w3.org/2005/Atom"><error>true</error><httpStatus>FORBIDDEN</httpStatus><httpStatusCode>403</httpStatusCode><statusCode>56122</statusCode><statusMsg>Deletion failed. Links exist (0xDB3A)</statusMsg></apiStatus>





Checked all links on all domains and all links to the external domain are "undefined".




Hans








>>> Morris Blackham<mb@no.mx.forums.microfocus.com> Maandag 18 Juli 2016 23:28 >>>


Have to do this by hand with Rest.




curl -k --user gwadmin:pwd -X DELETE https:/10.10.10.10:9710/gwadmin-service/domains/domtodelete




if there are other objects like a MTA, GWIA or Postoffice under the domain, you'll have to do the same for those items before deleting the domain.




There is a defect written on this, but it hasn't risen up the priority chain yet..




--Morris




>>> Hans Boone<booj@no-mx.forums.microfocus.com> 7/18/2016 9:18 AM >>>


Hello,




We want to remove an external domain (the external system doesn't exist anymore).

I can't find it in the documentation, only a thread for GW2012 using Console one.




What is the correct procedure?




Kind regards,
Hans Boone
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.