kevinstepper Absent Member.
Absent Member.
964 views

IMAP and POP authentication problems

Hi,

we have a GW 2014 system, all working ok, except that we have a problem with IMAP and POP connectivitiy

POP and IMAP are enabled on the GWIA, IMAP also on the POA.

I can telnet on the default ports ( 110, 143, 25 ) into the server.

When setting up an POP client, I cannot authenticate. It does not accept the user and the password ( both are correct )

When setting up an IMAP client, I can authenticate on 143 and receive mails, but on 25 also the credentials are rejected.

I would appreciate help with that, thank you very much

k
Labels (1)
0 Likes
8 Replies
kevinstepper Absent Member.
Absent Member.

Re: IMAP and POP authentication problems

Just realised: I can telnet on 1677 from other hosts, but cannot telnet to the local loopback on 1677

Same for 143 and 110.

Would that make a difference?
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: IMAP and POP authentication problems

Hi,

With regards to telneting to GroupWise ports on the local loopback address if your GroupWise agents are set to bind exclusively to the IP addresses specified in the configuration then the agents won't be listening on the local loopback address.

You don't indicate if you have enabled POP and IMAP in the GWIA classes of service. If your Post Office and GWIA are on the same server only one can have IMAP enabled. Have you checked the web consoles of the agents for the information on POP and IMAP connections - usually gives clues as to why it's failing. Also, there are always the agent log files which in Verbose mode should give you information.

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
kevinstepper Absent Member.
Absent Member.

Re: IMAP and POP authentication problems

Hi Laura,

thank you for your answer.

Yes, agents are bound exclusively. Should have thought of that.

I have only the default class of service with IMAP and POP enabled, everyone is part of that sevice.

In the GWIA log I only get

90C4 GroupWise login failed: 8503

On the POA Log all i can find is:

Login GW UserID:[kstepper] from x,x,x,x IMAP command:["***"]

I still think that GWIA cannot communicate with the POA on 1677. But I cannot find anywhere how to edit the post office links for GWIA in GW 2014.

kevin
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: IMAP and POP authentication problems

Hi Kevin,

Firstly, port 1677 is used by the GroupWise Client to communicate with the POA.

Secondly, in the Web Console of the GWIA, under the IMAP Service section, when you are logging in, what counter increments? Is it the Password Authentication Errors, or the Store Login Errors, or the Denied Access Count? Please let us know.

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
kevinstepper Absent Member.
Absent Member.

Re: IMAP and POP authentication problems

Hi,

thanks again.

I thoguht that GWIA also has to communicate with the post office via 1677. Anyway, thanks for clarifying.

regarding imap section on gwia web console, i have this:

Password Authentication Errors 0
Retrieval Errors 0
Conversion Errors 0
TCP/IP Read Errors 67
TCP/IP Write Errors 5
Denied Access Count 0
Store Login Errors 61

When retrying, both the TCP/IP read errrors and the store login errors increase.

thanks a lot.

kevin
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: IMAP and POP authentication problems

Hi Kevin,

Store Login Errors typically indicate a corrupt GWIA Access database. Document any custom settings in your GWIA class of service. Shut down your GWIA, rename the gwac.db to gwac.old file in the GWIA directory and start GWIA again. GWIA will rebuild this file. Reconfigure your class of service with any custom settings noted prior to doing this.

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
kevinstepper Absent Member.
Absent Member.

Re: IMAP and POP authentication problems

Hi Laura,

you are a genius. I bow my head in admiration. 🙂

Thanks for the quick help and solution.

kevin
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: IMAP and POP authentication problems

Hi Kevin,

Always a pleasure to assist 🙂

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.