Cougie Absent Member.
Absent Member.
1548 views

Installed CalDAV. Webaccess stopped working. 443 conflict?

Hi,

I installed CalDAV on the GroupWise server and now the Webaccess redirects to a CalDAV welcome page. If I disable the CalDAV service. Web access still doesn't work. I believe this to be a port 443 conflict.

Is is advisable to for instance change the CalDAV or WebAccess to use a different port? Is so how do I go about doing this. Can it be done the the GroupWise Admin Console?

Otherwise is there another solution to get GroupWise Webaccess working? (The WebAccess is a priority)

Thanks.
Labels (1)
0 Likes
5 Replies
dzanre1 Absent Member.
Absent Member.

Re: Installed CalDAV. Webaccess stopped working. 443 conflic

Yes, both CalSrv and WebAccess SSL use port 443, so if you wish to run them on the same server, you will need to change the port for the CalSrv. Note that most programs and devices EXPECT the the CalSrv is running on port 443, so you will need to make sure than anyone who wishes to subscribed to these services knows that they must change the IP address.

Just disabling the CalSrv will not cause WebAccess to work if Apache has failed to load port 443 during startup. Try restarting apache to see if that fixes your WebAccess issue with the cal server unloaded.


Probably the easiest thing to do would be to rerun the calendar server setup, and change the port during configuration.
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Installed CalDAV. Webaccess stopped working. 443 conflict?

You can run /opt/novell/groupwise/calsvr/configure, You don't need to run
the install to get to it. Then go to a browser and hit
https://caldavserver:9443. I'd suggest changing from 443 to port 8443,
Mac's seem to like that port cause it's the default port for Apple's
calendar server.

You can also create autodisovery type DNS SRV records for caldav and
carddav services. Create 2 records for each domain that a user would have
in their email address (i,e, for novell.com microfocus.com etc) The SRV
records would be:


_caldavs._tcp SRV 0 1 8443 yourdomain.com.
_carddavs._tcp SRV 0 1 8443 yourdomain.com.


Where the 8443 is the listen port you configure for the caldav service. The
Mac calendar and contact apps will query these records based on the email
address you provide in the account automatic setup configuration option


--Morris


>>>


> Yes, both CalSrv and WebAccess SSL use port 443, so if you wish to run
> them on the same server, you will need to change the port for the
> CalSrv. Note that most programs and devices EXPECT the the CalSrv is
> running on port 443, so you will need to make sure than anyone who
> wishes to subscribed to these services knows that they must change the
> IP address.
>
> Just disabling the CalSrv will not cause WebAccess to work if Apache has
> failed to load port 443 during startup. Try restarting apache to see if
> that fixes your WebAccess issue with the cal server unloaded.
>
>
> Probably the easiest thing to do would be to rerun the calendar server
> setup, and change the port during configuration.


0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Installed CalDAV. Webaccess stopped working. 443 conflict?


Opps, had a brain cramp..



The DNS record should reflect the server that is hosting the caldav service. Example




_caldavs._tcp SRV 0 1 8443 caldavserver.yourdomain.com.



--Morris





>>> Morris Blackham<mb@no.mx.forums.microfocus.com> 2/25/2016 5:06 PM >>>



You can run /opt/novell/groupwise/calsvr/configure, You don't need to run

the install to get to it. Then go to a browser and hit
https://caldavserver:9443. I'd suggest changing from 443 to port 8443,



Mac's seem to like that port cause it's the default port for Apple's

calendar server.




You can also create autodisovery type DNS SRV records for caldav and

carddav services. Create 2 records for each domain that a user would have

in their email address (i,e, for novell.com microfocus.com etc) The SRV

records would be:







_caldavs._tcp SRV 0 1 8443 yourdomain.com.

_carddavs._tcp SRV 0 1 8443 yourdomain.com.







Where the 8443 is the listen port you configure for the caldav service. The

Mac calendar and contact apps will query these records based on the email

address you provide in the account automatic setup configuration option







--Morris








>>>






> Yes, both CalSrv and WebAccess SSL use port 443, so if you wish to run



> them on the same server, you will need to change the port for the



> CalSrv. Note that most programs and devices EXPECT the the CalSrv is



> running on port 443, so you will need to make sure than anyone who



> wishes to subscribed to these services knows that they must change the



> IP address.



>



> Just disabling the CalSrv will not cause WebAccess to work if Apache has



> failed to load port 443 during startup. Try restarting apache to see if



> that fixes your WebAccess issue with the cal server unloaded.



>



>



> Probably the easiest thing to do would be to rerun the calendar server



> setup, and change the port during configuration.
0 Likes
Cougie Absent Member.
Absent Member.

Re: Installed CalDAV. Webaccess stopped working. 443 conflic

Hi.
Thanks for the responses.
If I were to give CalDAV another port, can I use port 444for example? And if so what changes in Mac Mail will I need to make if that's possible?
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Installed CalDAV. Webaccess stopped working. 443 conflict?


If you create the DNS records as I mentioned, no need to do anything in Mac calendar. If not, you need to do a manual setup in the caldav accout creation and have the user specify the IP:port of the caldav server..



--Morris




>>> Cougie<Cougie@no-mx.forums.microfocus.com> 3/1/2016 9:26 PM >>>







Hi.

Thanks for the responses.

If I were to give CalDAV another port, can I use port 444for example?

And if so what changes in Mac Mail will I need to make if that's

possible?







--

Cougie

------------------------------------------------------------------------
Cougie's Profile: https://forums.novell.com/member.php?userid=102654


View this thread: https://forums.novell.com/showthread.php?t=497049
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.