jesullivan Frequent Contributor.
Frequent Contributor.
1316 views

Issue Stopping PO Agents

We recently needed to restart our GroupWise servers. I was able to shutdown all of the services (MTA's and GWIA) from the web admin site. Neither of our PO Agents would fully shutdown though. It stayed in a stopping status for over 25 minutes. I eventually had to kill the process. Afterwards I checked the logs. Both PO Agents show that they were waiting for a GWTCP handler to terminate: 'Waiting for GWTCP-SBRM-Handler_38 to terminate'. We are currently on 14.2.2hp1 build 128215. The servers are running on Win Server 2012. They had been restarted only one week prior when we took the latest update. Has anyone else seen this issue?

Thanks
Jeremy
Labels (1)
0 Likes
15 Replies
Knowledge Partner
Knowledge Partner

Re: Issue Stopping PO Agents

In article <jesullivan.84tozc@no-mx.forums.microfocus.com>, Jesullivan
wrote:
> It stayed in a
> stopping status for over 25 minutes. I eventually had to kill the
> process. Afterwards I checked the logs. Both PO Agents show that they
> were waiting for a GWTCP handler to terminate: 'Waiting for
> GWTCP-SBRM-Handler_38 to terminate'.


It looks like something is hanging on to that connection they way they
shouldn't
First place to look is if there is any firewall on this server that is
actively trying to manage the connection. If so stop them from messing
with the GroupWise ports. To test, shut down that firewall (assumes this
is reproducible, or when you find the POA taking long to stop)

do you have remote users with slow connections and no limits on the size
of attachments that can be sent in the system? If so, some limits might
be in order http://www.konecnyad.ca/andyk/gwlimits.htm


Andy of
http://KonecnyConsulting.ca in Toronto
Knowledge Partner
http://forums.novell.com/member.php/75037-konecnya
If you find a post helpful and are logged in the Web interface, please
show your appreciation by clicking on the star below. Thanks!

___
Andy of Konecny Consulting in Toronto
Knowledge Partner Profile
If you find a post helpful, click the Like button below. Thanks!
0 Likes
jesullivan Frequent Contributor.
Frequent Contributor.

Re: Issue Stopping PO Agents

I confirmed that the windows firewall is turned off. We don't have any other firewall software on the box itself. As far as users go we only have online groupwise client users. Just to follow up on this. We had to same issues today while trying to shutdown GW. This seems to have started after taking the lastest hot patch.

Thanks
Jeremy
0 Likes
Knowledge Partner
Knowledge Partner

Re: Issue Stopping PO Agents

In article <jesullivan.858syo@no-mx.forums.microfocus.com>, Jesullivan
wrote:
> This seems to have
> started after taking the lastest hot patch.


Hmm, pity I don't have this running on a Windows system to test. (All
my clients run on SLES or OES)
What versions of client do you have running? If you have the time for
testing, it would be interesting to see if which clients being
connected makes a difference. Does this happen if there are no clients
connected? Can you spin a copy of this into an isolated lab?
I was hoping someone with a similar setup would have joined us by now.

Andy of
http://KonecnyConsulting.ca in Toronto
Knowledge Partner
http://forums.novell.com/member.php/75037-konecnya
If you find a post helpful and are logged in the Web interface, please
show your appreciation by clicking on the star below. Thanks!

___
Andy of Konecny Consulting in Toronto
Knowledge Partner Profile
If you find a post helpful, click the Like button below. Thanks!
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Issue Stopping PO Agents

Hi Jeremy,

I recommend you take a look on the POA Web Console --> Status tab --> C/S Handler Threads (under Thread Status) --> see if any of them remain in a state other than Idle with a climbing Time Elapsed (Secs) count. Please let us know.

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
jesullivan Frequent Contributor.
Frequent Contributor.

Re: Issue Stopping PO Agents

Laura,

I checked. We have 34 C/S Handler Threads with elapsed time in one POA. Our other POA has 4 threads with elapsed time. All of these threads are in a 'Handle Request' state.

Thanks
Jeremy
0 Likes
Knowledge Partner
Knowledge Partner

Re: Issue Stopping PO Agents

In article <jesullivan.85yhyn@no-mx.forums.microfocus.com>, Jesullivan
wrote:
> I checked. We have 34 C/S Handler Threads with elapsed time in one POA.
> Our other POA has 4 threads with elapsed time. All of these threads
> are in a 'Handle Request' state.


What sort of times are you seeing? Just a few seconds? hundreds of
seconds? Much higher? Things like rules running against the entire
mailbox or a mass delete/move can cause these longer ones, but those
aren't common.
If you drill in to each of them, you can see what client (who and IP) is
related. They should be different, if not you have both a PC to check out
and an account to run maintenance against.
Is there anything in common with those users/IPs? Such as all in a
specific location going through a common router/firewall along the line.
And still concerned that you might be running too tight on resources on
the server.


Andy of
http://KonecnyConsulting.ca in Toronto
Knowledge Partner
http://forums.novell.com/member.php/75037-konecnya
If you find a post helpful and are logged in the Web interface, please
show your appreciation by clicking on the star below. Thanks!

___
Andy of Konecny Consulting in Toronto
Knowledge Partner Profile
If you find a post helpful, click the Like button below. Thanks!
0 Likes
jesullivan Frequent Contributor.
Frequent Contributor.

Re: Issue Stopping PO Agents

Andy,

The thread seconds go from 950,000 seconds all the way down to 5063 seconds. I did notice that there are a pair of handlers for each unique Time Elapsed value. So for example both Handlers 65 and 66 have the same time elapse of 5063. Eight pairs of handlers don't have anything in the User ID field. The rest have different user ids for each pair. I also confirmed that each has a different ip address. The majority have 'Read fields' as the current transaction. A couple have 'Read Distribution List' and 'Read Whole Items'.

Thanks
Jeremy
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Issue Stopping PO Agents

Hi Jeremy

I have seen this on Windows servers before. I recommend that you get the latest FTF. As far as I am aware some work has been done on thread optimization for Windows servers. I can't say for sure if it will solve your issue 100% but am confident that it should make a difference.

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
jesullivan Frequent Contributor.
Frequent Contributor.

Re: Issue Stopping PO Agents

Laura,

I'll ask support about the FTF and let you know how it goes. Thanks for your help.

Jeremy
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Issue Stopping PO Agents

Hi Jeremy,

Once you've patched your servers I would really appreciate feedback from you. Many thanks in advance.

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
jesullivan Frequent Contributor.
Frequent Contributor.

Re: Issue Stopping PO Agents

Well we applied the FTF a few days ago. I'm already seeing C/S handler threads with large time elapsed amounts. It will take about a week to see if it helps the client refresh issues. In the meantime the FTF seems to have caused a issue on the web server. I now have multiple people reporting that they are unable to sent emails from the web client. It gives them a 'user not on post office' error. The same users are able to send emails fine from the full client. The weird thing is this isn't affecting everyone. It seems to be random people on both of our post offices. I've contacted support a couple of times now. No response.
0 Likes
Knowledge Partner
Knowledge Partner

Re: Issue Stopping PO Agents

In article <jesullivan.86b2qn@no-mx.forums.microfocus.com>, Jesullivan
wrote:
> I now have multiple
> people reporting that they are unable to sent emails from the web
> client. It gives them a 'user not on post office' error.


Was Webaccess started before or after the POAs?
Make sure it is after.


Andy of
http://KonecnyConsulting.ca in Toronto
Knowledge Partner
http://forums.novell.com/member.php/75037-konecnya
If you find a post helpful and are logged in the Web interface, please
show your appreciation by clicking on the star below. Thanks!

___
Andy of Konecny Consulting in Toronto
Knowledge Partner Profile
If you find a post helpful, click the Like button below. Thanks!
0 Likes
Highlighted
jesullivan Frequent Contributor.
Frequent Contributor.

Re: Issue Stopping PO Agents

It was updated last and started after everything else was back up. I've determined that the issue has something to do with the Address Book. They aren't able to reply to emails or start new ones using the groupwise address book. I was able to send a email from one of the affected accounts by typing a email address in directly instead of using the address book. Weird.
0 Likes
Knowledge Partner
Knowledge Partner

Re: Issue Stopping PO Agents

In article <jesullivan.86h9fb@no-mx.forums.microfocus.com>, Jesullivan
wrote:
> They aren't able to reply to emails or start new ones using the
> groupwise address book. I was able to send a email from one of the
> affected accounts by typing a email address in directly instead of using
> the address book. Weird.


A) report that to the SR you have open
B) do you run regular Maintenance on the PostOffices? Make sure they are
running and check the results as those reports may well have the answer in
them. http://www.konecnyad.ca/andyk/gwmnt5x.htm

which build did you get?


Andy of
http://KonecnyConsulting.ca in Toronto
Knowledge Partner
http://forums.novell.com/member.php/75037-konecnya
If you find a post helpful and are logged in the Web interface, please
show your appreciation by clicking on the star below. Thanks!

___
Andy of Konecny Consulting in Toronto
Knowledge Partner Profile
If you find a post helpful, click the Like button below. Thanks!
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.