Our vBulletin migration is complete.
Welcome vBulletin users! All content and user information from the Micro Focus Forums (vBulletin) site has been migrated to this site. READ MORE.
mmoshcs Contributor.
Contributor.
1472 views

Issue with DST for Aus CST timezone?

Only reference I've found to a similar issue is http://forums.novell.com/novell-product-discussions/collaboration/groupwise/groupwise-2012/gw2012-web-access/453422-off-one-hour-gw-webaccess-12-eastern-time-zone.html

All emails and appointments in webaccess are showing as 1 hour earlier than actual, the groupwise client however is fine. Server OS timezone is set correctly as far as I can tell. Is there something I can check or is this likely a bug?

We are running 2012 SP1, exact version as listed in webaccess is
Build Number: 103731
Program Release: 12.0.1 9/6/2012

Regards
Matt
Labels (2)
0 Likes
8 Replies
buckesfeld Absent Member.
Absent Member.

Re: Issue with DST for Aus CST timezone?

Matt,

is the timezone set correctly in WebAccess? I see problems here with timezone detection, WebAccess picks whatever seems close, which, for GMT+1, unfortunately has the wrong DST settings. Manually setting the timezone in WebAccess helps.

Uwe


--
Novell Knowledge Partner (NKP)
Please don't send me support related e-mail unless I ask you to do so.
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Issue with DST for Aus CST timezone?

As far as I know, in SP1 for 2012 WebAccess detects the time zone settings of the PC and works according to that.

There is no setting in the WebAccess interface to select the time zone settings.

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
mmoshcs Contributor.
Contributor.

Re: Issue with DST for Aus CST timezone?

If there is no setting in webacces to set the timezone, which matches what I've found when looking at the conf files and user interface, what can I do to resolve this? Times were fine until the DST change that happen over the weekend.
0 Likes
buckesfeld Absent Member.
Absent Member.

Re: Issue with DST for Aus CST timezone?

* laurabuckley wrote, On 10/10/2012 11:16 AM:
> There is no setting in the WebAccess interface to select the time zone
> settings.


In the webaccess client interface?

Uwe

--
Novell Knowledge Partner (NKP)
Please don't send me support related e-mail unless I ask you to do so.
0 Likes
Knowledge Partner
Knowledge Partner

Re: Issue with DST for Aus CST timezone?

buckesfeld;2223644 wrote:
* laurabuckley wrote, On 10/10/2012 11:16 AM:
> There is no setting in the WebAccess interface to select the time zone
> settings.


In the webaccess client interface?

Uwe

--
Novell Knowledge Partner (NKP)
Please don't send me support related e-mail unless I ask you to do so.


That's correct. In GW 2012 SP1, the option to specify timezone was removed in the webaccess client.
It relies solely upon some java script things to fetch/obtain the time and prior to SP1, there were certain things that would block that from running (NAM was one of them, but we also duped it with our IBM WebSphere Portal SSO feature).

Basically if you front-end with NAM, you have to use Identity Injection not FormFill if you want the code to work properly.
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Issue with DST for Aus CST timezone?

Uwe - the webaccess client interface has NO option for timezone settings in SP1 - it reads the settings from the PC - which, of course, has it's own problems.

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
mmoshcs Contributor.
Contributor.

Re: Issue with DST for Aus CST timezone?

I'm using NAM but not for SSO, just as a reverse proxy. The issue is still present if I access webacc direct url thus bypassing NAM. Is there anything I can do to find out why it's not working or is the timezone stuff a big black box in terms of operation?

I'm confirmed that the timezone configuration in consoleone is correct, not sure if that is what webaccess uses however.
0 Likes
Knowledge Partner
Knowledge Partner

Re: Issue with DST for Aus CST timezone?

mmoshcs;2223893 wrote:
I'm using NAM but not for SSO, just as a reverse proxy. The issue is still present if I access webacc direct url thus bypassing NAM. Is there anything I can do to find out why it's not working or is the timezone stuff a big black box in terms of operation?

I'm confirmed that the timezone configuration in consoleone is correct, not sure if that is what webaccess uses however.


As Laura mentioned, in GW 2012 SP1, there's no timezone config anymore, it's all within the browser code (if you view the source code on the login page, you'll see the lines that are in there).

Now, if you are NOT on GW 2012 SP1, then you should have the option for setting the timezone but that would require the release GW 2012 and no FTF's after that to be present.

Note: In GW 2012 RELEASED, I believe that for EASTERN time, there was a bug where no matter what, the time would be off by one hour, so perhaps there's another bug that wasn't documented as a TID in GW 2012 that also did the same thing for Australian CST time?

Either way, can you update to GW 2012 SP1 on the webaccess server?
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.