NOTICE: Significant community changes coming soon
The header menu and the home page on our community will be changing soon. Get more information HERE.
Highlighted
Absent Member.
Absent Member.
3120 views

MAPI Intergration with applications

Since the update from GW14 client to GW18, users can no longer send emails from Excel (2013/2016) and Sage. If we roll back to the GW14 client it works fine.

For some users it works, but they receive prompts to load the GW Profile (Which doesn't help if sage is trying to send 50 mails as the prompt appears 50 times) but for others there is just an error.

Do you know if there is any fix for this? Or even a workaround to get it working.

Thanks

Mark
Labels (1)
Tags (3)
0 Likes
24 Replies
Highlighted
Micro Focus Expert
Micro Focus Expert

Hi Mark,

I recently worked with a customer using a third-party application to store their PDF's in, access them in this app, and when trying to send as an attachment would get the error that there's no default client. Engineering managed to fix this particular issue. Perhaps the FTF of the client that solved the customer's issue will solve your issue too. Please open a service request and ask for the latest FTF of the GroupWise client.

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
Highlighted
Absent Member.
Absent Member.

laurabuckley;2488132 wrote:
Hi Mark,

I recently worked with a customer using a third-party application to store their PDF's in, access them in this app, and when trying to send as an attachment would get the error that there's no default client. Engineering managed to fix this particular issue. Perhaps the FTF of the client that solved the customer's issue will solve your issue too. Please open a service request and ask for the latest FTF of the GroupWise client.

Cheers,


Thanks Laura

I'll do that, but what is FTF?

Thanks

Mark
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Hi Mark,

FTF = Field Test File --> it's an updated, but not publically released, patch.

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
Highlighted
Absent Member.
Absent Member.

peawet08;2488129 wrote:
Since the update from GW14 client to GW18, users can no longer send emails from Excel (2013/2016) and Sage. If we roll back to the GW14 client it works fine.

For some users it works, but they receive prompts to load the GW Profile (Which doesn't help if sage is trying to send 50 mails as the prompt appears 50 times) but for others there is just an error.

Do you know if there is any fix for this? Or even a workaround to get it working.

Thanks

Mark


Hello,
we have had a similiar Problem. It´s absolutely urgent...

You Need to set up the Windows-E-Mail-Profile before starting the process
AND
you need to check all Default Apps (Standard-Apps, formerly "Standardprogramme") within Windows-Settings.
Windows-Settings differ from Version to Version.

After Installing GW18.0.2-client within a clean windows-Environment, gw-client has only 6 of 10 Windows-Defaults for E-Mail.
Even "GroupWise MAILTO Protocol Handler" and some other things are inactive.
Try to check this and activate all Windows-Mail-functions as Default to groupwise.

Found an interessting link for creating an gpo (.adm) here, but did not test it up to now:
https://support.microsoft.com/de-de/help/2008044/how-to-configure-the-default-e-mail-client-using-group-policy
Has to be customized for GroupWise...
Looking for help too.

Would be great to see GroupWise-Client-Setup setting all Defaults correctly within the next build.

Regards
JF
0 Likes
Highlighted
Absent Member.
Absent Member.

Hello,
is there any way, to get a tested and publically released patch for MAPI / MAIL Profile / Default Apps soon?
Best regards
JF
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Hi JF,

There is an upcoming release of GroupWise.

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
Highlighted
Absent Member.
Absent Member.

Hi Laura,

Do you know if there is a new release with the MAPI fix in that we can test on the machines we are experiencing the mailing issue with? They are currently using GW14 instead.

Thanks

Mark
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Hi Mark,

GroupWise 18.1 shipped on 31 October 2018.

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
Highlighted
Absent Member.
Absent Member.

Hi Laura,

Thanks, I missed that. Are there release notes anywhere listing fixes?

Thank you

Mark
0 Likes
Highlighted
Absent Member.
Absent Member.

Hi,
we are using GW 18.1.0 Build 132662, Dec. 2018, still getting mapi Errors, see:
Mapi_Send()
- MAPILogon()
---- mail-Objekt:
{[Betreff][VAL_QSTRING]=[Dokument, EXTERNE],[Anlagen][VAL_QSTRING]=[|C:\\Users\\username\\AppData\\Local\\Temp\\... .xls],[Optionen][VAL_QSTRING]=[Dialog]}
Fehlercode: 0x3
0 Likes
Highlighted
Trusted Contributor.
Trusted Contributor.

We have nearly the same problem:

With GW 18.1 it will not work. With GW 14.2 and then updating to 18.1 it will work only for the actually user, but if another user login, we have to install 14.2 and 18.1 once more. We see this only with one application creating one or more pdf and open groupwise new mail this the pdf as attachment and the recipient insert also.

I´m lookup for a solution since days. the message is no default mail client installed.....

All associations are set correctly. All other programs has no problem with sendto

0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.