Highlighted
Absent Member.
Absent Member.
261 views

Migration GW8 to GW2014R2, PostOffice MTP Inbound IP still on oldserver


Hi



we have to following migration scenario:



GW8 on OES2 (SLES10) should be migrated to GW2014R2 on OES2015 (SLES11SP4)



what we did

- from a Windows-PC, we used dbcopy to copy the Post Office data (two passes, -f and -s to finalize) from the old to the new server.


- from a the same Windows-PC, we used dbcopy to copy the Domain data from the old to the new server.

- we installed GW2014R2 on the new server

- we choosed upgrade and selected the Domain and the PostOffice directories on the new server

- the update reported success and Domain and PostOffice Version are on 1420 and MTA and POA Agents are running



But MTA can not communicate with the PostOffice. When looking at the MTP Status of the PostOffice-Agent, i can see that the Inbound IP-address still points to the old server.



Where can i change this address? (I did set of course the new IP-address in the Postoffice Agent, but that set obviously only the outbound address)



did i miss something or is this migration path i took not working at all?

When i started the upgrade on the new server, i think id did not stop the GroupWise-services on the old server. Might that be the reason that the old IP is still somewhere in the PostOffice files on the new server?



Thank you

Andrej
Labels (1)
0 Likes
3 Replies
Highlighted
Knowledge Partner
Knowledge Partner

Re: Migration GW8 to GW2014R2, PostOffice MTP Inbound IP still on oldserver

Hi.

You basically have two options:

1. In the Groupwise Admin interface correct the IP addresses for domain
and post office, and once down do a rebuild of the post office from there.

2. Use the mtpinipaddr switch in the POA startup file:

https://www.novell.com/documentation/groupwise2014r2/gw2014_guide_admin/data/aasstks.html

CU,
Massimo

On 29.11.2017 11:13, Andrej Dimic wrote:
>
> Hi
>
>
>
> we have to following migration scenario:
>
>
>
> GW8 on OES2 (SLES10) should be migrated to GW2014R2 on OES2015 (SLES11SP4)
>
>
>
> what we did
>
> - from a Windows-PC, we used dbcopy to copy the Post Office data (two passes, -f and -s to finalize) from the old to the new server.
>
>
> - from a the same Windows-PC, we used dbcopy to copy the Domain data from the old to the new server.
>
> - we installed GW2014R2 on the new server
>
> - we choosed upgrade and selected the Domain and the PostOffice directories on the new server
>
> - the update reported success and Domain and PostOffice Version are on 1420 and MTA and POA Agents are running
>
>
>
> But MTA can not communicate with the PostOffice. When looking at the MTP Status of the PostOffice-Agent, i can see that the Inbound IP-address still points to the old server.
>
>
>
> Where can i change this address? (I did set of course the new IP-address in the Postoffice Agent, but that set obviously only the outbound address)
>
>
>
> did i miss something or is this migration path i took not working at all?
>
> When i started the upgrade on the new server, i think id did not stop the GroupWise-services on the old server. Might that be the reason that the old IP is still somewhere in the PostOffice files on the new server?
>
>
>
> Thank you
>
> Andrej
>



--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
0 Likes
Highlighted
Absent Member.
Absent Member.

Antw: Re: Migration GW8 to GW2014R2, PostOffice MTP Inbound IPstill on oldserver


Hi Massimo



many thanks for you valuable information.



Allow me a follow-up question:

i will be restarting the whole migration from scratch. Including deleting the PostOffice and Domain directories and doing a dbcopy once again.



what is the easiest way to set GroupWise (on the new Server) to the initial state so that the GroupWise-Installation / upgrade can be done again?



would it be sufficent to delete all PostOffice and Domain directories and to delete /etc/opt/novell/groupwise/gwha.* ?



Thank you

Andrej







>>> Massimo Rosen<mrosenNO@SPAMcfc-it.de> 29.11.2017 12:11 >>>



Hi.




You basically have two options:




1. In the Groupwise Admin interface correct the IP addresses for domain

and post office, and once down do a rebuild of the post office from there.




2. Use the mtpinipaddr switch in the POA startup file:



https://www.novell.com/documentation/groupwise2014r2/gw2014_guide_admin/data/aasstks.html






CU,

Massimo




On 29.11.2017 11:13, Andrej Dimic wrote:


>



> Hi



>



>



>



> we have to following migration scenario:



>



>



>



> GW8 on OES2 (SLES10) should be migrated to GW2014R2 on OES2015 (SLES11SP4)



>



>



>



> what we did



>



> - from a Windows-PC, we used dbcopy to copy the Post Office data (two passes, -f and -s to finalize) from the old to the new server.



>



>



> - from a the same Windows-PC, we used dbcopy to copy the Domain data from the old to the new server.



>



> - we installed GW2014R2 on the new server



>



> - we choosed upgrade and selected the Domain and the PostOffice directories on the new server



>



> - the update reported success and Domain and PostOffice Version are on 1420 and MTA and POA Agents are running



>



>



>



> But MTA can not communicate with the PostOffice. When looking at the MTP Status of the PostOffice-Agent, i can see that the Inbound IP-address still points to the old server.



>



>



>



> Where can i change this address? (I did set of course the new IP-address in the Postoffice Agent, but that set obviously only the outbound address)



>



>



>



> did i miss something or is this migration path i took not working at all?



>



> When i started the upgrade on the new server, i think id did not stop the GroupWise-services on the old server. Might that be the reason that the old IP is still somewhere in the PostOffice files on the new server?



>



>



>



> Thank you



>



> Andrej



>








--

Massimo Rosen

Micro Focus Knowledge Partner

No emails please!
http://www.cfc-it.de
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: Antw: Re: Migration GW8 to GW2014R2, PostOffice MTP Inbound IPstill on oldserver

On 29.11.2017 13:55, Andrej Dimic wrote:
>
> Hi Massimo
>
>
>
> many thanks for you valuable information.
>
>
>
> Allow me a follow-up question:
>
> i will be restarting the whole migration from scratch. Including deleting the PostOffice and Domain directories and doing a dbcopy once again.
>
>
>
> what is the easiest way to set GroupWise (on the new Server) to the initial state so that the GroupWise-Installation / upgrade can be done again?
>
>
>
> would it be sufficent to delete all PostOffice and Domain directories and to delete /etc/opt/novell/groupwise/gwha.* ?
>
>
>
> Thank you
>
> Andrej
>
>
>
>
>
>
>>>> Massimo Rosen<mrosenNO@SPAMcfc-it.de> 29.11.2017 12:11 >>>

>
>
> Hi.
>
>
>
>
> You basically have two options:
>
>
>
>
> 1. In the Groupwise Admin interface correct the IP addresses for domain
>
> and post office, and once down do a rebuild of the post office from there.
>
>
>
>
> 2. Use the mtpinipaddr switch in the POA startup file:
>
>
>
> https://www.novell.com/documentation/groupwise2014r2/gw2014_guide_admin/data/aasstks.html
>
>
>
>
>
>
> CU,
>
> Massimo
>
>
>
>
> On 29.11.2017 11:13, Andrej Dimic wrote:
>
>>

>
>> Hi

>
>>

>
>>

>
>>

>
>> we have to following migration scenario:

>
>>

>
>>

>
>>

>
>> GW8 on OES2 (SLES10) should be migrated to GW2014R2 on OES2015 (SLES11SP4)

>
>>

>
>>

>
>>

>
>> what we did

>
>>

>
>> - from a Windows-PC, we used dbcopy to copy the Post Office data (two passes, -f and -s to finalize) from the old to the new server.

>
>>

>
>>

>
>> - from a the same Windows-PC, we used dbcopy to copy the Domain data from the old to the new server.

>
>>

>
>> - we installed GW2014R2 on the new server

>
>>

>
>> - we choosed upgrade and selected the Domain and the PostOffice directories on the new server

>
>>

>
>> - the update reported success and Domain and PostOffice Version are on 1420 and MTA and POA Agents are running

>
>>

>
>>

>
>>

>
>> But MTA can not communicate with the PostOffice. When looking at the MTP Status of the PostOffice-Agent, i can see that the Inbound IP-address still points to the old server.

>
>>

>
>>

>
>>

>
>> Where can i change this address? (I did set of course the new IP-address in the Postoffice Agent, but that set obviously only the outbound address)

>
>>

>
>>

>
>>

>
>> did i miss something or is this migration path i took not working at all?

>
>>

>
>> When i started the upgrade on the new server, i think id did not stop the GroupWise-services on the old server. Might that be the reason that the old IP is still somewhere in the PostOffice files on the new server?



Personally, I would also use rpm to uninstall the groupwise rpms and
reinstall them too.

rpm -qa | grep groupwise

To get a list of them, followed by rpm -e <nameofpackage>

CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.