Highlighted
Absent Member.
Absent Member.
1075 views

On RCGroupwise restart an old message pops up?

Hi,
New on Groupwise systems, so I hope to make a shortcut here.

Problem: When we restart our post office, an old message (with attachment) from one of our clients pops up in recipients mail boxes.

We asked our client to delete all traces of the mail from his mailbox, but after a restart today (kernel update) same thing happened.

I suspect this mail is hidden in some of the many queues in the groupwise system, but where? All advice is welcome.

brgds
Labels (2)
Tags (2)
0 Likes
4 Replies
Highlighted
Knowledge Partner
Knowledge Partner

Re: On RCGroupwise restart an old message pops up?

leonsmit;2338434 wrote:
Hi,
New on Groupwise systems, so I hope to make a shortcut here.

Problem: When we restart our post office, an old message (with attachment) from one of our clients pops up in recipients mail boxes.

We asked our client to delete all traces of the mail from his mailbox, but after a restart today (kernel update) same thing happened.

I suspect this mail is hidden in some of the many queues in the groupwise system, but where? All advice is welcome.

brgds


It could be the message is not being cleared/deleted from the delivery queue when having been delivered and thus gets redelivered after a service/server restart. At least I've seen that once or twice.

You could try stopping the postoffice (during offhours when there is not much email activity), then rename the wpcsin and wpcsout folders in the po folder and restart the po service again.

Cheers,
Willem
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: On RCGroupwise restart an old message pops up?

Thinking back a bit more, I think it was a message that was stuck in the GWIA queues (found in the wpgate folder of the owning domain), and not in the POA queue.

Cheers,
Willem
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: On RCGroupwise restart an old message pops up?

magic31;2338479 wrote:
Thinking back a bit more, I think it was a message that was stuck in the GWIA queues (found in the wpgate folder of the owning domain), and not in the POA queue.

Cheers,
Willem


Thanks Willem,
I have located the message in the /wpgate/send queue. Its from february 2014, and it seems like its stuck there for some reason. So whats next? Is it possible to just delete the file and then problem solved, or do I need to make any other alterations?

brgds
Leon
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: On RCGroupwise restart an old message pops up?

Hi Leon,

leonsmit;2338573 wrote:
I have located the message in the /wpgate/send queue. Its from february 2014, and it seems like its stuck there for some reason. So whats next? Is it possible to just delete the file and then problem solved, or do I need to make any other alterations?


Good & nope, nothing special needed. Just delete that file, test by restarting the GWIA service and you should be good. I never got around to finding out why that file would not process and delete... but I suspect the messages in question that I had, were sent with a using delayed delivery and something in that process went wrong causing the loop.

Cheers,
Willem
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.