Highlighted
Absent Member.
Absent Member.
747 views

POA Problem

My weekly maintenance gwcheck has reported back an issue I've not seen
before.

Checking for message databases that are not active

Problem 91- Database ngwdfr.db in Store Catalog(ngwguard.db) but not
found on disk

What needs done to resolve this issue? Running gw2012sp2 on sles11sp3
/ oes11sp2.

--
Stevo
Labels (2)
0 Likes
3 Replies
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: POA Problem

Hi Stevo,

The ngwdfr.db is where deferred messages are stored. Not too sure why yours is missing.

There are couple of things that you could do....

Firstly, seeing as the ngwguard.db is cached at POA startup you could try to simply shutdown the POA and once cleanly exited, start it up again and see if the problem continues.

If that doesn't work you could try the following to completely drop the deferred message database, but NOTE you will lose all deferred messages and user move verification:

1. Execute Software Distribution Directory\admin\utility\gwcheck\gwcheck.exe
2. Database Type - Post Office | Database Path - pathToPostOfficeDirectory | Post Office Name - Enter the Post Office Name as it appears in ConsoleOne
3. Object Type - User / Resource
4. Type NGWDFR.DB in the Object Type
5. Action - Structural Rebuild
6. Click Run
7. We should see an error message stating that NGWDFR.DB is dropped from the Guardian.

Note: You will lose any delayed messages and verification that all moves have been completed. NGWDFR.DB will be recreated automatically when the next delayed delivery message is sent, or when the next user is moved.

Let us know how it goes.

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: POA Problem

Well, simply exiting and restarting the POA did not help. So, did the
other steps, got the error about the missing db and it getting dropped.

Afterwards, ran another gwcheck, no problem 91 this time.

Thanks!


--
Stevo
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: POA Problem

Hi Stevo,

Pleasure is all mine. Glad that we managed to resolve your issue 🙂

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.