Highlighted
Absent Member.
Absent Member.
1730 views

Service only works during 10secs then hangs

Hello there!

My mobility service has a strange behavior. When i restart the service, it processes and syncs the accumulated tasks then it stops syncing again until i restart the service again.
I was using mobility 1.2.5 299 and even updated to mobility service 2.0 but the problem persists.
Already looked into logs but can't seem to find anything that points me to the right direction.

At the web console i can see the message "Time to Process GroupWise Events: It is taking a long time to receive events from GroupWise" but thats all.
Currently with 81 users and around 90 devices.

Some help would be greatly appreciated.

Thank You
Labels (1)
0 Likes
7 Replies
Highlighted
Knowledge Partner
Knowledge Partner

Re: Service only works during 10secs then hangs

nandofo;2306201 wrote:
Hello there!

My mobility service has a strange behavior. When i restart the service, it processes and syncs the accumulated tasks then it stops syncing again until i restart the service again.
I was using mobility 1.2.5 299 and even updated to mobility service 2.0 but the problem persists.
Already looked into logs but can't seem to find anything that points me to the right direction.

At the web console i can see the message "Time to Process GroupWise Events: It is taking a long time to receive events from GroupWise" but thats all.
Currently with 81 users and around 90 devices.

Some help would be greatly appreciated.

Thank You


Does the whole GMS service stop? Or just one of the sync agents?

It would be good to know some more details:

-Which GroupWise version(s) and patchlevels are running on the postoffices, and on which OS and patchlevel?
-What's the version/patchlevel of the server you are using for Mobility?
- Did the update.sh script (after patching/upgrading the packages to GMS 2.0) run through cleanly?


These pointers for the documentation might help:
https://www.novell.com/documentation/groupwisemobility2/gwmob2_guide_admin/data/admin_appndx_tshoot_gwsync.html
https://www.novell.com/documentation/groupwisemobility2/gwmob2_guide_admin/data/admin_appndx_tshoot_devsync.html


Cheers,
Willem
0 Likes
Highlighted
Outstanding Contributor.
Outstanding Contributor.

Re: Service only works during 10secs then hangs

How much disk space do you have free on the mobility server? IIRC <10% and the services will stop.

Mark.
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: Service only works during 10secs then hangs

MarkDissington,
> How much disk space do you have free on the mobility server? IIRC <10%
> and the services will st


Yes, that is a very nice feature 🙂 Bit me once.

--
Anders Gustafsson (NKP)
The Aaland Islands (N60 E20)

Have an idea for a product enhancement? Please visit:
http://www.novell.com/rms

0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Service only works during 10secs then hangs

Currently i have 28GB free from a total of 40GB.
Groupwise Poa's are running version 12.0.2-108211 on SLES 11 SP2.
Running Mobility service 2.0.0 build 429 on SLES 11 SP2.
The update.sh script ran clean.

Im still out of options here. 😕
Thanks for the replies.
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: Service only works during 10secs then hangs

matos02;2306333 wrote:
Currently i have 28GB free from a total of 40GB.
Groupwise Poa's are running version 12.0.2-108211 on SLES 11 SP2.
Running Mobility service 2.0.0 build 429 on SLES 11 SP2.
The update.sh script ran clean..


Ok..... You have tried restarting the POA's and then Mobility? I've seen some strangeness with, what seemed, POA events that hadn't processed while 1.2x was still running and causing stress on the 2.0 GMS system. Bouncing both POAs (customer in question had two PO's) followed by the GMS service/server cleared that up.

-Willem
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Service only works during 10secs then hangs

Tried that and the behavior stills the same.
It kinda accumulates everything then only syns when restarted, then it starts to accumulate events again untill restarted.
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: Service only works during 10secs then hangs

In article <matos02.69ix5z@no-mx.forums.novell.com>, Matos02 wrote:
> Im still out of options here. 😕
>

Additional options:
- are there any errors showing in the POA logs? what are they?
- Look for the IP of GMS on the POA logs, does it keep talking with the
POA after the sync has stopped or does it just disappear?
- Can you ping the POA from GMS? If so can you leave one running for a
while, especially past the point of not responding starts.
- Have you vacuumed recently?
http://www.novell.com/support/kb/doc.php?id=7009453
- any folders grown to an unusual size?
du / | sort -n | tail -50
or start with root and drill down from there with
du -h --max-depth=1

/var/lib/datasync/mobility is where the cached attachments appear to
go, so you can expect that to have some size of note if you have a lot
of attachments flowing. I periodically check that one directly with
du /var/lib/datasync -hx --max-depth=1



Andy of
KonecnyConsulting.ca in Toronto
Knowledge Partner
http://forums.novell.com/member.php/75037-konecnya
If you find a post helpful and are logged in the Web interface, please
show your appreciation by clicking on the star below. Thanks!

___
“i’ve sworn an oath of solitude til the blight is purged from these lands”
Andy of Konecny Consulting in Toronto
Knowledge Partner Profile
If you find a post helpful, click the Like button below. Thanks!
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.