Highlighted
Absent Member.
Absent Member.
859 views

Unable to Add Secondary Domain

GW 14.2.2 / SLES 11 SP4

I am trying to create a secondary domain on a brand new server. The software installation gives no errors. I run the Installation console, select Add a New Domain and enter the requisite information. I get an error pop-up "Unable to add secondary domain ()" when I click Finish.

It appears that the process is partially successful - The new domain appears under the primary domain's Admin console and the domain's directory structure is fleshed out on the new server. However, the MTA fails to start and not all of the usual files appear in the domain's home directory, e.g. there's a wpdomain.db file but not wpdomain.dc and the wp... subdirectories are missing. The Admin console shows a Pending Operations, one with an ObjectID named for the new domain and Operation = Modified, and a second with a hex-character named ObjectID and Operation = Added.

The symptoms are similar to those described in post https://forums.novell.com/showthread.php/498674-Unable-to-add-secondary-domain-due-to-Certificate-error. However, /opt/novell/groupwise/certificates/ is empty until I try to add the new domain.

Any suggestions on where to look for additional troubleshooting info?

Thx!
Labels (1)
0 Likes
4 Replies
Highlighted
Absent Member.
Absent Member.

Re: Unable to Add Secondary Domain

Did the objects get created in the admin console / GroupWise Database?
If so, try and copy the relevant *.dc files to the domain directory and start the MTA.
The directories should be then created by the mta - or if your prefer your can create them yourself.
Where does your domain directory reside? on Linux filesystem (which one) or NSS?
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Unable to Add Secondary Domain

Copying to *.dc files to the new domain's directory let the MTA start. The MTA created the missing sub-directories. Thx!

btw - We use EXT3 filesystems on our SLES11 GW servers.
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Re: Unable to Add Secondary Domain

Hi CB,

Just so you are aware, the agents, MTA/POA, will create directories such as WPCSIN and WPCSOUT and the necessary sub-directories on each start if they are not there 😉

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: Unable to Add Secondary Domain

I ran into pretty much the same problem adding a post office to the new domain. Copying the *.dc files (probably only needed wphost.dc and ngwguard.dc) to the PO's directory before adding the PO fixed it. Go figure.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.