chris_im_foruml Absent Member.
Absent Member.

Re: Unable to connect to GW with soap

I found it!!!

Disable the proxy if it is enabled. I saw in the logfile a "302 forbidden"

Chris

dzanre;1954836 wrote:
Yes - you can look in the /var/log/datasync/mobilityPackInstall.log


You should see lines like this:

Fri Mar 26 14:22:10 MDT 2010: Datasync.ValidateIPorHostname:entering with name 192.168.100.238
Fri Mar 26 14:22:10 MDT 2010: Datasync.ValidateIPorHostname:data ok.
Fri Mar 26 14:22:10 MDT 2010: Datasync.VerifyTrustedAppLogin:executing: python /opt/novell/datasync/syncengine/connectors/mobility/cli/gw_login.pyc --gw=https://192.168.100.238:7191 --appname='Mobility' --key='9B018700037400008511D1E9003ADE608C0187010374000097086088A801CB14'
Fri Mar 26 14:22:12 MDT 2010: Datasync.VerifyTrustedAppLogin:return code from verify:$["exit":0, "stderr":"", "stdout":"true\n"]
0 Likes
dzanre1 Absent Member.
Absent Member.

Re: Unable to connect to GW with soap

You mean the proxy on the SLES box itself, right?
0 Likes
d3b14n Absent Member.
Absent Member.

Re: Unable to connect to GW with soap

chris_im_foruml;1954839 wrote:
I found it!!!

Disable the proxy if it is enabled. I saw in the logfile a "302 forbidden"

Chris


chris,

you're my hero of the day!!!
connection worked now I will go on with the installation and report on any upcoming issues!

thx again, you made my day!
poldy
0 Likes
d3b14n Absent Member.
Absent Member.

Re: Unable to connect to GW with soap

dzanre;1954846 wrote:
You mean the proxy on the SLES box itself, right?


yupe, the culprit here was the system proxy on the sles box itself.
disabled it and rebooted and DataSync was able to connect to GW via the trusted app just fine!
probably put that in your guide, as another requirement!

so thx everyone who tried to help except of that one guy who ignored my pm and opened the same thread. like daaaaah 🙂

poldy
0 Likes
dzanre1 Absent Member.
Absent Member.

Re: Unable to connect to GW with soap

Heehee - well, we can never have too much information on the subject I guess 🙂
0 Likes
Fseguro Absent Member.
Absent Member.

Re: Unable to connect to GW with soap

I have an issue with the latest version of hte Datasync. 484.
I installed the new version on a clean machine. I turned on the verbose logging. When I configure and try to connect to Groupwise with soap, I get a "401, Authorization required" error. It will not connect.

When I connect to the soap port it reports that the PO version is still 8.0.1
But the POA is 8.02. We just updated it. It did not work when the PO was 8.01 either.

When I tried the same thing with the older version of the Datasync it worked.
0 Likes
WalterH Absent Member.
Absent Member.

Re: Unable to connect to GW with soap

Am 20.07.2010 16:06, schrieb Fseguro:
>
> I have an issue with the latest version of hte Datasync. 484.
> I installed the new version on a clean machine. I turned on the verbose
> logging. When I configure and try to connect to Groupwise with soap, I
> get a "401, Authorization required" error. It will not connect.
>
> When I connect to the soap port it reports that the PO version is still
> 8.0.1
> But the POA is 8.02. We just updated it. It did not work when the PO
> was 8.01 either.
>
> When I tried the same thing with the older version of the Datasync it
> worked.
>
>

Did you restart all GW agents on this server after updating?

Walter

0 Likes
Fseguro Absent Member.
Absent Member.

Re: Unable to connect to GW with soap

WalterH;2001011 wrote:
Am 20.07.2010 16:06, schrieb Fseguro:
>
> I have an issue with the latest version of hte Datasync. 484.
> I installed the new version on a clean machine. I turned on the verbose
> logging. When I configure and try to connect to Groupwise with soap, I
> get a "401, Authorization required" error. It will not connect.
>
> When I connect to the soap port it reports that the PO version is still
> 8.0.1
> But the POA is 8.02. We just updated it. It did not work when the PO
> was 8.01 either.
>
> When I tried the same thing with the older version of the Datasync it
> worked.
>
>

Did you restart all GW agents on this server after updating?

Walter


Yes, I did
Still same error.
Tried recreating the Trusted app and still same error.
0 Likes
Fseguro Absent Member.
Absent Member.

Re: Unable to connect to GW with soap

I just got back from Vacation.
I upgraded to the latest release just last week(1.90). I restarted the server. I still get an 401 error Authorization required whenever the GW connector tries to connect to my post office using SOAP.
Any ideas from anyone. It worked prior to version 484

Fernando
0 Likes
jmarton2 Absent Member.
Absent Member.

Re: Unable to connect to GW with soap

Fseguro wrote:

> I just got back from Vacation.
> I upgraded to the latest release just last week(1.90). I restarted the
> server. I still get an 401 error Authorization required whenever the
> GW connector tries to connect to my post office using SOAP.


Are you using SSL for the SOAP connection in the GW Connector? If so,
is SSL enabled in your POA for SOAP?

Perhaps try without SSL first.

--
Novell Knowledge Partner
Enhancement Requests: http://www.novell.com/rms

Joe Marton Emeritus Knowledge Partner
0 Likes
Fseguro Absent Member.
Absent Member.

Re: Unable to connect to GW with soap

No, I am not using SSL for SOAP. Its strange, when i turn on diagnostic logging on the post office, I do not see a SOAP connection attempt. I turned off proxy on the server to make sure it was not that.
Any ideas?
0 Likes
jmarton2 Absent Member.
Absent Member.

Re: Unable to connect to GW with soap

Fseguro wrote:

> No, I am not using SSL for SOAP. Its strange, when i turn on
> diagnostic logging on the post office, I do not see a SOAP connection
> attempt. I turned off proxy on the server to make sure it was not
> that. Any ideas?


Possible firewall blocking port 7191? From the Mobility server, try to
telnet to the POA on port 7191 and see if you connect.

--
Novell Knowledge Partner
Enhancement Requests: http://www.novell.com/rms

Joe Marton Emeritus Knowledge Partner
0 Likes
Fseguro Absent Member.
Absent Member.

Re: Unable to connect to GW with soap

We have a cluster, so I am using another port for soap. I can telent to it and get a reply back with date, servers, ( which still says 8.01, when its running 8.02), content-type and pragma.
0 Likes
jmarton2 Absent Member.
Absent Member.

Re: Unable to connect to GW with soap

Fseguro wrote:

> We have a cluster, so I am using another port for soap. I can telent
> to it and get a reply back with date, servers, ( which still says
> 8.01, when its running 8.02), content-type and pragma.


Is this alternate port also defined in Mobility or is Mobility trying
to use 7191?

--
Novell Knowledge Partner
Enhancement Requests: http://www.novell.com/rms

Joe Marton Emeritus Knowledge Partner
0 Likes
Micro Focus Contributor
Micro Focus Contributor

Re: Unable to connect to GW with soap

What is the status of this issue? Are you still seeing the issue reported?
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.