Highlighted
Absent Member.
Absent Member.
906 views

WebAccces just working with ONE Post Office

I have just installed WebAccess 2014 on a Windows 2016!
Version gw14.2.2hp1_full_win_multi.zip
I can get WebAccess work for only ONE Post Office at time.

I have put in these lines in webacc.cfg.
Provider.SOAP.1.ip=87.116.31.134
Provider.SOAP.1.port=7193
Provider.SOAP.2.ip=87.116.31.133
Provider.SOAP.2.port=7191

Telnet to both IPA / Port are responding - OK!

Both are working when the Post Office is Index (.1.)

FYI: The POA are running on the same Windows 2016 server with 2 IP addresses!

I can change the Index number - but ONLY Provider.SOAP.1 will work but Provider.SOAP.2 give me error message :
"Handling of SOAP protocol is not enabled"

I hope that you can help me!

Best Regards
Soren
Labels (1)
0 Likes
3 Replies
Highlighted
Knowledge Partner
Knowledge Partner

Re: WebAccces just working with ONE Post Office

On 29.11.2017 15:14, SMBCP wrote:
>
> I have just installed WebAccess 2014 on a Windows 2016!
>
> I can get WebAccess work for only ONE Post Office at time.
>
> I have put in these lines in webacc.cfg.
> Provider.SOAP.1.ip=87.116.31.134
> Provider.SOAP.1.port=7193
> Provider.SOAP.2.ip=87.116.31.133
> Provider.SOAP.2.port=7191
>
> Telnet to both IPA / Port are responding - OK!
>
> Both are working when the Post Office is Index (.1.)
>
> FYI: The POA are running on the same Windows 2016 server with 2 IP
> addresses!
>
> I can change the Index number - but ONLY Provider.SOAP.1 will work but
> Provider.SOAP.2 give me error message :
> "Handling of SOAP protocol is not enabled"
>
> I hope that you can help me!


The internal configuration of your IP Adresses /POrts must not match
above. With the configuration in webacc.cfg, you only tell webaccess hot
to find the initial POA to contact. If a user tries to access webaccess
that is *not* in this POA, it will not fall back to the other specified
one, but it will ask the initial POA it contacted for the IP of the
other one. And the answer it gets there must be wrong either way.

So what IPs do you see in the groupwise admin? Are the IPs above
natted/port forwarded to the outside?

CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: WebAccces just working with ONE Post Office

Hi Massimo
Thanks for your reply!

We have 2 Post Office - Diverse and ProProhus. - Both are one same server on LAN 10.1.2.73.

Diverse POA Networks address
IPA: 10.1.2.73
External: 87.116.31.134
C/S port: 1681 for both
SOAP port: 7193 for both

ProPosthus Networks address
IPA: 10.1.2.73
External: 87.116.31.133
C/S port: 1677 for both
SOAP port: 7191 for both

Both external IPA are natted/port forwarded!

Best Regards
Soren
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: WebAccces just working with ONE Post Office

On 30.11.2017 11:34, SMBCP wrote:
>
> Hi Massimo
> Thanks for your reply!
>
> We have 2 Post Office - Diverse and ProProhus. - Both are one same
> server on LAN 10.1.2.73.
>
> DIVERSE POA NETWORKS ADDRESS
> IPA: 10.1.2.73
> External: 87.116.31.134
> C/S port: 1681 for both
> SOAP port: 7193 for both
>
> PROPOSTHUS NETWORKS ADDRESS
> IPA: 10.1.2.73
> External: 87.116.31.133
> C/S port: 1677 for both
> SOAP port: 7191 for both
>
> Both external IPA are natted/port forwarded!


As I suspected, so webaccess talks to the external IP of one of the
POAs, finds a user is in the other POA; asks the POA it connects to
about IP/PORT of the other POA, and receives the 10.x.x.x. address,
which of course it can't connect to.

So much for the explanation.

Now the solution: Set the proper external proxy IP and port for the POAs
as described here:

https://www.novell.com/documentation/groupwise2014r2/gw2014_guide_admin/data/adm_poa_config_security.html


CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.