mdhilton Absent Member.
Absent Member.
1411 views

WebAccess URL Paramaters

Hello,

We have an internal website which opens up a WebAccess page, we pass the username and password in a url.

The url used to work but it doesn't anymore.

http://xxx.xxx.xxx.xxx/gw/webacc?action=User.Login&User.id={0}&User.password={1}&merge=webacc

Where {0} is the username and {1} is the password.

This used to take us straight into WebAccess, now we only get the WebAccess login screen.

Does anybody know if the syntax has changed in WebAccess 8?

Many thanks in advance.

Martin
Labels (2)
Tags (3)
0 Likes
5 Replies
Micro Focus Expert
Micro Focus Expert

Re: WebAccess URL Paramaters

I've tested your url against our 8.0.2 environment and all we got was a login page to webaccess - what version did this work on?

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
Knowledge Partner
Knowledge Partner

Re: WebAccess URL Paramaters

On 18/11/2012 20:16, laurabuckley wrote:

> I've tested your url against our 8.0.2 environment and all we got was a
> login page to webaccess - what version did this work on?


Since Martin (mdhilton) said "Does anybody know if the syntax has
changed in WebAccess 8?" I'm guessing not version 8 but something earlier.
--
Simon
Novell/SUSE/NetIQ Knowledge Partner

------------------------------------------------------------------------
Do you work with Novell technologies at a university, college or school?
If so, your campus could benefit from joining the Novell Technology
Transfer Partner (TTP) program. See novell.com/ttp for more details.
------------------------------------------------------------------------
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: WebAccess URL Paramaters

On 11/19/2012 5:44 AM, Simon Flood wrote:
> On 18/11/2012 20:16, laurabuckley wrote:
>
>> I've tested your url against our 8.0.2 environment and all we got was a
>> login page to webaccess - what version did this work on?

>
> Since Martin (mdhilton) said "Does anybody know if the syntax has
> changed in WebAccess 8?" I'm guessing not version 8 but something earlier.

No he's right. That used to workin GW 6/7, and there are TIDS on it.

This TID which indirectly discusses the breakage might have the workaround

http://www.novell.com/support/kb/doc.php?id=7007109

http://www.novell.com/documentation/developer/groupwise_sdk/gwsdk_gwwebacc/?page=/documentation/developer/groupwise_sdk/gwsdk_gwwebacc/data/a4exzbb.html

But implies you can now only do this for a specified set of ip addresses....
0 Likes
mdhilton Absent Member.
Absent Member.

Re: WebAccess URL Paramaters

All,

Thanks for your replies, yes it was 6.5 and possibly 7, we are not sure when it broke, just that it did break.

I will try this fix as in doc 7007109...

Resolution

Find the webacc.cfg for WebAccess application that runs on Tomcat, this file is located in /var/opt/novell/groupwise/webaccess. Set/enable the following line: Security.Authenticate.header.

I'll post back if it worked or not.

Regards

Martin
0 Likes
mdhilton Absent Member.
Absent Member.

Re: WebAccess URL Paramaters

UPDATE:

Tried altering the webacc.cfg but no change so far, however server not restarted so will try that next.

Regards

Martin
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.