Highlighted
Absent Member.
Absent Member.
2672 views

WebAccess and HTTPS

I had already installed the GroupWise Webaccess on a SLES 11 SP2 server and was able to access it via HTTPS. I have now installed the Calendar publisher on the same server but not the HTTP fails to load a login page stating connection was reset.

What could have gone wrong and how to do I check / correct it?

Thanks in advance,
Ken
Labels (1)
0 Likes
15 Replies
Highlighted
Absent Member.
Absent Member.

Re: WebAccess and HTTPS

I should also add that it does work using the standard HTTP just not with the secure port.

Sincerely,
Ken
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: WebAccess and HTTPS

kheinz;2340917 wrote:
I should also add that it does work using the standard HTTP just not with the secure port.

Sincerely,
Ken


Did you check the apache logs under /var/log/apache2/ , maybe some more info there?

Thomas
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: WebAccess and HTTPS

Thanks for the info, I was unsure where to look for the error. It says
Error 70014 End of File found: ajp_ilink_receive () can't receive header
Error: ajp_read_header: ajp_ilink_receieve failed
Error: 120006 APR does not understand this error code: proxy response failed from [::1] (localhost)

Ken
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: WebAccess and HTTPS

kheinz;2340991 wrote:
Thanks for the info, I was unsure where to look for the error. It says
Error 70014 End of File found: ajp_ilink_receive () can't receive header
Error: ajp_read_header: ajp_ilink_receieve failed
Error: 120006 APR does not understand this error code: proxy response failed from [::1] (localhost)

Ken


Okay and when you do "rcapache2 restart" does it show any error?

Thomas
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: WebAccess and HTTPS

No there isn't any error after restart but still no secure login.

[Tue Dec 02 07:57:39 2014] [notice] caught SIGTERM, shutting down
[Tue Dec 02 07:57:40 2014] [notice] Apache/2.2.12 (Linux/SUSE) PHP/5.2.14 with Suhosin-Patch configured -- resuming normal operations

Sincerely,
Ken
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: WebAccess and HTTPS

kheinz;2341001 wrote:
No there isn't any error after restart but still no secure login.

[Tue Dec 02 07:57:39 2014] [notice] caught SIGTERM, shutting down
[Tue Dec 02 07:57:40 2014] [notice] Apache/2.2.12 (Linux/SUSE) PHP/5.2.14 with Suhosin-Patch configured -- resuming normal operations

Sincerely,
Ken


Okay have you verified that proxy and proxy_ajp is enabled in /etc/sysconfig/apache2 ? See here: https://www.novell.com/support/kb/doc.php?id=7012914

Do you have both gw.conf and gwcal.conf under /etc/apache2/conf.d/ directory?

So http works for both webaccess and calendar but not https?

Thomas
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: WebAccess and HTTPS

I made sure I did what the TID asked
Also both of the conf files are under the specified directory

Also just checked to make sure that both the Webaccess and Calendar site are accessible through HTTP but neither one from HTTPS.

Sincerely,
Ken
0 Likes
Highlighted
Honored Contributor.
Honored Contributor.

Re: WebAccess and HTTPS

You stated the you could reach the Web access before adding the GWCal component.
If you just try to access the basic site securely (https://yoursite.whatever), does it work?

I don't know if this is applicable to your situation, but it's worth checking:

I ran into a somewhat similar situation, only I couldn't get the site to work via HTTPS in the first place.
I had added a vhost-ssl.conf file to the etc/apache2/vhosts.d folder, but got no secure access.

I compared the etc/sysconfig/apache2 file between a site with working secure access and one without.

In my case, there was a line in the file that read: APACHE_SERVER_FLAGS="" in the site that didn't work.
In the working site, the file read: APACHE_SERVER_FLAGS="SSL"
Once I changed it , I had secure access.
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: WebAccess and HTTPS

Thanks for the information. I checked my apache2 file it does have the SSL flag set.

Sincerely,
ken
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: WebAccess and HTTPS

kheinz;2341128 wrote:
Thanks for the information. I checked my apache2 file it does have the SSL flag set.

Sincerely,
ken


And what about the vhost-ssl.conf, have you also configured that, also check the listen.conf under /etc/apache2?

Does "netstat -plnt | grep 443" show that apache is listening on 443?

Thomas
0 Likes
Highlighted
Outstanding Contributor.
Outstanding Contributor.

Re: WebAccess and HTTPS

You haven't got the firewall blocking https access have you? I've frequently found servers where http port 80 has been allowed in but https has been forgotten.

M.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.