Anonymous_User Absent Member.
Absent Member.
4643 views

gwia cpu 98% permanent!

Hi!
i have just updated my second domain from gw7 sp3 to gw 8 sp1.
now the gwia on this sles10 sp2 server have permanently 98% cpu. top is showing the following

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
17223 root 16 0 64836 22m 10m S 95.4 1.5 223:06.92 gwia

installed and running on this server: mta gwia poa webaccess.

any ideas about the high cpu time?

thanks ahead
TS
Labels (2)
0 Likes
14 Replies
Anonymous_User Absent Member.
Absent Member.

Re: gwia cpu 98% permanent!

TiredSum wrote:
> Hi!
> i have just updated my second domain from gw7 sp3 to gw 8 sp1.
> now the gwia on this sles10 sp2 server have permanently 98% cpu. top is
> showing the following
>
> PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
> 17223 root 16 0 64836 22m 10m S 95.4 1.5 223:06.92 gwia
>
> installed and running on this server: mta gwia poa webaccess.
>
> any ideas about the high cpu time?
>
> thanks ahead
> TS
>

1. what does the verbose log show?
2. check the gwia queues.
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: gwia cpu 98% permanent!

Also, if you unload all agents besides GWIA does the CPU stay pegged at 98%? Just making sure this is only the GWIA causing the issue.
0 Likes
Anonymous_User Absent Member.
Absent Member.

Antw: Re: gwia cpu 98% permanent!

Hi!
this gwia currently has no work to do. (this gwia is going to be my big gwia for in/outgoing, but only if it is working well1)
so there are currently only some (2-3) imap/pop clients which are using this server.

1. what does the verbose log show?
nothing, or do you looking for something special?
2. check the gwia queues.
queues are empty.

one strange thing is, that using "rcgrpwise status" the gwia is "unused. all other agents on this server have the status running!
so I have tried to change the settings in gwha.conf from [GWIA.SecDom] to [SecDom.GWIA] but without success.

any ideas?
thanks ahead


>>> Michael Bell<mikebell90@no-mx.forums.novell.com> schrieb am Mittwoch, 09. September 2009 um 17:19 in Nachricht <hIPpm.8824$7G7.1976@kovat.provo.novell.com>:


TiredSum wrote:

> Hi!
> i have just updated my second domain from gw7 sp3 to gw 8 sp1.
> now the gwia on this sles10 sp2 server have permanently 98% cpu. top is
> showing the following
>
> PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
> 17223 root 16 0 64836 22m 10m S 95.4 1.5 223:06.92 gwia
>
> installed and running on this server: mta gwia poa webaccess.
>
> any ideas about the high cpu time?
>
> thanks ahead
> TS
>

1. what does the verbose log show?
2. check the gwia queues.
0 Likes
Anonymous_User Absent Member.
Absent Member.

Antw: Re: gwia cpu 98% permanent!

Hi!
yes, gwia stays at about 98%cpu no matter if there are other agents activ! (mta poa webacc - on this server)


thanks ahead
chris

>>> jgrubbs<jgrubbs@no-mx.forums.novell.com> schrieb am Donnerstag, 10. September 2009 um 02:16 in Nachricht <jgrubbs.3y9tsn@no-mx.forums.novell.com>:



Also, if you unload all agents besides GWIA does the CPU stay pegged at
98%? Just making sure this is only the GWIA causing the issue.


--
Jeff Grubbs
Novell Technical Support Engineer II
jgrubbs@novell.com
------------------------------------------------------------------------
jgrubbs's Profile: http://forums.novell.com/member.php?userid=41638
View this thread: http://forums.novell.com/showthread.php?t=385730
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Antw: Re: gwia cpu 98% permanent!

ts wrote:
> Hi!
> this gwia currently has no work to do. (this gwia is going to be my big
> gwia for in/outgoing, but only if it is working well1)
> so there are currently only some (2-3) imap/pop clients which are using
> this server.
>
> 1. what does the verbose log show?
> nothing, or do you looking for something special?
> 2. check the gwia queues.
> queues are empty.
>
> one strange thing is, that using "rcgrpwise status" the gwia is "unused.
> all other agents on this server have the status running!
> so I have tried to change the settings in gwha.conf from [GWIA.SecDom]
> to [SecDom.GWIA] but without success.
>
> any ideas?
> thanks ahead
>
> >>> Michael Bell<mikebell90@no-mx.forums.novell.com> schrieb am

> Mittwoch, 09. September 2009 um 17:19 in Nachricht
> <hIPpm.8824$7G7.1976@kovat.provo.novell.com>:
> TiredSum wrote:
> > Hi!
> > i have just updated my second domain from gw7 sp3 to gw 8 sp1.
> > now the gwia on this sles10 sp2 server have permanently 98% cpu. top is
> > showing the following
> >
> > PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
> > 17223 root 16 0 64836 22m 10m S 95.4 1.5 223:06.92 gwia
> >
> > installed and running on this server: mta gwia poa webaccess.
> >
> > any ideas about the high cpu time?
> >
> > thanks ahead
> > TS
> >

> 1. what does the verbose log show?
> 2. check the gwia queues.
>
>

run it manually from command line and with -show and see what you see?
reinstall it from scratch?

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: Antw: Re: gwia cpu 98% permanent!

Hi!
here is the startlog:

****** 09-11-09 07:47:39 ******
07:47:39 344 ******************* Agent Started *******************
07:47:39 344 MTP: Message Transfer Protocol initialization...
07:47:39 344 MTP: Queue initialization...
07:47:39 344 MTP: Queue initialization...
07:47:39 344 Startup: No frgnames.cfg file found.
07:47:39 344 HTTP server running
07:47:39 344 Startup: No route.cfg file found.
07:47:39 560 Starting GWHTTP-Listener
07:47:39 792 Starting GWHTTP-Handler_1
07:47:40 240 SMTP service running
07:47:40 688 Starting GWTCP-Dispatcher
07:47:40 304 Starting GWTCP-Monitor
07:47:40 920 Starting GWPOP-Listener
07:47:40 536 Starting GWIMAP-Listener
07:47:40 344 Begin Configuration Information
07:47:40 344 Platform= UNIX
07:47:40 344 Domain and Agent= Uni-remote.GWIA
07:47:40 344 Foreign Name= s14extra.mydomain.com gwx1.mydomain.com
07:47:40 344 Description= mydomain GWIA - mydomain-Remote
07:47:40 344 Alias Type= offmail
07:47:40 344 Root Directory= /var/gw/wpdomain/wpgate/gwia
07:47:40 344 Work Directory= /var/gw/wpdomain/wpgate/gwia/gwiawork
07:47:40 344 Log File= /var/log/gw/gwia/0911gwia.003
07:47:40 344 Directory ID= gwi154
07:47:40 344 Directory Synchronization= NO
07:47:40 344 Directory Exchange= NO
07:47:40 344 Accounting= YES
07:47:40 344 Convert GroupWise Status to Messages= NO
07:47:40 344 Outbound Status Level= UNDELIVERED
07:47:40 344 Log Level= Verbose
07:47:40 344 Log Max Age= 100 days
07:47:40 344 Log Max Space= 1048576 kb
07:47:40 344 Enable Recovery= YES
07:47:40 344 Retry Count= 10
07:47:40 344 Retry Interval= 60 seconds
07:47:40 344 Failed Recovery Wait= 3600 seconds
07:47:40 344 Network Reattach Command= <none specified>
07:47:40 344 Correlation DB Enabled= NO
07:47:40 344 Send/Receive Cycle= 4 minutes
07:47:40 344 Minimum Run= 0 minutes
07:47:40 344 Idle Sleep Duration= 0 seconds
07:47:40 344 Snap Shot Interval= 17 minutes
07:47:40 344 Time Zone= WET
07:47:40 344 GMT Offset= 1 hours, 0 minutes
07:47:40 344 Hemisphere= NORTH
07:47:40 344 Daylight Saving Change= 1 hours, 0 minutes
07:47:40 344 Daylight Saving Begin= 3/29 (month/day)
07:47:40 344 Daylight Saving End= 10/25 (month/day)
07:47:40 344 SNMP On
07:47:40 344 Startup Switches= --show --home /var/gw/wpdomain/wpgate
07:47:40 344 /gwia --dhome /var/gw/wpdomain/wpdate/gwia --attachms
07:47:40 344 g --smtp --ari-never --mudas 2 --imap4 --mime --ldap
07:47:40 344 --imapssl enabled --killthreads --xspam --flatfwd --k
07:47:40 344 eepsendgroups --dsn --dsnage 4 --st 50 --rt 150 --htt
07:47:40 344 p --defaultcharset UTF-8
07:47:40 344 End Configuration Information

there are not messages in/out or something else, because this server is not "public published" now. so there are only some "knowing" who are useing this server. but i can not make it productive until this high-cpu-thing is solved.
reinstall it from scratch? how - or just copy the gwia-agent-files again?

thanks ahead
chris

>>> Michael Bell<mikebell90@no-mx.forums.novell.com> schrieb am Freitag, 11. September 2009 um 07:38 in Nachricht <tnlqm.9333$7G7.6545@kovat.provo.novell.com>:


run it manually from command line and with -show and see what you see?
reinstall it from scratch?
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: gwia cpu 98% permanent!

I would honestly say this is one you ought to consider opening a service request with support on so we can really dig into what is happening. You could have triggered a defect. If you want to go ahead with the reinstall first that is fine. I would do it this way...
1. remove the gwia rpm
2. delete the gwia object in consoleone (make sure you record any unique settings first so that you can recreate them)
3. reinstall the gwia which re-creates the object and install rpm.

See if that makes any difference.
0 Likes
Anonymous_User Absent Member.
Absent Member.

Antw: gwia cpu 98% permanent!

Hi,

change the settings in gwha.conf from [GWIA.SecDom] to [gwia.secdom] all in
lower case!

Kill all running gwia processes and try again.

I guess there are many gwia processes running: ps ax | grep gwia


Walter




>>> TiredSum<tiredsum@gmx.at> schrieb am 09.09.2009 um 13:43 in Nachricht

<4AA7B140.C0EF.000F.0@gmx.at>:
> Hi!
> i have just updated my second domain from gw7 sp3 to gw 8 sp1.
> now the gwia on this sles10 sp2 server have permanently 98% cpu. top is
> showing the following
>
> PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
> 17223 root 16 0 64836 22m 10m S 95.4 1.5 223:06.92 gwia
>
> installed and running on this server: mta gwia poa webaccess.
>
> any ideas about the high cpu time?
>
> thanks ahead
> TS

0 Likes
Anonymous_User Absent Member.
Absent Member.

Antw: gwia cpu 98% permanent!

hi walter!

I think this works. with lowercase I can see gwia running using rcgrpwise status!
now I have to reinstall gwia ....

THANKS
chris


>>> Walter Hofstädtler<walter@nospam.hofstaedtler.com> schrieb am Samstag, 12. September 2009 um 18:05 in Nachricht <4AABE2CF.A7EA.00F7.0@nospam.hofstaedtler.com>:


Hi,

change the settings in gwha.conf from [GWIA.SecDom] to [gwia.secdom] all in
lower case!

Kill all running gwia processes and try again.

I guess there are many gwia processes running: ps ax | grep gwia


Walter
0 Likes
Anonymous_User Absent Member.
Absent Member.

Antw: Re: gwia cpu 98% permanent!

Hi!
I think I have solved my problem.
I changed the gwia/groupwise/gatewaytimesettings/ "Idle Sleep Duration" from 0 to 10.
with the setting of 10 my gwia has an "top" cpu-rating about 0.5 percent.

Thanks for your help
christian


>>> jgrubbs<jgrubbs@no-mx.forums.novell.com> schrieb am Samstag, 12. September 2009 um 03:16 in Nachricht <jgrubbs.3ydlwn@no-mx.forums.novell.com>:



I would honestly say this is one you ought to consider opening a service
request with support on so we can really dig into what is happening.
You could have triggered a defect. If you want to go ahead with the
reinstall first that is fine. I would do it this way...
1. remove the gwia rpm
2. delete the gwia object in consoleone (make sure you record any
unique settings first so that you can recreate them)
3. reinstall the gwia which re-creates the object and install rpm.

See if that makes any difference.


--
Jeff Grubbs
Novell Technical Support Engineer II
jgrubbs@novell.com
------------------------------------------------------------------------
jgrubbs's Profile: http://forums.novell.com/member.php?userid=41638
View this thread: http://forums.novell.com/showthread.php?t=385730
0 Likes
Anonymous_User Absent Member.
Absent Member.

Antw: gwia cpu 98% permanent!

Hi,

great to hear, all object names in lowercase fixes a lot of startup
problems.

Walter


>>> ts<tiredsum@gmx.at> schrieb am 17.09.2009 um 08:57 in Nachricht

<4AB1FA52.C0EF.000F.0@gmx.at>:
> hi walter!
>
> I think this works. with lowercase I can see gwia running using
> rcgrpwise status!
> now I have to reinstall gwia ....
>
> THANKS
> chris
>
>>>> Walter Hofstädtler<walter@nospam.hofstaedtler.com> schrieb am Samstag,

12.
> September 2009 um 18:05 in Nachricht
> <4AABE2CF.A7EA.00F7.0@nospam.hofstaedtler.com>:
>
> Hi,
>
> change the settings in gwha.conf from [GWIA.SecDom] to [gwia.secdom]
> all in
> lower case!
>
> Kill all running gwia processes and try again.
>
> I guess there are many gwia processes running: ps ax | grep gwia
>
>
> Walter

0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: gwia cpu 98% permanent!

Great resolution on that one! Sorry I disappeared from the conversation but I was out of the office for a few days. Anyway, it is nice to know that there are so many awesome people out there that know so much!
0 Likes
Anonymous_User Absent Member.
Absent Member.

Re: gwia cpu 98% permanent!

I had a very similar problem and after reversing [domain_mail.GWIA] to [GWIA.domain_mail] in gwha.conf the Internet Agent is show as running with rcgrpwise status.
0 Likes
jmpita74 Absent Member.
Absent Member.

Re: Antw: Re: gwia cpu 98% permanent!

Support | Troubleshooting GWIA High Utilization

This link, solve us our problem.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.