Highlighted
Outstanding Contributor.
Outstanding Contributor.
915 views

gwtmstmp 8209 error ONLY on Gnome Terminal

I've just migrated from Netware 6.5SP8 GW8.03HP3 to GW2012 SP2 running on SLES11SP3 with OES11SP2.

I'm trying to set up some backup scripts using dbcopy essentially the script that Willem has posted in other threads.
Now the first few times I ran it I was doing it via a remote putty session, but now I'm testing on the Gnome Terminal in the Console and getting the following error when it gets to the gwtmstmp command:

-- In Gnome
ford:/opt/novell/groupwise/agents/bin # /opt/novell/groupwise/agents/bin/gwtmstmp -s -p /media/nss/GWISE/grpw_po
Load of Resource File (/opt/novell/groupwise/agents/bin/../lib/gwtsaxuk.fil) failed - error - 8209 for lang 'uk'
Trying 'us' Resource File.
Load of Resource File (/opt/novell/groupwise/agents/bin/../lib/gwtsaxuk.fil) failed - error - 8209 for lang 'en'

-- In Putty
ford:/opt/novell/groupwise/agents/bin # /opt/novell/groupwise/agents/bin/gwtmstmp -s -p /media/nss/GWISE/grpw_po
Successfully set backup timestamp for all users on post office at /media/nss/GWISE/grpw_po

Why on earth would it start looking for the wrong Resource file in Gnome?
There is only one gwtsa file:
-rw-r--r-- 1 root root 121030 Mar 26 2013 /opt/novell/groupwise/agents/lib/gwtsaxen.fil
The real question is would cron have the same issue and not be able to run gwtmstmp successfully?

Mark.
Labels (2)
0 Likes
4 Replies
Highlighted
Knowledge Partner
Knowledge Partner

Re: gwtmstmp 8209 error ONLY on Gnome Terminal

In article <MarkDissington.6jjzrz@no-mx.forums.novell.com>,
MarkDissington wrote:
> I'm trying to set up some backup scripts using dbcopy essentially the
> script that Willem has posted in other threads.
> Now the first few times I ran it I was doing it via a remote putty
> session, but now I'm testing on the Gnome Terminal in the Console and
> getting the following error when it gets to the gwtmstmp command:
>


What user have you been running them as? Both the same? Root?

Perchance was the GW8 system multilingual, where as the 2012 system is
now just English? If so, a top down rebuild might be in order.
https://www.novell.com/support/kb/doc.php?id=3347260

One thought that would be worth trying, make a copy of gwtsaxen.fil as
gwtsaxuk.fil and see if that works.



Andy of
KonecnyConsulting.ca in Toronto
Knowledge Partner
http://forums.novell.com/member.php/75037-konecnya
If you find a post helpful and are logged in the Web interface, please
show your appreciation by clicking on the star below. Thanks!

___
“i’ve sworn an oath of solitude til the blight is purged from these lands”
Andy of Konecny Consulting in Toronto
Knowledge Partner Profile
If you find a post helpful, click the Like button below. Thanks!
0 Likes
Highlighted
Outstanding Contributor.
Outstanding Contributor.

Re: gwtmstmp 8209 error ONLY on Gnome Terminal

Hi Andy,

Yes, both consoles, Gnome and Putty via SSH we logged in as root.

I believe that the gw8 installation was multilingual and it does appear that the gw2012 install was from the english only tar file (an oversight on my part). We should be running multi-lingual as we have a Bulgarian Branch office, would it just be a case of upgrading over the top and re-copying the ofviews from the multilingual rpms but reinstate multilingual support?
I assume if we do that then the mystery error will also vanish.

I did try making a symbolic link to the existing file as gwtsaxuk.fil but that still returned the same error.

Thanks,
Mark.
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: gwtmstmp 8209 error ONLY on Gnome Terminal

In article <MarkDissington.6jrilz@no-mx.forums.novell.com>,
MarkDissington wrote:
> We should be running multi-lingual as we have a Bulgarian
> Branch office, would it just be a case of upgrading over the top and
> re-copying the ofviews from the multilingual rpms but reinstate
> multilingual support?

I believe so

> I assume if we do that then the mystery error will also vanish.

Fingers Xed

Did you also try a real copy (cp) to make gwtsaxuk.fil
I know should be the same as a symlink, but you never know.


Andy of
KonecnyConsulting.ca in Toronto
Knowledge Partner
http://forums.novell.com/member.php/75037-konecnya
If you find a post helpful and are logged in the Web interface, please
show your appreciation by clicking on the star below. Thanks!

___
“i’ve sworn an oath of solitude til the blight is purged from these lands”
Andy of Konecny Consulting in Toronto
Knowledge Partner Profile
If you find a post helpful, click the Like button below. Thanks!
0 Likes
Highlighted
Outstanding Contributor.
Outstanding Contributor.

Re: gwtmstmp 8209 error ONLY on Gnome Terminal

konecnya;2331966 wrote:
In article <MarkDissington.6jrilz@no-mx.forums.novell.com>,
MarkDissington wrote:
> We should be running multi-lingual as we have a Bulgarian
> Branch office, would it just be a case of upgrading over the top and
> re-copying the ofviews from the multilingual rpms but reinstate
> multilingual support?

I believe so

> I assume if we do that then the mystery error will also vanish.

Fingers Xed

Did you also try a real copy (cp) to make gwtsaxuk.fil
I know should be the same as a symlink, but you never know.


Andy of
KonecnyConsulting.ca in Toronto
Knowledge Partner
http://forums.novell.com/member.php/75037-konecnya
If you find a post helpful and are logged in the Web interface, please
show your appreciation by clicking on the star below. Thanks!


Just a quick update.

Finally got round to installing the multilingual rpms using "rpm -Uvh --force ........" to get them to overwritten the same version number english-only rpms, then restarted all the agents, but this still didn't resolve the issue. All of the user interfaces are now correclty multilingual (you can pick from about 20 languages in the advanced section of WebAccess).
Went into ConsoleOne, properties of the domain, the language drop down was also fully populated, changed it to another language, it rebuilt the domain db languages, then changed it back to English UK, it rebuilt the domain db languages again - tried gwtmstmp still the same error.
Checked in /opt/novell/groupwise/agents/lib - still only gwtsaxen.fil present as a gwtsaXXX file, lots of other language files prefixed gwmonx/gwmtax/gwpoax are present, but only the single gwtsa file - do the others even exist?

So, the solution (workaround) we put in please. Now we have the multilingual rpms installed symbolic links almost work properly. I added links to gwtsaxen.fil from both gwtsaxuk.fil and gwtsaxus.fil, for some reason the uk one is still ignored and reports an error, but the us one appears to be followed OK now.

Not clean, not nice and I'm sure I'm missing something somewhere, but it appears to have at least partially resolved the error.

M
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.