Absent Member.
Absent Member.
2320 views

inet messages with attachments can't be fetched w/IMAP ssl

Problem discovered using NotifyLink, but repeatable using Outlook Express - email coming from internet with attachments cannot be fetched using IMAP over SSL. Switched to regular IMAP, and problem goes away. NotifyLink gives error 371, Outlook Express says:

Outlook Express could not download the requested message. It is likely that the message was removed or expired from the server. A message could not be downloaded from the IMAP server. Subject 'test message', Account: 'servername', Server: 'servername', Protocol: IMAP, Server Response: 'UID FETCH (8209)', Port: 993, Secure(SSL): Yes, Error Number: 0x800CCCD2

Running IMAP on GWIA on W2008, recently upgraded to GW 2012. (Could the self-signed cert created with the GWCSRGEN utility be at play here?)

Alternatively, tried to switch to non-SSL by changing SSL from "Required" to "Enabled", but server still responding "NO LOGIN Connection must be encrypted" despite toggling settings and restarting GWIA. The docs say "If SSL is "Enabled", and the client can perform SSL, SSL will be used." But it would seem that "Not required/Enabled" would allow non-SSL connections if requested over port 143, no?
Labels (2)
0 Likes
8 Replies
Highlighted
Absent Member.
Absent Member.

Re: inet messages with attachments can't be fetched w/IMAP s

The solution to the second part of this is that the gwia.cfg was over-riding settings from ConsoleOne. Now able to connect over non-SSL IMAP.
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: inet messages with attachments can't be fetched w/IMAP s

Guess I'll have to amend this - "switched to regular IMAP on POA [vs IMAP on GWIA], and problem goes away." Switching to regular IMAP on GWIA acts the same, messages from internet with attachments can't be picked up by IMAP client. Apparently SSL is not involved.
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: inet messages with attachments can't be fetched w/IMAP ssl

On 04.08.2012 00:46, ksorensen wrote:
>
> Guess I'll have to amend this - "switched to regular IMAP on POA [vs
> IMAP on GWIA], and problem goes away." Switching to regular IMAP on GWIA
> acts the same, messages from internet with attachments can't be picked
> up by IMAP client. Apparently SSL is not involved.
>
>

This rather sounds like a general TCP communication issue, possibly
involving a paranoid firewall setup. Most likely a MTU / ICMP filtering
problem.

CU,
--
Massimo Rosen
Novell Knowledge Partner
No emails please!
http://www.cfc-it.de
CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: inet messages with attachments can't be fetched w/IMAP s

Thanks, Massimo, but no go - tried less restrictive firewalls, then none at all, no change. Aside from checking the MTU (everyone's at 1500), and pinging to be sure ICMP works, I think I've exhausted every option. Well, except Wireshark...
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: inet messages with attachments can't be fetched w/IMAP ssl

On 06.08.2012 21:06, ksorensen wrote:
>
> Thanks, Massimo, but no go - tried less restrictive firewalls, then none
> at all, no change. Aside from checking the MTU (everyone's at 1500), and
> pinging to be sure ICMP works, I think I've exhausted every option.
> Well, except Wireshark...
>
>


Quite frankly, in cases like these, wireshark shouldn't be the last, but
one of the first options of debugging. 😉

CU,
--
Massimo Rosen
Novell Knowledge Partner
No emails please!
http://www.cfc-it.de
CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: inet messages with attachments can't be fetched w/IMAP s

Funny, I could hear Laura Chappell saying that as I typed it. Unfortunately, all I could see was a bunch of FETCHing and PEEKing, nothing that looked like an IMAP error.
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: inet messages with attachments can't be fetched w/IMAP ssl

On 07.08.2012 15:26, ksorensen wrote:
>
> Funny, I could hear Laura Chappell saying that as I typed it.
> Unfortunately, all I could see was a bunch of FETCHing and PEEKing,
> nothing that looked like an IMAP error.
>
>

I wuldn't expect to see a glaring error in this case. I would search for
communications that simply drop.

CU,
--
Massimo Rosen
Novell Knowledge Partner
No emails please!
http://www.cfc-it.de
CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: inet messages with attachments can't be fetched w/IMAP ssl

ksorensen wrote:

> Now able to connect over non-SSL IMAP.


Good - because I was going to say that as a Mac user, I use IMAP all of the time
via SSL, and have no attachment issues.

--
Danita
Novell Knowledge Partner
Upgrading to GroupWise 2012? http://www.caledonia.net/blog/?p=514
http://www.caledonia.net/gw12upg.html
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.