Highlighted
Absent Member.
Absent Member.
1215 views

"Role" Resource Type not found

Referencing TID 7012806, https://www.novell.com/support/kb/doc.php?id=7012806 , I verified our installation is on GW2012 SP2 12.0.2-108211 but we are not seeing "Role" as an option for a Resource Type. Please advise what we can do to make the Role Resource Type available on our system.

Thank you,
Ronnie
Labels (2)
0 Likes
8 Replies
Highlighted
Micro Focus Expert
Micro Focus Expert

Hi Ronnie,

Perhaps your eDirectory schema has not been sufficiently extended.

In ConsoleOne, select a tree to check.

Click Tools > GroupWise Utilities > Check eDirectory Schema.

If the eDirectory tree has not yet been extended for GroupWise, the eDirectory Schema Extension dialog box lists the changes that are required for GroupWise.

Click Yes to extend the schema for GroupWise so that you can create GroupWise objects in the selected tree.

Let us know how it goes.

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

On 13.01.2014 20:46, sarnor wrote:
>
> Referencing TID 7012806,
> https://www.novell.com/support/kb/doc.php?id=7012806 , I verified our
> installation is on GW2012 SP2 12.0.2-108211 but we are not seeing "Role"
> as an option for a Resource Type. Please advise what we can do to make
> the Role Resource Type available on our system.


In addition to what Laura said, also ceck that the ConsoleOne snapins
you use are current.

CU,
--
Massimo Rosen
Novell Knowledge Partner
No emails please!
http://www.cfc-it.de
CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
0 Likes
Highlighted
Absent Member.
Absent Member.

Thank you for the reply, Laura. I ran the eDirectory schema check and I got a "The eDirectory schema for the selected tree has been properly modified for use with Groupwise." As Massimo indicated in his response (thank you Massimo), I checked the C1 snap in for GW Administration and noticed it indicated for version 2012 SP1. I copied the snap-ins again from the GW2012 SP2 install zip file to my C1 folder and when I run C1, it continues to display Ver 2012 SP1. So I am not sure if I have the right version of snap ins, and if this is causing the schema not to extend properly. Please advise.

Thank you,
Ronnie
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

On 14.01.2014 15:06, sarnor wrote:
>
> Thank you for the reply, Laura. I ran the eDirectory schema check and I
> got a "The eDirectory schema for the selected tree has been properly
> modified for use with Groupwise." As Massimo indicated in his response
> (thank you Massimo), I checked the C1 snap in for GW Administration and
> noticed it indicated for version 2012 SP1. I copied the snap-ins again
> from the GW2012 SP2 install zip file to my C1 folder and when I run C1,
> it continues to display Ver 2012 SP1. So I am not sure if I have the
> right version of snap ins, and if this is causing the schema not to
> extend properly. Please advise.


Unfortunately, the SP2 snapins still display as SP1 in ConsoleOne, yet
they are different. If you copied them, you should be fine in that
regard, but unfortunately that was my only idea for now.. 😞

CU,
--
Massimo Rosen
Novell Knowledge Partner
No emails please!
http://www.cfc-it.de
CU,
--
Massimo Rosen
Micro Focus Knowledge Partner
No emails please!
http://www.cfc-it.de
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Hi Ronnie,

Just to ensure that we are all on the same page here.... In ConsoleOne, if you right-click on a Resource and go to Properties | GroupWise Tab | Identification - third option from the bottom is a drop-down list for Resource Type - this is the option that you are not seeing?

Let us know - thanks 🙂

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert



Hi, Please see attached image 🙂

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
Highlighted
Absent Member.
Absent Member.

Hi Laura,

Yes, that is what I am talking about. I entered a post yesterday in response to Massimo's post but apparently it did not get posted/saved. Anyway, I responded to Massimo yesterday that after he confirmed that the snap-in for GW2012 SP2 also displays SP1, I went ahead and checked the resource account that I needed to change the resource type and the drop down now displays "Role" as an option! So it looks like updating the C1 snap-ins to SP2 fixed the issue. Thank you both for your help in getting this issue resolved here.

Thanks,
Ronnie
0 Likes
Highlighted
Micro Focus Expert
Micro Focus Expert

Hi Ronnie,

So glad that you got it sorted 🙂 Thanks for letting us know.

Cheers,
Laura Buckley

Views/comments expressed here are entirely my own.
If you find this post helpful, please show your appreciation and click on "Like" below...
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.