Big news! The community will be moving to a new platform April 21. Read more.
Big news! The community will be moving to a new platform April 21. Read more.
Commander
Commander
993 views

User creation problem through Delimited driver in IDM 4.8

Jump to solution

Hy Team,

i am trying to create the user by the use of delimited driver. when i put the .csv file in the input path , only the first user in input file is created in ID vault although i put the multiple user value but the driver will check only the 1 st row value .it dont check the other values.i put the unique association value for each unique user.

 

1 Solution

Accepted Solutions
Commodore
Commodore

Theres a known bug and please update to the latest release of dtf driver: https://download.microfocus.com/Download?buildid=ElZdWZtt61c~

I had the same issue


Regards,

Philipp


--
https://www.lanworks.de

View solution in original post

7 Replies
Knowledge Partner Knowledge Partner
Knowledge Partner

As always, show us some trace.

I.e. Is it only processing the first line in the file?  What happens when it gets to the second line?  No event?

(Are your carriage returns right?  dos2unix/unix2dos tools as needed?)

Commander
Commander

Hlo team,

when driver Scanning for input file ,it takes only the 1st user data of the input file then after again it will scan the input file. i attached the both input and log file . 

Knowledge Partner Knowledge Partner
Knowledge Partner

I cannot tell from the file nor the log.  What platform is the Delim Text driver running on?  Windows or Linux?

What are the line endings you saved the text file with?

If on Linux, try dos2unix on the file. Or a text editor that can save with Linux line endings.

Commander
Commander

Delimited driver running on SUSE linux server 12 sp3  . i converted the input file from DOS to unix (by dos2unix) and i also tried with Text editor but in both cases still the driver only took the 1 st user data only .

Knowledge Partner Knowledge Partner
Knowledge Partner

Try changing the line endings with unix2dos.  🙂  I.e. Reverse it and check.

This is usually not an issue.  I.e. It successfully reads all the lines, no config needed.

Perhaps check the file encoding and set it appropriately in the driver config setting?  (special characters usually are the issue there, not reading teh second line.)

 

Try more than 2 lines like 5, to ensure it is not just the one line problem. Alas, experiment.

Commodore
Commodore

Theres a known bug and please update to the latest release of dtf driver: https://download.microfocus.com/Download?buildid=ElZdWZtt61c~

I had the same issue


Regards,

Philipp


--
https://www.lanworks.de

View solution in original post

Knowledge Partner Knowledge Partner
Knowledge Partner

Awesome, good to know.  I assume it is this bug referenced in the Readme on the patch:

 

Bug 1158617 - The Delimited Text driver is successfully processing the input XML file in the publisher channel.

 

Love it, does not say it is about multiline files. And the bugs linked suggest XML only, but I guess there was overlap in the bug and the fix.

Thanks for letting us know on this one!

The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.