UPDATE! The community will be go into read-only on April 19, 8am Pacific in preparation for migration on April 21. Read more.
UPDATE! The community will be go into read-only on April 19, 8am Pacific in preparation for migration on April 21.Read more.
Commodore
Commodore
213 views

upgrade to 3.6.2 where can I get postgresql 11.10.0?

Hello,

When upgrading IG from 3.6.1 to 3.6.2 on SLES 12sp4

The documentation states that I should run the versions.sh file.

It detects old versions and states which software versions I need to upgrade to

With regard to postgresql, it states

Where is your PostgreSQL bin located? [/opt/netiq/idm/apps/postgres/bin]:
  Expected PostgreSQL version 11.10.0, but instead found the older 10.5

I have seached quite a bit for a tar.gz version of that postgresql release, but have been unable to locate it.

Does anyone know where I can find it?

If not, can I do something else?

 

0 Likes
5 Replies
Micro Focus Expert
Micro Focus Expert

Greetings,
   Please review the System Requirements again, as we state: "or later patched versions of 11.x"  The current 11.x version via the PostgreSQL channel is: 11.11  
 
 
  Since you are Linux, you will need to install PostgreSQL via the PostgreSQL channel and not from the channel of your Linux Server (SLES or RHEL).  This is outlined in the documentation as well as in the "Installing-PostgreSQL.txt" located in the Linux Helper Install Script.  We provide examples for SLES and RHEL in the above text file.  If you are on RHEL, the PostgreSQL site has step by step instructions for there once you select the version of RHEL.
  
 
 
Sincerely,
Steven Williams
Principal Enterprise Architect
Micro Focus
0 Likes
Micro Focus Expert
Micro Focus Expert

Greetings,
    Please be aware that your ID Gov 3.6.1 set-up was not in a supported configuration. We have required PostgreSQL 11.x starting with ID Gov 3.6.0.  Starting with version 11.0 of PostgreSQL, they stopped creating a Linux installer and require installing it via their channel.  They do make a Windows installer, but for Linux one must install it via their channel.  
It is surprising that your ID Gov 3.6.1 set-up was working "correctly" considering you were utilizing PostgreSQL 10.x
 
 
Sincerely,
Steven Williams
Principal Enterprise Architect
Micro Focus
0 Likes
Micro Focus Expert
Micro Focus Expert

Greetings,
    Please be aware that your ID Gov 3.6.1 set-up was not in a supported configuration in another way, the Operating System. With ID Gov 3.6.0 we stopped supporting SLES 12.x and RHEL 7.x.  Please review the System Requirements before continuing.  Here is the list of Operating Systems that are required for ID Gov 3.6.2 (which was the same for 3.6.1):
 
Red Hat Enterprise Linux 8.0 (64-bit) or later patched versions of 8.x
 
SUSE Linux Enterprise Server 15.1 or later patched version of 15.x
 
Microsoft Windows Server 2016 (64-bit) or later patched version of Windows Server 2016
 
Microsoft Windows Server 2019 or later patched versions of Windows Server 2019
 
 
Sincerely,
Steven Williams
Principal Enterprise Architect
Micro Focus
0 Likes
Commodore
Commodore

Thanks for the reply.

If my memory doesnt fail (and that happens).

When the system was originally installed (ig 3.5 or so), there was a similar procedure, where we had to download the binary tgz file, and place it somewhere for the installer to pick it up.

That means, that we are in a situation where the postgresql placed in /opt/netiq/idm/apps/postgres/bin is 10.5

BUT the system itself reports a lot of postgresql versions

# rpm -qa|grep postgres
postgresql-server-13-1.1.noarch
postgresql12-server-12.4-19.1.x86_64
postgresql13-13.0-1.1.x86_64
postgresql-13-1.1.noarch
postgresql11-11.9-28.1.x86_64
postgresql12-12.4-19.1.x86_64
postgresql13-server-13.0-1.1.x86_64
postgresql11-server-11.9-28.1.x86_64

The server however seems to run postgresql 11

# ps aux |grep postgres

postgres 1525 0.0 0.3 238892 23096 ? S 10:29 0:00 /usr/lib/postgresql11/bin/postgres -D /opt/netiq/idm/apps/postgres/data

 

So the question here is, what can I do about this mess?

0 Likes
Commodore
Commodore

Answering myself.

That probably means that I should

upgrade to a supported os

Point the versions.sh to the correct postgresql binary folder for the versions check

(that must be /usr/lib/postgresql11/bin/postgres)

The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.