Highlighted
aortizmicrofocus Absent Member.
Absent Member.
891 views

Language in notification mails

Hi

I´m currently testing with revisions and when a revision starts the system sends a mail to the reviewer. Until here all is fine, but I need that the language of the mail will be spanish, so I changed the preferred language of the system in the configutil.sh tool to ES also in the identity exists an attributes called preferredLanguage and preferredLocale and both have ES as value. But the mail content is still in english. What more I have to change to see the content of the mail in spanish???

Thanks in advance.
Tags (3)
0 Likes
6 Replies
jmontm42 Absent Member.
Absent Member.

Re: Language in notification mails

aortizmicrofocus;2465537 wrote:
What more I have to change to see the content of the mail in spanish???


There is a line in the User Guide - "When Identity Governance sends an email, the application queries the preferred language of the
target user. If Identity Governance supports that language, the email is delivered in the preferred
language. Otherwise, the emails use the default language for the system. You can customize the
content in the emails."

However, I have not seen any way to set the preferred language of the user. There is a default user attribute for preferredLocale. You might try setting that attribute on a user and then sending a notification to see if it sends the right template. I'd try a value like 'es' first.

--Jim
0 Likes
Micro Focus Expert
Micro Focus Expert

Re: Language in notification mails

On 9/6/17 5:24 PM, jmontm42 wrote:
>
> aortizmicrofocus;2465537 Wrote:
>> What more I have to change to see the content of the mail in spanish???

>
> There is a line in the User Guide - "When Identity Governance sends an
> email, the application queries the preferred language of the
> target user. If Identity Governance supports that language, the email is
> delivered in the preferred
> language. Otherwise, the emails use the default language for the system.
> You can customize the
> content in the emails."
>
> However, I have not seen any way to set the preferred language of the
> user. There is a default user attribute for preferredLocale. You might
> try setting that attribute on a user and then sending a notification to
> see if it sends the right template. I'd try a value like 'es' first.
>
> --Jim
>
>

Greetings,
The notification works based upon the Preferred Locale attribute on
the user. I tested with Spanish (actual value of es -> lowercase) and
all worked correctly for me for that user.



--
Sincerely,
Steven Williams
Principal Enterprise Architect
Micro Focus
0 Likes
aortizmicrofocus Absent Member.
Absent Member.

Re: Language in notification mails

You´re right. It works perfectly.

Thanks!
0 Likes
aortizmicrofocus Absent Member.
Absent Member.

Re: Language in notification mails

Hi

Thanks in advance for your help. Now, I need to customize the content of the notification. I downloaded the notification template (EmailTemplates.xml file) and I change it and upload it. It appears a message that says "Email templates have been updated", I did several tests and my changes doesn´t appear in the notification. Even I restart the tomcat and still same. Do I have to do some other procedure to update the changes in the content of the notification template? What can be caused this?

Any help would be appreciated.
0 Likes
dbuschke Trusted Contributor.
Trusted Contributor.

Re: Language in notification mails

Hi,
I think there was a notice in the documentation which says "Don't change the filename". But I cannot check because I have currently no access to the documentation (permission denied, whatever this means).

Have you changed the filename?

regards
Daniel

EDIT: Access via Internet Explorer is denied, Firefox works. The line is still present: https://www.netiq.com/documentation/access-review-25/access-review-user/data/b19vqvxo.html

NOTE:If prompted, do not rename the EmailTemplates.xml file. Identity Governance cannot upload a file that does not match the expected name.
0 Likes
aortizmicrofocus Absent Member.
Absent Member.

Re: Language in notification mails

Hi

I actually did not change the filename but I had a syntax error in the xml body. I found the error in the catalina.out log, it isn´t very clear but It mention the line and the column with the problem, so I fixed it and it works.

Thanks!!!
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.