Absent Member.
Absent Member.
963 views

4.7.0.1 stops registering changes

Been getting this a bit and its irritatingly painful!

While working away, Designer suddenly stops registering changes. That is, any changes does not reflect with the "save" buttons becoming available. Behavior after that can be either of the following:



  • Closing the project it does NOT prompt to save and closes successfully. A restart of Designer and ALL changes since it stopped registering are lost.
  • Closing the project it prompts to save changes. Click Yes and it sits there and fails to close Designer. Click No and it will close the project, but all changes lost.


So, result in either case is work is lost. This is unbearable especially when changes can't be deployed when they relate to User App (other thread), so can't even deploy and recover from the Vault after restart.

When you're busy working away, making a stack of changes and not noticing the save button failure (simply because you shouldn't HAVE to worry), there can be a significant amount of work lost.

Visit my Website for links to Cool Solution articles.
Labels (1)
0 Likes
8 Replies
Highlighted
Absent Member.
Absent Member.

Re: 4.7.0.1 stops registering changes

I think this log entry is related:

!MESSAGE Unhandled event loop exception!STACK 0
java.lang.StackOverflowError


It came about after a:

Exception while dispatching event org.osgi.service.event.Event [topic=org/eclipse/e4/ui/model/ui/ElementContainer/selectedElement/SET] to handler org.eclipse.e4.ui.services.internal.events.UIEventHandler@2e0ff1c0


But I don't see that particular error again, even though I did strike the "no save" issue a few times....


Visit my Website for links to Cool Solution articles.
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: 4.7.0.1 stops registering changes

ScorpionSting wrote:

> While working away, Designer suddenly stops registering changes. That
> is, any changes does not reflect with the "save" buttons becoming
> available.


A colleague mentioned something similar as well, but when we tried to
reproduce, all worked as expected. I'm pretty sure it was 4.7.0 or even some
4.6.* version, though. Anyone else?

--
http://www.is4it.de/en/solution/identity-access-management/

(If you find this post helpful, please click on the star below.)
______________________________________________
https://www.is4it.de/identity-access-management
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: 4.7.0.1 stops registering changes

Yes, forcing replication of the issue isn't easy.... 😞

Visit my Website for links to Cool Solution articles.
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: 4.7.0.1 stops registering changes

ScorpionSting wrote:

> Designer suddenly stops registering changes


Btw. what OS platform and Java version do you see this with?

--
http://www.is4it.de/en/solution/identity-access-management/

(If you find this post helpful, please click on the star below.)
______________________________________________
https://www.is4it.de/identity-access-management
0 Likes
Highlighted
Absent Member.
Absent Member.

Re: 4.7.0.1 stops registering changes

I've seen it now on both openSUSE 42.3 and Windows 10....

jre is 1.8.0_162

Visit my Website for links to Cool Solution articles.
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: 4.7.0.1 stops registering changes

I had the similar situation with my Designer.
All changes for the project was lost.

After computer reboot issue "fixed".
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: 4.7.0.1 stops registering changes

My OS is Windows 7
0 Likes
Highlighted
Knowledge Partner
Knowledge Partner

Re: 4.7.0.1 stops registering changes

On 05/23/2018 03:04 PM, al b wrote:
>
> My OS is Windows 7


That explains why you would need to reboot your entire computer to fix an
application problem, I guess.

--
Good luck.

If you find this post helpful and are logged into the web interface,
show your appreciation and click on the star below.

If you want to send me a private message, please let me know in the
forum as I do not use the web interface often.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.