Knowledge Partner
Knowledge Partner
546 views

(-9963) An error occurred reading the attribute 0x000003cd: failed,no such value (-602)

I've already searched and seen this thread
http://forums.novell.com/showthread.php?t=333424

However we don't have two driversets in the same tree so I don't think
that this is the problem:

Environment:

1 tree / driverset / two servers

eDir 8.8.6 patch 5 (win 2k3 32bit) + IDM 3.6.1 engine patch 4b
eDir 8.8.6 patch 5 /win 2k8r2 64bit) + IDM 4.0.1 engine patch 2

This is a migrate scenario and we are moving drivers one by one from
3.6.1 to run on 4.0.1 server (not using the migrate function in
Designer). The 3.6.1 server will be decommissioned once the migration is
complete.

The error occurs on a single driver DN that had been previously deployed
when it is first started on the IDM 4.0.1. It doesn't re-occur if the
driver is restarted again.

In addition we have seen more than once (but not at any predictable
interval) the same error has appeared consecutively for ALL drivers in
the driver set (inlcuding drivers which are still running on the 3.6.1
server)

Any suggestions as to what is causing this and how to troubleshoot this
further? We hadn't seen these errors on the IDM 3.6.1 server prior to
adding the 4.0.1 server to the driverset via iManager.
Alex McHugh - Knowledge Partner - Stavanger, Norway
Who are the Knowledge Partners
If you appreciate my comments, please click the Like button.
If I have resolved your issue, please click the Accept as Solution button.
Labels (1)
0 Likes
2 Replies
Knowledge Partner
Knowledge Partner

Re: (-9963) An error occurred reading the attribute 0x000003cd: failed,no such value (-602)

On 18.04.2012 08:11, Alex McHugh wrote:
> I've already searched and seen this thread
> http://forums.novell.com/showthread.php?t=333424
>
> However we don't have two driversets in the same tree so I don't think
> that this is the problem:
>
> Environment:
>
> 1 tree / driverset / two servers
>
> eDir 8.8.6 patch 5 (win 2k3 32bit) + IDM 3.6.1 engine patch 4b
> eDir 8.8.6 patch 5 /win 2k8r2 64bit) + IDM 4.0.1 engine patch 2
>
> This is a migrate scenario and we are moving drivers one by one from
> 3.6.1 to run on 4.0.1 server (not using the migrate function in
> Designer). The 3.6.1 server will be decommissioned once the migration is
> complete.
>
> The error occurs on a single driver DN that had been previously deployed
> when it is first started on the IDM 4.0.1. It doesn't re-occur if the
> driver is restarted again.
>
> In addition we have seen more than once (but not at any predictable
> interval) the same error has appeared consecutively for ALL drivers in
> the driver set (inlcuding drivers which are still running on the 3.6.1
> server)
>
> Any suggestions as to what is causing this and how to troubleshoot this
> further? We hadn't seen these errors on the IDM 3.6.1 server prior to
> adding the 4.0.1 server to the driverset via iManager.


No responses yet, but can replicate this:

1. Create/deploy/start via Designer 4.0.1 AU2 an empty (no policies)
generic null driver on the 3.6.1 server (with a designer project that
doesn't include the new server)
2. switch to a designer project that includes the new server and simply
live import the generic null driver from IDV.
3. 4.0.1 server references Driver DN in error

[04/19/2012 21:25:56.799]
DirXML Log Event -------------------
Driver: \IDV\ACME\Services\IDM\DriverSet\Generic Null
Status: Error
Message: (-9963) An error occurred reading the attribute
0x000003cd: failed, no such value (-602).
[04/19/2012 21:26:04.909] ENG ET:Processing DirXML sub-verb
DSVR_DISCOVER_JOBS
[04/19/2012 21:26:05.752] ENG ET:Processing DirXML sub-verb
DSVR_GET_CHUNKED_RESULT
[04/19/2012 21:26:05.768] ENG ET:Processing DirXML sub-verb
DSVR_GET_CHUNKED_RESULT
[04/19/2012 21:26:05.768] ENG ET:Processing DirXML sub-verb
DSVR_GET_CHUNKED_RESULT
[04/19/2012 21:26:05.799] ENG ET:Processing DirXML sub-verb
DSVR_GET_CHUNKED_RESULT
[04/19/2012 21:26:05.815] ENG ET:Processing DirXML sub-verb
DSVR_CLOSE_CHUNKED_RESULT
[04/19/2012 21:26:06.440]
DirXML Log Event -------------------
Driver: \IDV\ACME\Services\IDM\DriverSet\Generic Null
Status: Error
Message: (-9963) An error occurred reading the attribute
0x000003cd: failed, no such value (-602).


4. 3.6.1 server doesn't mention any DN but shows another error
[04/19/2012 21:26:04.471]
DirXML Log Event -------------------
Status: Error
Message: (-9956) DirXMLVerbHandler::construct: An error occurred
while constructing an object: failed, invalid request (-641).
[04/19/2012 21:26:04.596] ENG ET:Processing DirXML sub-verb
DSVR_DISCOVER_JOBS
[04/19/2012 21:26:05.174] ENG ET:Processing DirXML sub-verb
DSVR_GET_CHUNKED_RESULT
[04/19/2012 21:26:05.189] ENG ET:Processing DirXML sub-verb
DSVR_GET_CHUNKED_RESULT
[04/19/2012 21:26:05.221] ENG ET:Processing DirXML sub-verb
DSVR_GET_CHUNKED_RESULT
[04/19/2012 21:26:05.236] ENG ET:Processing DirXML sub-verb
DSVR_GET_CHUNKED_RESULT
[04/19/2012 21:26:05.267] ENG ET:Processing DirXML sub-verb
DSVR_CLOSE_CHUNKED_RESULT
[04/19/2012 21:26:06.783]
DirXML Log Event -------------------
Status: Error
Message: (-9956) DirXMLVerbHandler::construct: An error occurred
while constructing an object: failed, invalid request (-641).
[04/19/2012 21:26:07.205]
DirXML Log Event -------------------
Status: Error
Message: (-9956) DirXMLVerbHandler::construct: An error occurred
while constructing an object: failed, invalid request (-641).

---

Can anyone explain why this may occur? Is this something that can be
ignored?
Alex McHugh - Knowledge Partner - Stavanger, Norway
Who are the Knowledge Partners
If you appreciate my comments, please click the Like button.
If I have resolved your issue, please click the Accept as Solution button.
0 Likes
Knowledge Partner
Knowledge Partner

Re: (-9963) An error occurred reading the attribute 0x000003cd: failed,no such value (-602)

On 19.04.2012 21:39, Alex McHugh wrote:
> On 18.04.2012 08:11, Alex McHugh wrote:
>> Any suggestions as to what is causing this and how to troubleshoot this
>> further? We hadn't seen these errors on the IDM 3.6.1 server prior to
>> adding the 4.0.1 server to the driverset via iManager.

>
> No responses yet, but can replicate this:

....
> Can anyone explain why this may occur? Is this something that can be
> ignored?


Actually digging a bit deeper, I think it may be related to querying for
driver information/status.

If I open iManager 2.7.4 patch 4 on new (4.0.1) server navigate to "
Driver Set Overview", then switch to view the old (3.6.1) server, then
this generates a similar error for each driver in the driver set. If I
click on "refresh" the same errors are generated again.

"(-9956) DirXMLVerbHandler::construct: An error occurred while
constructing an object: failed, invalid request (-641)"

I don't get the same kind of error when trying the reverse (iManager on
3.6.1 server viewing driver set overview of 4.0.1 server)

Any ideas. Are these errors cosmetic or is there something underlying
that is wrong?
Alex McHugh - Knowledge Partner - Stavanger, Norway
Who are the Knowledge Partners
If you appreciate my comments, please click the Like button.
If I have resolved your issue, please click the Accept as Solution button.
0 Likes
The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.