Welcome Serena Central users! CLICK HERE
The migration of the Serena Central community is currently underway. Be sure to read THIS MESSAGE to get your new login set up to access your account.
tschloesser Super Contributor.
Super Contributor.
140 views

Designer 4.7.2 and MacOS 10.15

Jump to solution

Designer 4.7.2 or newer cannot be run under the current version of MacOS 10.15, released last week!

When starting Designer versions starting 4.7.2 under MacOS 10.15 a couple of security warnings/errors are coming up, but even by "allowing" all this exceptions Designer cannot run as expected. Even some editors (i.e. filter, data mapping, etc.) are not working and closing Designer is not possible.

According to support MacOS 10.15 is not supported and possibly will not even be supported by Designer 4.8!

Strange thing is, that Designer 4.7.1.x is working as designed - so I did some digging and found, the layout of the embedded JRE is different starting with Designer 4.7.2.x.

You can see this, if you show the contents of /Applications/Designer!

On my Mac I have two Designer instances installed, 4.7.3 and 4.7.1.1 - I changed the -vm parameter in the designer.ini of the 4.7.3 instance to the full path of the JRE shipping with Designer 4.7.1.1 and now I can start, work and close the curren version of Designer as planed!

JAVA is a strange thing!

Maybe you find this work-around useful. So far I did not run into any problems using the current Designer with the older JRE!

 

Kind regards,

 

Thorsten

 

 

 

 

Labels (1)
Tags (1)
1 Solution

Accepted Solutions
tschloesser Super Contributor.
Super Contributor.

Re: Designer 4.7.2 and MacOS 10.15

Jump to solution

I did some more digging and testing and found a work-around which will not depend on two instances of designer installed at the end.

This is what I did:

I installed Designer 4.7 in a different directory and patched it up to 4.7.1.1.

In the Designer 4.7.3 Directory I renamed the ../jre folder (just to have the chance to get back) to jre.bak

I copied the whole jre Folder from the Desiger 4.7.1.1 instance to the Designer 4.7.3 folder.

In the designer 4.7.3 folder will be the Designer application at the same level as the copied jre folder. Right-click on that application and select show contents. 

Bildschirmfoto 2019-10-17 um 08.24.56.pngIn the package contents you can find Designer.ini. Open this file and replace the lines 

#-vm
#../../../jre/lib/server/libjvm.dylib

with the following code

-vm
../../../jre/Contents/Home/lib/server/libjvm.dylib

Now you are save to delete the temporary installation of Designer 4.7.1.1 and start Designer 4.7.3.

For me this is working so far, I hope M.F. will release an official hot-fix soon.

BTW: Please "like" this post if you find it useful 😉

 

Kind regards,

 

Thorsten

2 Replies
ericveysey Trusted Contributor.
Trusted Contributor.

Re: Designer 4.7.2 and MacOS 10.15

Jump to solution

Thanks for the tip! I'm running into the same issues, I haven't had a chance to to look into if further. I've been allowing the files in Security, it was getting annoying. 

0 Likes
tschloesser Super Contributor.
Super Contributor.

Re: Designer 4.7.2 and MacOS 10.15

Jump to solution

I did some more digging and testing and found a work-around which will not depend on two instances of designer installed at the end.

This is what I did:

I installed Designer 4.7 in a different directory and patched it up to 4.7.1.1.

In the Designer 4.7.3 Directory I renamed the ../jre folder (just to have the chance to get back) to jre.bak

I copied the whole jre Folder from the Desiger 4.7.1.1 instance to the Designer 4.7.3 folder.

In the designer 4.7.3 folder will be the Designer application at the same level as the copied jre folder. Right-click on that application and select show contents. 

Bildschirmfoto 2019-10-17 um 08.24.56.pngIn the package contents you can find Designer.ini. Open this file and replace the lines 

#-vm
#../../../jre/lib/server/libjvm.dylib

with the following code

-vm
../../../jre/Contents/Home/lib/server/libjvm.dylib

Now you are save to delete the temporary installation of Designer 4.7.1.1 and start Designer 4.7.3.

For me this is working so far, I hope M.F. will release an official hot-fix soon.

BTW: Please "like" this post if you find it useful 😉

 

Kind regards,

 

Thorsten

The opinions expressed above are the personal opinions of the authors, not of Micro Focus. By using this site, you accept the Terms of Use and Rules of Participation. Certain versions of content ("Material") accessible here may contain branding from Hewlett-Packard Company (now HP Inc.) and Hewlett Packard Enterprise Company. As of September 1, 2017, the Material is now offered by Micro Focus, a separately owned and operated company. Any reference to the HP and Hewlett Packard Enterprise/HPE marks is historical in nature, and the HP and Hewlett Packard Enterprise/HPE marks are the property of their respective owners.